Xfinity plant
Xfinity globe
Community Forum

cable tv connection goes off and on after upgrade

Regular Visitor

cable tv connection goes off and on after upgrade

I paid to have a service call to upgrade my cable TV boxes to X1.  Two of the connected TV's work fine.  They are in the bedrooms.  The one in the living room goes on and off constantly as if the signal is interrupted.  I have replaced the coaxial cables with new ones and checked all the connections to be sure they are tight.  This worked fine before the upgrade.  I also have internet from the same line with a splitter and that is working fine.  I can't travel and need some help.  I tried the Support that refreshes and also the one that resets the cable and it didn't help.  Will I have to pay again for home service?  Comcast should stand behind their products.  Any suggestions?


Accepted Solutions
Official Employee

Re: cable tv connection goes off and on after upgrade

Hello patm3333. I can assist in troubleshooting your X1 service issues. I can also help get a repair tech visit scheduled as needed. Please send me a private message and include your full name and account primary phone number so I can assist you. 


All Replies
Official Employee

Re: cable tv connection goes off and on after upgrade

Hello patm3333. I can assist in troubleshooting your X1 service issues. I can also help get a repair tech visit scheduled as needed. Please send me a private message and include your full name and account primary phone number so I can assist you. 

Regular Visitor

Re: cable tv connection goes off and on after upgrade

Thank you for your response.  I am not certain how to send a private message.  Please advise.

Official Employee

Re: cable tv connection goes off and on after upgrade

To send me a private message click my name (ComcastJoeTru) and click Private Message Me.