Xfinity plant
Xfinity globe
Community Forum

Xg1v4 static and black screen when watching 4k

Regular Visitor

Xg1v4 static and black screen when watching 4k

Just got my XG1v4 and when I go to Netflix and try to watch any 4K content the screen flips back and forth from a black screen to a static screen. Unplugging and plugging back in the hdmi fixes the problem. I have a high quality 2.0 4K hdmi cable that works fine when playing 4K movies on my 4K player.

Edit: it isn’t just 4K content. It actually happens if I am scrolling Netflix and a preview/trailer plays and goes to the full screen it blacks out. As long as the preview plays while the list of shows is still up no problem but when it automatically goes full screen I lose my picture.
Expert

Re: Xg1v4 static and black screen when watching 4k

Problem Solver

Re: Xg1v4 static and black screen when watching 4k


@Undxrtaker wrote:
Just got my XG1v4 and when I go to Netflix and try to watch any 4K content the screen flips back and forth from a black screen to a static screen. Unplugging and plugging back in the hdmi fixes the problem. I have a high quality 2.0 4K hdmi cable that works fine when playing 4K movies on my 4K player.

Edit: it isn’t just 4K content. It actually happens if I am scrolling Netflix and a preview/trailer plays and goes to the full screen it blacks out. As long as the preview plays while the list of shows is still up no problem but when it automatically goes full screen I lose my picture.

I don't know if you got your problem solved yet, but you need a high quality 2.2 4K capable HDMI cable to work with Comcast 4K DVR.

Expert

Re: Xg1v4 static and black screen when watching 4k


@MNtundraRET wrote:

@Undxrtaker wrote:
Just got my XG1v4 and when I go to Netflix and try to watch any 4K content the screen flips back and forth from a black screen to a static screen. Unplugging and plugging back in the hdmi fixes the problem. I have a high quality 2.0 4K hdmi cable that works fine when playing 4K movies on my 4K player.

Edit: it isn’t just 4K content. It actually happens if I am scrolling Netflix and a preview/trailer plays and goes to the full screen it blacks out. As long as the preview plays while the list of shows is still up no problem but when it automatically goes full screen I lose my picture.

I don't know if you got your problem solved yet, but you need a high quality 2.2 4K capable HDMI cable to work with Comcast 4K DVR.


Sometimes it is the TV's HDMI port that is the issue.  The HDMI cable that came with my 4k DVR works with my Vizio 4K TV.

 

Official Employee

Re: Xg1v4 static and black screen when watching 4k


@Undxrtaker wrote:
Just got my XG1v4 and when I go to Netflix and try to watch any 4K content the screen flips back and forth from a black screen to a static screen. Unplugging and plugging back in the hdmi fixes the problem. I have a high quality 2.0 4K hdmi cable that works fine when playing 4K movies on my 4K player.

Edit: it isn’t just 4K content. It actually happens if I am scrolling Netflix and a preview/trailer plays and goes to the full screen it blacks out. As long as the preview plays while the list of shows is still up no problem but when it automatically goes full screen I lose my picture.

Did you go in and change the Video display of the dvr? 720p is the default.

Are you using your tv’s 4K HDMI port?

Regular Visitor

Re: Xg1v4 static and black screen when watching 4k

I have changed the resolution to 4K and all of my hdmi cables are monster platinum black cables so not the issue there.

It has also been doing it when watching YouTube. After I unplug and replug the hdmi to the Comcast box it will play but I have to do that every time I turn on YouTube.