Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,874,318

members

1,457

online

29,139

topics

Top

Xfinity XG1v4 Black Screen Lock Up

New Poster

Xfinity XG1v4 Black Screen Lock Up

Hi all, a couple weeks ago I upgraded my box to the XG1v4 so I could watch some of the Olympics in 4k.  On occasion, when I turn the TV on, it's just a black screen, no buttons work, just frozen black screen.  I have to unplug and replug the box in for it to work.  Doesn't happen all the time.  I got it to happen less by turning on HDMI control but it's very frustrating.  My setup is XG1v4 --> Yamaha Reciever --> Samsung 4k TV, all brand new and up to spec HDMI cables.  I "think" it might be a handshake issue but it only gets fixed by a hard reset.  Any help or insight would be greatly appreciated.  Please note, I already switched the box out once so I'm fairly certain it's not a hardware issue with the box.  Thanks!

Official Employee

Re: Xfinity XG1v4 Black Screen Lock Up


wrote:

Hi all, a couple weeks ago I upgraded my box to the XG1v4 so I could watch some of the Olympics in 4k.  On occasion, when I turn the TV on, it's just a black screen, no buttons work, just frozen black screen.  I have to unplug and replug the box in for it to work.  Doesn't happen all the time.  I got it to happen less by turning on HDMI control but it's very frustrating.  My setup is XG1v4 --> Yamaha Reciever --> Samsung 4k TV, all brand new and up to spec HDMI cables.  I "think" it might be a handshake issue but it only gets fixed by a hard reset.  Any help or insight would be greatly appreciated.  Please note, I already switched the box out once so I'm fairly certain it's not a hardware issue with the box.  Thanks!


Bypass the Yamaha and see if the issue replicates. Possibly make sure the power saver is off


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Frequent Visitor

Re: Xfinity XG1v4 Black Screen Lock Up

I am having this exact same issue, however my XG1v4 is connected directly to my Sony 4K TV.  It seems like it only happens when the TV is off for an extended period of time, like overnight and when I get home from work (like 15 hrs).  I get sound but just a black screen.  I have to pull the power on the XG1v4 and reconect it then everything works perfectly.  I even tried to turn off Power Saver Mode just to make sure that was not doing something weird, no luck.

 

Any ideas?

 

Thanks,

Mike

Service Expert

Re: Xfinity XG1v4 Black Screen Lock Up


@MichaelAP wrote:

I am having this exact same issue, however my XG1v4 is connected directly to my Sony 4K TV.  It seems like it only happens when the TV is off for an extended period of time, like overnight and when I get home from work (like 15 hrs).  I get sound but just a black screen.  I have to pull the power on the XG1v4 and reconect it then everything works perfectly.  I even tried to turn off Power Saver Mode just to make sure that was not doing something weird, no luck.

 

Any ideas?

 

Thanks,

Mike


did you verify that comcast labs hdmi link is off?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Frequent Visitor

Re: Xfinity XG1v4 Black Screen Lock Up

I am 99% sure I did (it was set to off) but I will confirm when I get home later today.  What does that option do?

Frequent Visitor

Re: Xfinity XG1v4 Black Screen Lock Up


@Rustyben wrote:

@MichaelAP wrote:

I am having this exact same issue, however my XG1v4 is connected directly to my Sony 4K TV.  It seems like it only happens when the TV is off for an extended period of time, like overnight and when I get home from work (like 15 hrs).  I get sound but just a black screen.  I have to pull the power on the XG1v4 and reconect it then everything works perfectly.  I even tried to turn off Power Saver Mode just to make sure that was not doing something weird, no luck.

 

Any ideas?

 

Thanks,

Mike


did you verify that comcast labs hdmi link is off?


I did verify that HDMI Link was set to Off.  The only change I have made so far is to turn off Power Saver Mode.

Service Expert

Re: Xfinity XG1v4 Black Screen Lock Up


@MichaelAP wrote:

@Rustyben wrote:

@MichaelAP wrote:

I am having this exact same issue, however my XG1v4 is connected directly to my Sony 4K TV.  It seems like it only happens when the TV is off for an extended period of time, like overnight and when I get home from work (like 15 hrs).  I get sound but just a black screen.  I have to pull the power on the XG1v4 and reconect it then everything works perfectly.  I even tried to turn off Power Saver Mode just to make sure that was not doing something weird, no luck.

 

Any ideas?

 

Thanks,

Mike


did you verify that comcast labs hdmi link is off?


I did verify that HDMI Link was set to Off.  The only change I have made so far is to turn off Power Saver Mode.


sounds good let us know if all is well.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Frequent Visitor

Re: Xfinity XG1v4 Black Screen Lock Up


@Rustyben wrote:

@MichaelAP wrote:

@Rustyben wrote:

@MichaelAP wrote:

I am having this exact same issue, however my XG1v4 is connected directly to my Sony 4K TV.  It seems like it only happens when the TV is off for an extended period of time, like overnight and when I get home from work (like 15 hrs).  I get sound but just a black screen.  I have to pull the power on the XG1v4 and reconect it then everything works perfectly.  I even tried to turn off Power Saver Mode just to make sure that was not doing something weird, no luck.

 

Any ideas?

 

Thanks,

Mike


did you verify that comcast labs hdmi link is off?


I did verify that HDMI Link was set to Off.  The only change I have made so far is to turn off Power Saver Mode.


sounds good let us know if all is well.


OK so this weekend the TV was on quite a bet without any issues.  Today when I came home from work (TV was off for about 16 hrs) and turned it on I got the blank screen but had sound.  I was able to change channels from the remote and the screen did kinda appear.  It was flickering but I could at least see it.  I tried to change resolution and still had horrible picture.  I finally rebooted it and now I have a perfect picture.  So it seems like if the TV is off for a long period of time this happens.  Any other ideas?

Problem Solver

Re: Xfinity XG1v4 Black Screen Lock Up


@MichaelAP wrote:

@Rustyben wrote:

@MichaelAP wrote:

@Rustyben wrote:

@MichaelAP wrote:

I am having this exact same issue, however my XG1v4 is connected directly to my Sony 4K TV.  It seems like it only happens when the TV is off for an extended period of time, like overnight and when I get home from work (like 15 hrs).  I get sound but just a black screen.  I have to pull the power on the XG1v4 and reconect it then everything works perfectly.  I even tried to turn off Power Saver Mode just to make sure that was not doing something weird, no luck.

 

Any ideas?

 

Thanks,

Mike


did you verify that comcast labs hdmi link is off?


I did verify that HDMI Link was set to Off.  The only change I have made so far is to turn off Power Saver Mode.


sounds good let us know if all is well.


OK so this weekend the TV was on quite a bet without any issues.  Today when I came home from work (TV was off for about 16 hrs) and turned it on I got the blank screen but had sound.  I was able to change channels from the remote and the screen did kinda appear.  It was flickering but I could at least see it.  I tried to change resolution and still had horrible picture.  I finally rebooted it and now I have a perfect picture.  So it seems like if the TV is off for a long period of time this happens.  Any other ideas?


Have you used the Samsung TV remote to check for updates for your Samsung TV?

Frequent Visitor

Re: Xfinity XG1v4 Black Screen Lock Up


@MNtundraRET

Have you used the Samsung TV remote to check for updates for your Samsung TV?

Good idea, I have a Sony TV and I did just check to make sure the software was  up to date.  It was.

 

Thanks for the idea.

Special Events
FIFA World Cup 2018 on Xfinity See More
Discussion stats
  • 9 replies
  • 749 views
  • 0 kudos
  • 5 in conversation