Xfinity plant
Xfinity globe
Community Forum

XR5 remote wont pair

Frequent Visitor

XR5 remote wont pair

For some reason, the XR5 remote will not pair with the X1 set-top box. I want to set it up so the remote is directly connected to the box so I can control the box without having to point the remote at it. Every time I try to set it up, the set up light flashes red and green and the option to type in the pair number never shows on the screen. Can this be fixed? 


Accepted Solutions
Contributor

Re: XR5 remote wont pair

Yeah, those of us with Arris boxes look like we are stuck until 2.0 is approved for our devices.

All Replies
Official Employee

Re: XR5 remote wont pair

Are you referring to the smaller box ( RNG 150 ), they don't get paired with the remote and you need one of these
http://forums.comcast.com/t5/X1/XR8-Adaptors/td-p/2470728
Frequent Visitor

Re: XR5 remote wont pair

No. I know it doesn't pair with the smaller boxes. This one won't pair with the X1 HD DVR box for some reason. 

Expert

Re: XR5 remote wont pair

How does it behave when you try to pair?  What happens at each step?

Contributor

Re: XR5 remote wont pair

Sounds like another user with the RF pairing issue...
Frequent Visitor

Re: XR5 remote wont pair

I hold the setup button until the light turns green, then I press the Xfinity button and the light flashes green and red for a moment. Nothing else happens. When I had my last X1 HD DVR with the XR2 remote, I was easily able to set it up. I had to downgrade my cable for a while so this is a new box,  and it came with the XR5 remote. I like the XR5 remote better. Is there some setting in the box that needs to be turned on? 

Contributor

Re: XR5 remote wont pair

Do me a favor...go to settings, about, and tell me what it says for remote battery level.
Frequent Visitor

Re: XR5 remote wont pair

I checked the battery level and it said 5%. I have now changed the batteries to fresh new ones just before I made this post and it still says 5%. How does it know what the battery level is and how do I update/refresh that information so it recognizes the new batteries? I just got these batteries from the store today so I know they are fully charged. 

Expert

Re: XR5 remote wont pair


Wesley_wg wrote:

I checked the battery level and it said 5%. I have now changed the batteries to fresh new ones just before I made this post and it still says 5%. How does it know what the battery level is and how do I update/refresh that information so it recognizes the new batteries? I just got these batteries from the store today so I know they are fully charged. 


I did a test, removed RF pairing, (setup 987) and checked battery says 'unknown'. The battery level as originally told to us was available only when RF paired. If remote is RF paired when you press channel up/down or the xFinity button the remotes's power button at the top will 'glow' green. If IR is being used same button presses will be red. what color(s) are you seeing with keypresses of those buttons? (flashes red? green? green/red sequence?)

Contributor

Re: XR5 remote wont pair

Wes, this seems to be a symptom of the the RF pairing issue. The 5% battery life is obviously inaccurate (mine shows the same 5% even though I have swapped batteries) and I think its like the pairing is jammed up somewhere. I did the 987 unpair which allowed the remote to communicate using IR, but the same as you, I can't re-pair the remote in RF mode. This is likely a software issue that will hopefully corrected. Can any Comcast rep chime in?

Expert

Re: XR5 remote wont pair


TN_3 wrote:

Wes, this seems to be a symptom of the the RF pairing issue. The 5% battery life is obviously inaccurate (mine shows the same 5% even though I have swapped batteries) and I think its like the pairing is jammed up somewhere. I did the 987 unpair which allowed the remote to communicate using IR, but the same as you, I can't re-pair the remote in RF mode. This is likely a software issue that will hopefully corrected. Can any Comcast rep chime in?


funny you bring that up. To answer the previous question I unpaired my remote and could not repair it (on 1.49.04 and f/w 1.3.4). I put a problem report on the inability to pair on another thread and overnight they updated my Pace DVRs to f/w 2 which fixed the problem. My sympton is that with f/w 1.3.4 and 1.49.04 version the process of pressing setup on the remote triggered the help menu. After the f/w update the pairing worked properly. In the answer the comcast person said that the f/w 2.0 is currently only ready for the pace set top boxes the arris is still in process.

Frequent Visitor

Re: XR5 remote wont pair

Okay, thanks for the help and information! It looks like my software is on version 1.49.04 (XRE Server Version) and 1.3.4 (Receiver). Hopefully version 2 is sent out to everyone soon. Neither of the XR5 remotes I have are paired with the box even though the box acts as if there is a remote paired to it. When I push the buttons mentioned earlier, the light is red so they are in IR mode. Since it looks like a software issue, I'll just have to wait for the update. I appreciate the help with troubleshooting. 

Contributor

Re: XR5 remote wont pair

Yeah, those of us with Arris boxes look like we are stuck until 2.0 is approved for our devices.
Frequent Visitor

Re: XR5 remote wont pair

The 2.0 update that I got today fixed my pairing problem and made the whole thing run smoother. 

Expert

Re: XR5 remote wont pair


TN_3 wrote:
Yeah, those of us with Arris boxes look like we are stuck until 2.0 is approved for our devices.

Arris boxes are now approved for 2.0.0.

Expert
Moved:

The XR5 Remote stopped controlling the cable box