Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,873,390

members

776

online

28,951

topics

Top

X1 Voice Remote - Voice part doesn't work well

ANSWERED
Frequent Visitor

X1 Voice Remote - Voice part doesn't work well

So I just got the X1 Voice Remote yesterday (7/30/15). Beautiful remote btw. It comes with a setup guide which I followed word for word (that's important for people to understand, I literally did the setup instructions to the letter) .... the remote works great....except the voice command part of it, you know the whole main feature of the remote -- doesn't work with much reliability. 

 

At initial setup voice commands worked perfectly for a good 20 minutes..... then it stopped working. In frustration I powered off my entire X1 cable box...waited a minute or two and powered it back on. The voice commands worked again until I went to bed. This morning before I went to work voice command worked (I only gave one command this morning). Tonight I'm trying it out again...voice command is not working again. 

 

During this whole time it should be noted -- ALL other aspects of the remote works perfectly....plus it controls my tv on/off and volume perfectly as well as that for my receiver. The only thing that seems sketchy is the voice feature.....To be honest the voice command is more a gimmick feature to me than anything...but it does annoy me that its not working. I mean the thing is BRAND NEW.

Accepted Solution

Re: X1 Voice Remote - Voice part doesn't work well

I appreciate everyones fast reply....honestly I never had a reply that fast on any tech related forum...impressive.

 

I fixed the issue myself about an hour after I made my post. 

 

The problem btw was that it wasn't recognizing ANY voice AT ALL.

 

What seemed to fix the problem was one or all of these....

 

I restarted the X1, took the batteries out of the voice remote for about 30 seconds...put them back in, waited for X1 to complete restart...then I re-ran setup on the voice remote again (I had previously done this) ....after all that it seems to be working now...and it was working the whole rest of last night just fine.

 

 

View answer in context
Frequent Visitor

XR11 Voice commands bring up wrong channel or do nothing

When I try something like "Watch Discovery Channel" the onscreen display shows that it recogniced what I said.  But then switches to the wrong channel.   Some channel change requests like "Watch ESPN" or "Watch NBC" do not change the channel at all.

 

 

Gold Problem Solver

Re: XR11 Voice commands bring up wrong channel or do nothing

I doubt the XR11 is that smart. However if you give it channels numbers such as "watch 202" it works fine. At least mine does.


Anon1573450 wrote:

When I try something like "Watch Discovery Channel" the onscreen display shows that it recogniced what I said.  But then switches to the wrong channel.   Some channel change requests like "Watch ESPN" or "Watch NBC" do not change the channel at all.

 

 


 

Frequent Visitor

Re: XR11 Voice commands bring up wrong channel or do nothing

It is supposed to be that smart.  And I even saw it work in the store.  The rep said "Watch ESPN" and it changed the channel to espn, without explicitly telling it the channel number.  Comcast even has this type of feature listed for the remote.   What boggles me is the it does kinda work sometimes, it just goes to the wrong channel.  

Official Employee

Re: XR11 Voice commands bring up wrong channel or do nothing


Anon1573450 wrote:

When I try something like "Watch Discovery Channel" the onscreen display shows that it recogniced what I said.  But then switches to the wrong channel.   Some channel change requests like "Watch ESPN" or "Watch NBC" do not change the channel at all.

 

 



Hi,

 

My apologies for the issues you've been seeing. The X1 Voice Remote should indeed allow you to tune to channels by saying things like "Watch Discovery Channel", and it should tune to the proper channel.

 

I can take a look into this for you, do you have an approximate time/date that this last occurred that I can start from? If you want to share any other details, feel free to send me a private message.

 

Thanks,

 

-Nick


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Gold Problem Solver

Re: XR11 Voice commands bring up wrong channel or do nothing

I must admit, it has been quite a while since I have tried voice command on my XR11. I tried saying channel names vs. channel numbers and it worked just fine. With most channels but not all.

However, it occured to me the mic in the XR11 could be responding to background noise including the TVs (or audio systems) own volume level.

Maybe you could pay attention to the sound levels in the background and see what happens...


Anon1573450 wrote:

It is supposed to be that smart.  And I even saw it work in the store.  The rep said "Watch ESPN" and it changed the channel to espn, without explicitly telling it the channel number.  Comcast even has this type of feature listed for the remote.   What boggles me is the it does kinda work sometimes, it just goes to the wrong channel.  




 

Official Employee

Re: XR11 Voice commands bring up wrong channel or do nothing

Just as an update, I've already forwarded your information over to the Voice Remote engineering team. This issue is something we've also heard from others, and we have an investigation ongoing. Will let you know as soon as I hear more information.
RickGr4 is also correct in saying that background levels could be affecting accuracy, so just ensure that there's nothing interfering Smiley Happy
Thanks!
-Nick

Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Frequent Visitor

Re: XR11 Voice commands bring up wrong channel or do nothing

Thanks for forwarding this on.  Background levels were low to none when I was testing.  And I could see on the TV that it understood what I said. 

Frequent Visitor

Re: XR11 Voice commands bring up wrong channel or do nothing

I just had my X1 system installed yesterday.  So i would say that this was happening from 4PM MDT onward.   I have not tested at all today, but will try again tonight when I get home.

 

Thanks

Chris

Official Employee

Re: XR11 Voice commands bring up wrong channel or do nothing


Anon1573450 wrote:

I just had my X1 system installed yesterday.  So i would say that this was happening from 4PM MDT onward.   I have not tested at all today, but will try again tonight when I get home.

 

Thanks

Chris


Thank you for taking the time to provide the extra details. I'll keep you posted on any updates that I hear back.


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Frequent Visitor

Re: XR11 Voice commands bring up wrong channel or do nothing

It seems to be fixed now for me.  When I first got home (around 3pm) it did not work.  But as of just after 5pm it is now working perfectly.  

 

This is a great feature.

Official Employee

Re: XR11 Voice commands bring up wrong channel or do nothing


Anon1573450 wrote:

It seems to be fixed now for me.  When I first got home (around 3pm) it did not work.  But as of just after 5pm it is now working perfectly.  

 

This is a great feature.


Glad to hear it's working now. The team hasn't applied any fix to your account, but we have heard from others with the same issue that it does automatically clear itself around 24 hours after installation. Seems to be the same case for you. We will continue to investigate the root cause.

 

Please feel free to reach out if you have any other issues, and thanks for your time.

 

-Nick


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Frequent Visitor

I have a new voice remote not taking voice commands

I have a new voice remote and it was working fine but has stopped taking voice commands I have paired it a second time and it did not help. When you hold down the button it comes up on the TV with the mic. but does not seam to hear the command. I am not sure if it is something like the mic is muted or even if that is possible.

New Poster

Re: I have a new voice remote not taking voice commands

i just got the new x1 system with remote yesterday and had it working fine and mine has stopped working today as well. i was on hold with Comcast customer service over 30 minutes for them to say a service tech will call me later. still waiting......
New Poster

Re: I have a new voice remote not taking voice commands

Same here.  I've had it for a few days and was working GREAT.  Now - same thing.  It "listens" and then does nothing.  I have rebooted the box as well as factory reset and re-paired the remote.  

 

Based on your same issues i would guess that maybe the third party company that processes these voice commands is having issues(??)

New Poster

Re: I have a new voice remote not taking voice commands

Yeah, that's the only thing I can think of. When I hold the button I hear the audio beep and it says "listening" on the screen but after the command it just disappears and nothing happens. Everything else on the remote work fine
New Poster

Re: I have a new voice remote not taking voice commands

That is exactly what happens with mine.  I'll update back if any changes or improvments.  

 

I have to say - I was really impressed with how well it worked (when it did).  Very cool tech!

 

New Poster

Re: I have a new voice remote not taking voice commands

Same here... really love it... but all it does it listen and then does not follow my commands... I already have this type of tech... its called my dogs.... 

 

But I digress... 

 

Comcast!!!! get this fixed.... I cannot live without this, its too darn great!!!

New Poster

Re: I have a new voice remote not taking voice commands

Having the same issue with the remote, worked great and then quit. I'll check back to this post and see if we get any resolve.


mahst68 wrote:

Same here... really love it... but all it does it listen and then does not follow my commands... I already have this type of tech... its called my dogs.... 

 

But I digress... 

 

Comcast!!!! get this fixed.... I cannot live without this, its too darn great!!!


 

Gold Problem Solver

Re: I have a new voice remote not taking voice commands

Anyone try UNPLUGGING and rebooting their X1 DVR??? Take the batteries out of the remote???

When you change channels using the XR11 does the light flash red or green? If it flashes red it is NOT paired anymore.

 

New Poster

Re: I have a new voice remote not taking voice commands


RickGr4 wrote:

Anyone try UNPLUGGING and rebooting their X1 DVR??? Take the batteries out of the remote???

When you change channels using the XR11 does the light flash red or green? If it flashes red it is NOT paired anymore.

 


Yup - I did all of the above.  Twice.  The only time the remote flashes red is after I try a voice command.  Every other function is 100%.

Gold Problem Solver

Re: I have a new voice remote not taking voice commands

I decided to try my XR11. You guys are correct. It's not working with my Arris DVR.

I was at a friends house yesterday morning who had just gotten X1. Comcast set her up with a V3 Pace and an XR11. The tech left without pairing the remote. Once I paired the remote and box, voice control worked fine. So at least in the case of the V3 Pace, voice control was working as of 11am yesterday...

New Poster

Re: I have a new voice remote not taking voice commands

Mine was certainly working yesterday.  Just notice that it stopped sometime this morning.  :-(

Gold Problem Solver

Re: I have a new voice remote not taking voice commands

Knowing Comcast I would not expect this to be fixed on a Sunday. Maybe it's just a server down somewhere out on Comcastland...

New Poster

Re: I have a new voice remote not taking voice commands

looks like we all are having the same issue. i use voice command all the time including this morning. not working now. sounds like a problem from comcast or their third party. i will check it later tonight

Frequent Visitor

Re: I have a new voice remote not taking voice commands

In readying on the web I think they are using a 3rd party for the voice translation so the 3rd party may be down. It can not be a quirk that all of us are having the problem at the same time without it being on comcast's end.... I only had it for 2 days to play with it but man I love that remote  

New Poster

Re: I have a new voice remote not taking voice commands

I feel better seeing I'm not the only one with this problem it appears to be a server issue on their side I'm sure it will be fixed soon enough. I thought I had broken my remote when I dropped it
Problem Solver

Re: I have a new voice remote not taking voice commands

Yup. V3 Pace and XR11, worked great yesterday, nothing today. Seems to be a common occurrence as well, as this is not the first thread where there is a consensus that the service is down. Somewhat disappointing that these features aren't stable yet.
Problem Solver

Re: I have a new voice remote not taking voice commands

Update.. It's working now here in Indy.

However, can anyone explain why.. a certain inappropriate phrase.. always tunes to Hallmark channel? It seems very very strange.

Service Expert

Re: I have a new voice remote not taking voice commands

Be sure to keep the blue button pressed the whole time you are speaking.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Problem Solver

Re: I have a new voice remote not taking voice commands


RobertWy wrote:

Be sure to keep the blue button pressed the whole time you are speaking.


The problem wasn't this, it's that you would let go after speaking, the "Listening" would go away and nothing happened.

Service Expert

Re: I have a new voice remote not taking voice commands

I read in another thread that the "xfinity X1 Remote" app was having the same problem, so I'm guessing it's a system-wide issue of some kind.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Problem Solver

Re: I have a new voice remote not taking voice commands


RobertWy wrote:

I read in another thread that the "xfinity X1 Remote" app was having the same problem, so I'm guessing it's a system-wide issue of some kind.


Yes, hopefully it is resolved for good now and doesn't happen again.

New Poster

Re: I have a new voice remote not taking voice commands

Looks like ours is working again (Detroit area).  :-)

Frequent Visitor

Re: I have a new voice remote not taking voice commands

Well Atlanta is back online..... thanks guys for the chiming in it's cool that you can find out things this fast..LOL

Official Employee

Re: I have a new voice remote not taking voice commands

There was a brief issue on our end with the Voice Navigation system which should was resolved just around 5 PM EST. Sorry about the wait for a reply here, just caught this thread.

 

Let me know if you are all still having any problems Smiley Happy

 

Thank you for reporting this!

 

-Nick


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Frequent Visitor

Voice Remote not working, "Listening" mic not shown on screen

I just installed my X1 with DVR yesterday, and the voice remote doesn't seem to be working. The remote buttons work for changing channel and volume and they also will turn off TV and Receiver. However, when I press and hold the mic button on the remote I don't get any indication on screen that it is listening. The light on the remote changes to blue like it is listening, just nothing on screen and no results.

Service Expert

Re: Voice Remote not working, "Listening" mic not shown on screen


db28 wrote:

I just installed my X1 with DVR yesterday, and the voice remote doesn't seem to be working. The remote buttons work for changing channel and volume and they also will turn off TV and Receiver. However, when I press and hold the mic button on the remote I don't get any indication on screen that it is listening. The light on the remote changes to blue like it is listening, just nothing on screen and no results.


Did you go into Settings and turn VOICE on?  Must also be done there....




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Frequent Visitor

Re: Voice Remote not working, "Listening" mic not shown on screen

Yes, I checked that. It does sometimes respond to voice after a delay of about 5-10 seconds but there is still no "Listening" displayed on screen.

Official Employee

Re: Voice Remote not working, "Listening" mic not shown on screen

Just to make sure we catch the obvious, did you rf pair the remote?





Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Silver Problem Solver

Re: X1 Voice Remote - Voice part doesn't work well

So what happens when you try? Does it not recognize the right words? Take you to wrong channels? Give you an error?

 

If you want us to help you then we'll need this info...

 

Gold Problem Solver

Re: X1 Voice Remote - Voice part doesn't work well

Ya just need to learn to speak Minion. Maybe this will help:

http://customer.xfinity.com/help-and-support/cable-tv/XR11-remote-FAQs


Tomsal74 wrote:

So I just got the X1 Voice Remote yesterday (7/30/15). Beautiful remote btw. It comes with a setup guide which I followed word for word (that's important for people to understand, I literally did the setup instructions to the letter) .... the remote works great....except the voice command part of it, you know the whole main feature of the remote -- doesn't work with much reliability. 

 

At initial setup voice commands worked perfectly for a good 20 minutes..... then it stopped working. In frustration I powered off my entire X1 cable box...waited a minute or two and powered it back on. The voice commands worked again until I went to bed. This morning before I went to work voice command worked (I only gave one command this morning). Tonight I'm trying it out again...voice command is not working again. 

 

During this whole time it should be noted -- ALL other aspects of the remote works perfectly....plus it controls my tv on/off and volume perfectly as well as that for my receiver. The only thing that seems sketchy is the voice feature.....To be honest the voice command is more a gimmick feature to me than anything...but it does annoy me that its not working. I mean the thing is BRAND NEW.


 

Frequent Visitor

Re: X1 Voice Remote - Voice part doesn't work well

I appreciate everyones fast reply....honestly I never had a reply that fast on any tech related forum...impressive.

 

I fixed the issue myself about an hour after I made my post. 

 

The problem btw was that it wasn't recognizing ANY voice AT ALL.

 

What seemed to fix the problem was one or all of these....

 

I restarted the X1, took the batteries out of the voice remote for about 30 seconds...put them back in, waited for X1 to complete restart...then I re-ran setup on the voice remote again (I had previously done this) ....after all that it seems to be working now...and it was working the whole rest of last night just fine.

 

 

New Poster

Re: X1 Voice Remote - Voice part doesn't work well

I have the same problem, except that my voice commands don't work at all.  I returned the device to the Comcast Store today.  They gave me a new one and told me to unplug my DVR for 5 minutes when I got home.  I did that and the voice commands still don't work.

Service Expert

Re: X1 Voice Remote - Voice part doesn't work well

You have to turn Voice on in Settings.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Silver Problem Solver

Re: X1 Voice Remote - Voice part doesn't work well


RobertWy wrote:

You have to turn Voice on in Settings.


It's on by default.

 

But you do need to pair the remote via RF to the DVR or Xi3 box, something that the instructions do tell you to do.

 

Hold setup until light goes green, press Xfinity, follow directions on the screen.

 

Voice control not available on an RNG150.

New Poster

X1 Voice Not working, Screen doesnt show "listening"

So we literally just got this system a few hours ago, we tried out the voice a few times, and it worked fine. now of course after the technician left, its no longer working. we hold the remote and speak clearly without any other noise, the remote turns blue makes the ping noise, and flashes repeatedly after we speak, and then goes red. There is no " listening" popup on the screen at the present time either, there was in the beginning. Ive tried restarting the device, and ive reset up the remote multiple times. Still not working. Brand new need help.

 

-thankyou

New Poster

Re: Voice Remote not working, "Listening" mic not shown on screen

After receiving my X1 box, the voice remote was set up and working fine until I tried using it today.  Now I'm having the same problem as the original post.  I reset the remote and paired it again but still having issues.  

Frequent Visitor

Re: X1 Voice Not working, Screen doesnt show "listening"

Many are experiencing this and it's not just with new customers.  Almost certain last nights update broke the voice commands.. 

New Poster

Re: X1 Voice Not working, Screen doesnt show "listening"

We have had our remote for two weeks and things have been fine...but today, the voice control feature stopped working.  We have repaired the remote, etc....but nothing is working.

Special Events
FIFA World Cup 2018 on Xfinity See More