Xfinity plant
Xfinity globe
Community Forum

X1 Companion Box Factory Reset

Contributor

X1 Companion Box Factory Reset

Is there a way to reset the X1 companion box to "factory default"?

 

I'm having an recurring issue with a box that used to be hooked up to SD TV and is now on a HDTV.  Would like to try resetting the box fully before I get it swapped out.

 

I've had Comcast restart it remotely and I know the "exit 5 sec, down, down, 2" method to restart it but I'd like to try and reset it as if it were being installed for the first time and you have to enter your account # and such. Is it possible?

 

Make & Model: PA pr150bnc (RNG150)

Gold Problem Solver

Re: X1 Companion Box Factory Reset

Hmmm,

Good question. At first glance I don't see a way to do it and I was thinking Comcast may not what that to be able to happen because I am guessing they would want access to the boxes usage and uptime over it's life..


dfriswell wrote:

Is there a way to reset the X1 companion box to "factory default"?

 

I'm having an recurring issue with a box that used to be hooked up to SD TV and is now on a HDTV.  Would like to try resetting the box fully before I get it swapped out.

 

I've had Comcast restart it remotely and I know the "exit 5 sec, down, down, 2" method to restart it but I'd like to try and reset it as if it were being installed for the first time and you have to enter your account # and such. Is it possible?

 

Make & Model: PA pr150bnc (RNG150)



.

Official Employee

Re: X1 Companion Box Factory Reset

There is a way but what's the recurring issue? A factory reset isn't going to do much.
Contributor

Re: X1 Companion Box Factory Reset

Hi Andrew,

 

The issue with this box is it resets its HDMI output to 480i every night when the box reboots and the TV is off. The video display option stays set to 720p but the box outputs 480i. Figured a factory reset would be the last ditch effort before swapping the box out.

 

 

Gold Problem Solver

Re: X1 Companion Box Factory Reset

Hopefully the new 2.0 firmware wil fix this but I also suspect you have an older TV....

X1 boxes don't always play nice with older TVs....


dfriswell wrote:

Hi Andrew,

 

The issue with this box is it resets its HDMI output to 480i every night when the box reboots and the TV is off. The video display option stays set to 720p but the box outputs 480i. Figured a factory reset would be the last ditch effort before swapping the box out.

 

 


 

Official Employee

Re: X1 Companion Box Factory Reset

How do you have it hooked up to the tv?
Contributor

Re: X1 Companion Box Factory Reset

It's hooked up to a new Proscan 32" TV via HDMI. I tried it on another TV (an older Proscan) and it did the same thing. If theTV is on when the box reboots everything is fine. Only happens when the box reboots and the TV is off.

 

The other X1 companion box I have doesn't do this on either TV,

 

When does the new firmware come out?

 

Would still like to try a factory default on this box if possible. When it was intially installed, it was connected to a SDTV via composite cable.

Official Employee

Re: X1 Companion Box Factory Reset

Check your private messages
Contributor

Re: X1 Companion Box Factory Reset

Looks like that did the trick!

 

After the factory default reset and re-config I removed power from the box for a minute and then powered it back up with the TV off. Let it boot with the TV off for a few minutes and then turned the TV on and it was correctly set at 720p. Sweet!

 

Looks like the box had remembered the 480i setting from the SDTV it was initially paired with and the only way to clear it was via the factory default reset.

 

Will know for sure tomorrow after the overnight reboot.

Contributor

Re: X1 Companion Box Factory Reset

The box is still outputting the correct signal this morning, problem solved!

Thanks!!
Expert

Re: X1 Companion Box Factory Reset


dfriswell wrote:
The box is still outputting the correct signal this morning, problem solved!

Thanks!!

that's excellent. Did you have to input account numbers etc to reactivate the box?

Contributor

Re: X1 Companion Box Factory Reset

Yes, the factory reset procedure requires you to re-enter the account number and phone to reactivate the box.

Official Employee

Re: X1 Companion Box Factory Reset

The box is still outputting the correct signal this morning, problem solved!

Thanks!!
_______________

Great to hear Dave, hope everything stays that way!!!
Expert

Re: X1 Companion Box Factory Reset

is that the way you have to do companion boxes when new? I only have DVRs.

Gold Problem Solver

Re: X1 Companion Box Factory Reset

Hmmmm,

The conspiracy theorist in me suggests that Andrew and Comcast could provide more information here so the problems solvers in this forum are better equipped to help people (and therefore save Comcast money)...

Maybe we should have the details as to how to do a "factory reset" and what it can and cannot accomplish...





Official Employee

Re: X1 Companion Box Factory Reset

Something's are better left to the red letters.
Gold Problem Solver

Re: X1 Companion Box Factory Reset

You are the only red letter member of this forum that I would accept that response.... LOL

 


ComcastAndrew wrote:
Something's are better left to the red letters.

 

Problem Solver

Re: X1 Companion Box Factory Reset

Rick I know how it's done, but I am not telling...It is also something that only certain Comcast people have access to. I wonder how long Andrew was on hold for that one!

Gold Problem Solver

Re: X1 Companion Box Factory Reset

I don't like secrets pizzaman. You will pay dearly for this. LOL LOL LOL


gotpizza wrote:

Rick I know how it's done, but I am not telling...It is also something that only certain Comcast people have access to. I wonder how long Andrew was on hold for that one!


 

New Poster

Re: X1 Companion Box Factory Reset

Can I get a private message from a "red letter" guy on how to do a full reset? I want to input the correct device names so I can use the X11 iPhone remote app, but it seems like you have to put the name in at install. I can change the names on the device but new name doesn't transfer to remote app
Valued Contributor

Re: X1 Companion Box Factory Reset


stephennor wrote:
Can I get a private message from a "red letter" guy on how to do a full reset? I want to input the correct device names so I can use the X11 iPhone remote app, but it seems like you have to put the name in at install. I can change the names on the device but new name doesn't transfer to remote app

stephennor, once you make the change of the friendly name, it can take 6 hours to update in the app.




Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Expert

Re: X1 Companion Box Factory Reset


ComcastNeal wrote:

stephennor wrote:
Can I get a private message from a "red letter" guy on how to do a full reset? I want to input the correct device names so I can use the X11 iPhone remote app, but it seems like you have to put the name in at install. I can change the names on the device but new name doesn't transfer to remote app

stephennor, once you make the change of the friendly name, it can take 6 hours to update in the app.


don't know if changed since whole-home went into effect but the DVR manager was the fastest change method before (change there was reflected everywhere quickly).

New Poster

Re: X1 Companion Box Factory Reset

I changed the name on the device a week ago, and it never updated on the app. I've even deleted and re-downloaded the app a couple of times.

 

Expert

Re: X1 Companion Box Factory Reset


stephennor wrote:

I changed the name on the device a week ago, and it never updated on the app. I've even deleted and re-downloaded the app a couple of times.

 


go here http://xfinitytv.comcast.net/mytv/cable-boxes (login) and change it there. then change to dvr manager page and verify it is updated. since it has not changed yet try adding 2 after each unique name (so it is different this time). once the dvr manager shows information and new name on the web page run the smart phone app and see if the new names populate it (xfinity my account app should be up to date pretty quickly)

 

New Poster

Re: X1 Companion Box Factory Reset

It worked! Many many thanks.
New Poster

Re: X1 Companion Box Factory Reset

I am having the exact same problem. Can you forward me the instructions for how to reset the device? Thanks
Regular Visitor

Re: X1 Companion Box Factory Reset

When I first installed my X1 box I was able to pair my remote for Aim Anywhere service. Later, when the remote wasn't responding, I removed the pairing. I am no longer able to pair the remote again.  I called tech support and they walked me through the standard procedure (hold reset for 3 seconds, hit the Xfinity button), but the pairing code screen never appears. Tech support told me to replace my remote, which I did to day at the local Comcast store. But still cannot pair.  It seems I must hard-reset the X1 box to its factory state so that I might re-pair with the new remote.

 

Can anybody tell me how to reset the X1 to factory defaults?  Rebooting does not do the trick. I want to start over, like the first time I set up the new X1 box.

 

Thanks for your help.

-Steve

Expert

Re: X1 Companion Box Factory Reset

Someone in this forum said there might be a software issue with paring.

New Poster

Re: X1 Companion Box Factory Reset

ok i just got the X1 service on FRIDAY and it worked greeat that night went to watch TV on saturday night and had a blue screen saying it needed a soft wear update !! called and talked to 2 differnt people in their customer service center and nothing helped fix the problem still today on sunday blue screen and cant get anyone out  here till tuesday at 5-7 pm need help to get this fixed any one ????

Official Employee

Re: X1 Companion Box Factory Reset

ok i just got the X1 service on FRIDAY and it worked greeat that night went to watch TV on saturday night and had a blue screen saying it needed a soft wear update !! called and talked to 2 differnt people in their customer service center and nothing helped fix the problem still today on sunday blue screen and cant get anyone out here till tuesday at 5-7 pm need help to get this fixed any one ????
__________________________

Unfortunately, you have a secondary box that has a software issue and needs to get swapped out.
New Poster

Re: X1 Companion Box Factory Reset

well what would have caused that after only one day of having this service ?????

 

Regular Visitor

Re: X1 Companion Box Factory Reset

ComcastAndrew, can you help me?  Is it the case that once paired and then unpaired, an X1 box can never be paired again?  Do I need to swap out my X1 box?

 

Thanks,

-Steve

Expert

Re: X1 Companion Box Factory Reset


hersker wrote:

ComcastAndrew, can you help me?  Is it the case that once paired and then unpaired, an X1 box can never be paired again?  Do I need to swap out my X1 box?

 

Thanks,

-Steve


when comcast forced out 2.0 to my Pace DVRs the ability to RF-pair instantly was fixed.

Regular Visitor

Re: X1 Companion Box Factory Reset

Thanks to those who replied. An hour on the phone with two different reps and 3 reboots of my X1, still can't pair remote.  Comcast technician scheduled to visit and investigate.

Expert

Re: X1 Companion Box Factory Reset


hersker wrote:

Thanks to those who replied. An hour on the phone with two different reps and 3 reboots of my X1, still can't pair remote.  Comcast technician scheduled to visit and investigate.


I think it may take a software upgrade to fix the pairing issue.  It has been discussed in other threads in this forum.

Valued Contributor

Re: X1 Companion Box Factory Reset


hersker wrote:

Thanks to those who replied. An hour on the phone with two different reps and 3 reboots of my X1, still can't pair remote.  Comcast technician scheduled to visit and investigate.


Hi hersker.  A few things to note for you.  First, RF pairing will be fixed for you when your boxes move back to 2.0 from 1.3.4 firmware.  We are aware of this issue and apologize for the inconvenience.  Second, when the technician comes to your house, please have them look at your Family Room box.  The RF levels are not within spec and your experience will be affected.  The 2.0 firmware for Arris boxes will be available soon.  Thanks for your patience!




Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: X1 Companion Box Factory Reset

Is there anyway for us t oget this for our secondary box. We are having tuning issues and Im wondering if it was because we activated it wit ha splitter. Wanted to do a whole new activation to see if that does the trick. 

Expert

Re: X1 Companion Box Factory Reset


ragedk13 wrote:

Is there anyway for us to get this for our secondary box. We are having tuning issues and Im wondering if it was because we activated it with a splitter. Wanted to do a whole new activation to see if that does the trick. 


by unplugging the power from the DVR for 30+ seconds and plugging back in, many times that will cause the firmware upgrade to begin. What is the model number of the DVR with problems (under the power button on front of DVR?

Official Employee

Re: X1 Companion Box Factory Reset

Is there anyway for us t oget this for our secondary box. We are having tuning issues and Im wondering if it was because we activated it wit ha splitter. Wanted to do a whole new activation to see if that does the trick.
_____________________

If you're thinking the splitter is causing your issues, take it out if you can. A reset with the splitter still there won't change anything. I see you self installed, you have 2 X1 boxes and a modem, so you should have either a 3 way splitter or 2 2 way splitters in your house. Anymore than that, it's lowering your signal. Also, check the conditions/age of your cables and wall plates and the splitters, it all comes into play.
New Poster

Re: X1 Companion Box Factory Reset

If we remove it then we won't have either Internet or cable. We have the main box directly plugged in but then took the secondary box is installed with the modem in the same room with the splitter. We've never had any other problems until we installed these. The splitter was brand new shipped from you guys. Everything else is good.
Official Employee

Re: X1 Companion Box Factory Reset

The X1 platform needs a stronger/cleaner signal than what you had before, you should probably get a tech out to investigate further.

Check your private messages as well
Regular Visitor

Re: X1 Companion Box Factory Reset

I am having issues as well. Can you please sned me a private message on how to factory reset my companion box.

Regular Visitor

Re: X1 Companion Box Factory Reset

Follow-up to my February posting.

 

Comcast technician came out and:

 

* simplified some cabling, removing a splitter

* installed some kind of grounding connector to a pipe where the cable first enters the garage

 

This improved the signal and all problems are now resolved.

New Poster

Re: X1 Companion Box Factory Reset

Would you be able to send me the steps for reset? I had an old TV that was not HDMI capable. I bought an hdmi to RCA converter box to try and work around the problem. It seems to be stuck in a some odd display mode that won't show anything on the old non-hdmi TV or a TV with a direct HDMI port. I think something with the converter box put it into this display state. You can see the splash screen that it's powering up for a bit, but shortly after the screen goes black and that's the end of it. Does this on 2 companion boxes now that had not yet been activated but were hooked up to and booted to the HDMI to RCA box.
Thanks for the help!
Expert

Re: X1 Companion Box Factory Reset


Ejk2 wrote:
Would you be able to send me the steps for reset? I had an old TV that was not HDMI capable. I bought an hdmi to RCA converter box to try and work around the problem. It seems to be stuck in a some odd display mode that won't show anything on the old non-hdmi TV or a TV with a direct HDMI port. I think something with the converter box put it into this display state. You can see the splash screen that it's powering up for a bit, but shortly after the screen goes black and that's the end of it. Does this on 2 companion boxes now that had not yet been activated but were hooked up to and booted to the HDMI to RCA box.
Thanks for the help!

 

If you have not tried this yet, remove the Adaptor and attempt to activate the companion boxes to the HDMI enabled TV only....  Once completed, change the video settings for the non-hdmi tv to something it can accept and then move it to there to test with the adaptor installed.

 

 



The Support Forums are "public" forums and you should not post identifiable information (full name, account number, address, phone numbers & email addresses).  Users of these forums are Comcast customers,the same as you & me and volunteer their time to assist with the issues and/or problems that you may be experiencing.  Please ensure your post is in the correct Forum to begin with.  Please do not send me Private Messages for personal help but instead use the Forums to allow everyone to read and offer comments to assist you.  Comcast employees are identified with RED lettered User Names.

New Poster

Re: X1 Companion Box Factory Reset

Thanks. I have tried moving the box to a known working HDMI TV and connected it directly to HDMI. But the same issue persists. Boot up "powering in screen" comes up then after 30 seconds or so goes black and stays there. I can't imagine I got 2 bad boxes brand new out box as the tech rep has suggested to me. I also took one of my working companion boxes that I had already activated and tried to hook it up to the old tube tv with the adapter and I only get audio, no video. Do something is wrong with what this particular adapter will accept and convert I guess. It will be going back to Amazon tomorrow.

Unfortunately I'm still stuck with 2 boxes that boot up then go black. I should note that I noticed the one box when it first booted up did a software update but as soon as it completed that and booted again it gets past that initial splash and then must change to some unsupported resolution or something. Odd that I can't get the HDMI Tv to show anything though. Would love if there really is a reset option to test out with these things.
Expert

Re: X1 Companion Box Factory Reset


Ejk2 wrote:
Thanks. I have tried moving the box to a known working HDMI TV and connected it directly to HDMI. But the same issue persists. Boot up "powering in screen" comes up then after 30 seconds or so goes black and stays there. I can't imagine I got 2 bad boxes brand new out box as the tech rep has suggested to me. I also took one of my working companion boxes that I had already activated and tried to hook it up to the old tube tv with the adapter and I only get audio, no video. Do something is wrong with what this particular adapter will accept and convert I guess. It will be going back to Amazon tomorrow.

Unfortunately I'm still stuck with 2 boxes that boot up then go black. I should note that I noticed the one box when it first booted up did a software update but as soon as it completed that and booted again it gets past that initial splash and then must change to some unsupported resolution or something. Odd that I can't get the HDMI Tv to show anything though. Would love if there really is a reset option to test out with these things.

 

You can try one more thing.... once the box has booted up and past the splash screen, try pressing EXIT EXIT EXIT 720 and see if that works.   Additionally try same but with 480.

 

-=Ray=-

Frequent Visitor

Re: X1 Companion Box Factory Reset


dfriswell wrote:

Looks like that did the trick!

 

After the factory default reset and re-config I removed power from the box for a minute and then powered it back up with the TV off. Let it boot with the TV off for a few minutes and then turned the TV on and it was correctly set at 720p. Sweet!

 

Looks like the box had remembered the 480i setting from the SDTV it was initially paired with and the only way to clear it was via the factory default reset.

 

Will know for sure tomorrow after the overnight reboot.


how didyou do it

Expert

Re: X1 Companion Box Factory Reset

If you have a screen resolution issue, there is a setting for it in Settings.

 

Or, you can try entering your TV's screen resolution with your remote

 

exit exit exit 480

 

exit exit exit 1080

 

(maybe exit exit exit 720)

New Poster

Re: X1 Companion Box Factory Reset

How do you do factory reset. I've been looking everywhere