Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,857,209

members

860

online

29,940

topics

Top

X1 Box Won't Turn On

New Poster

X1 Box Won't Turn On

I am having an issue getting my X1 box to turn on. The remote will turn the TV on but not the box. The blue botton is on and I have already tried unplugging it and plugging it back in as well as holing the blue button to reboot it but nothing has worked. Has anyone else had this problem/can give advice? Thanks!

Regular Contributor

Re: X1 Box Won't Turn On

Has it ever worked?  If so, the box or TV may have a problem.  If you are just starting out, I would guess you don't have the cabling correct and/or the tv input is not set correctly. If the blue light is on, the box is on.


mariaxo11 wrote:

I am having an issue getting my X1 box to turn on. The remote will turn the TV on but not the box. The blue botton is on and I have already tried unplugging it and plugging it back in as well as holing the blue button to reboot it but nothing has worked. Has anyone else had this problem/can give advice? Thanks!


 

New Poster

Re: X1 Box Won't Turn On

No, I've had it installed for a few months now and it has worked fine. 

Service Expert

Re: X1 Box Won't Turn On


mariaxo11 wrote:

I am having an issue getting my X1 box to turn on. The remote will turn the TV on but not the box. The blue botton is on and I have already tried unplugging it and plugging it back in as well as holing the blue button to reboot it but nothing has worked. Has anyone else had this problem/can give advice? Thanks!


Sounds like you need to take it to a Comcast Store and exchange it for a new box.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Official Employee

Re: X1 Box Won't Turn On


mariaxo11 wrote:

I am having an issue getting my X1 box to turn on. The remote will turn the TV on but not the box. The blue botton is on and I have already tried unplugging it and plugging it back in as well as holing the blue button to reboot it but nothing has worked. Has anyone else had this problem/can give advice? Thanks!

 

____________\

 

Are you on the proper input on your TV?

 Update, it's showing offline, check your cable connections and if it continues either have a tech out to check your connections and swap your box or swap your box at your local service center. Your modem is online and signal looks good.


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: X1 Box Won't Turn On

Thanks, it is on the proper input and still not working.

Valued Contributor

Re: X1 Box Won't Turn On

Mario - 

 

I have the same problem and it has to do with COMCAST updating the X1 box from time to time. I had month it worked - NO CHANGES IN BETWEEN - then it stopped working - then it worked again and right now It's not. I checked the Sofware revision on my box the whole time and everytime it stopped working they send a new update to my box ! Yeahhhh 

 

Ok try this turn every thing on - if the blue light is on your box - turn it manually off by pushing it once - count to 5 and push it once - it takes some time to lid up again .. that's HOW i get my box to work right now ! I just had to do this again 5 min ago :-)  Software GLITCH ! 

Forums Tips and Tricks:
Tagging Posts... See More
Discussion stats
  • 6 replies
  • 10084 views
  • 1 kudo
  • 5 in conversation