Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,857,353

members

1,231

online

29,958

topics

Top

Trouble Connecting.

New Poster

Trouble Connecting.

We have the message "We're having trouble connecting to the X1 Platform," and we've tryed everything it said to. This has been going on for a few days now. We need some way to fix it.

Gold Problem Solver

Re: Trouble Connecting.

X1 DVR or companion box?

Are you seeing error messages?

Do you know for sure that the cable outlet you are connecting to has live signal?
New Poster

Re: Trouble Connecting.

It is a companion box, it does have live signal, (on main box it does the same thing as companion box, but with live tv playing in background, you can't change channel) and the only error message is the Can't Connect one. (I think the error code is RDK-03033).

Official Employee

Re: Trouble Connecting.


cmellon wrote:

It is a companion box, it does have live signal, (on main box it does the same thing as companion box, but with live tv playing in background, you can't change channel) and the only error message is the Can't Connect one. (I think the error code is RDK-03033).


Can you clarify a few things? 

The DVR is showing offline but your modem is online. Do you know if you have any amps that your cable boxes are connected to? If so, check that it has power.

Your account shows 1 DVR and 5 XiD's. Is this correct? If so, that's one thing that can cause issues. It's supposed to be 3 XiD devices for every XG device ( DVR or XG2)


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Trouble Connecting.

No amps, and that is correct, but we've had the X1 box for more than a year, and this has never happened (except for a few minutes at a time).

Official Employee

Re: Trouble Connecting.


cmellon wrote:

No amps, and that is correct, but we've had the X1 box for more than a year, and this has never happened (except for a few minutes at a time).


Are all 6 boxes not working?

 

If no amps, how is everything hooked up? Details


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Forums Tips and Tricks:
Tagging Posts... See More
Discussion stats
  • 5 replies
  • 387 views
  • 0 kudos
  • 3 in conversation