Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,858,892

members

1,148

online

29,055

topics

Top

TV's not working!

New Poster

TV's not working!

This is the 4th day that all 4 of our televisions are unable to change channels. They are stuck on the last channel used. When we press "guide," a message comes up that there is trouble with our x1 platform connection. It then gives the following instructions: Ensure cable is tightly secured.

Unplug set-up box from electrical outlet. Wait 10 seconds then plug back in.

 

It references the following code as well: RDK-03033

 

 

Service Expert

Re: TV's not working!


don15215 wrote:

This is the 4th day that all 4 of our televisions are unable to change channels. They are stuck on the last channel used. When we press "guide," a message comes up that there is trouble with our x1 platform connection. It then gives the following instructions: Ensure cable is tightly secured.

Unplug set-up box from electrical outlet. Wait 10 seconds then plug back in.

 

It references the following code as well: RDK-03033


do you have an Xg1 DVR and 3 XiD set top boxes? try rebooting the Xg1 and when it comes completely up and is properly displaying live TV reboot each of the others. To reboot, remove the power cord from the AC power plug for 30 seconds or so then plug back in.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Forums Tips and Tricks:
Tagging Posts... See More
Discussion stats
  • 1 reply
  • 230 views
  • 0 kudos
  • 2 in conversation