Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,872,509

members

1,469

online

28,796

topics

Top

Sound but no picture

ANSWERED
Frequent Visitor

Sound but no picture

My X1 DVR restarted and now I get sound but no picture, just the screen with the network logo.

Accepted Solution

Re: Sound but no picture

That was going to be my next step, but a couple of restarts did the trick, thanks.

View answer in context
Service Expert

Re: Sound but no picture

Did you try unplugging and plugging back in the power cord?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Frequent Visitor

Re: Sound but no picture

That was going to be my next step, but a couple of restarts did the trick, thanks.

Special Events
FIFA World Cup 2018 on Xfinity See More
Discussion stats
  • 2 replies
  • 9613 views
  • 0 kudos
  • 2 in conversation