Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,872,176

members

1,486

online

28,724

topics

Top

No audio out of the HDMI output

Frequent Visitor

No audio out of the HDMI output

I have my X1DVR hooked up to my TV via the HDMI cable. It worked...but then I lost the sound. I read somewhere on a forum there is some combination of removing hdmi and power cables from both the tv and receiver, and then plugging them back up. I did this once...and it worked, but it doesn't work now. I am having to use the component input now, but I want to use the HDMI.

 

What is the problem? There has to be a setting or some type of "handshake" issue.

 

Thanks

Frequent Visitor

Re: No audio out of the HDMI output

I have the PA px001anm  receiver. I still cannot get any audio out of the HDMI output, but I get a great picture. I read somewhere to turn cable box off, leave TV on and hit the menu button on the remote or the front of the box to be able to enter a menu to check the audio settings, but this doesn't work with my system.

 

I have a TON of programs recorded and don't want to swap out the box, but i want to change my set up in the living room and need to use the HDMI output, so what can I do to get the output to work properly?

Official Employee

Re: No audio out of the HDMI output


gtcoatie wrote:

I have the PA px001anm  receiver. I still cannot get any audio out of the HDMI output, but I get a great picture. I read somewhere to turn cable box off, leave TV on and hit the menu button on the remote or the front of the box to be able to enter a menu to check the audio settings, but this doesn't work with my system.

 

I have a TON of programs recorded and don't want to swap out the box, but i want to change my set up in the living room and need to use the HDMI output, so what can I do to get the output to work properly?


Apologies for the issue that you described above.

Thanks for the follow-up and detail here (and thanks for your PM). 

I have escalated your issue.

The steps you outlined above (turning the cable box off) are not for the X1 Platform.

I am checking with our teams again on your situation. Thanks for your patience.  


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Frequent Visitor

Re: No audio out of the HDMI output

Thanks Ted, but you told me that last week. I have tried online chat and called support and NO ONE can help. I had an appt for last Tuesday and the technician didn't show up.........it is crazy.

 

I do appreciate any help you can provide.

Frequent Visitor

Re: No audio out of the HDMI output

Ted,

 

It has been another week....and still no response. What do I need to do? I have already had my box swapped out once and lost everything I had recorded.....

Regular Visitor

Re: No audio out of the HDMI output

I'm having a similar issue with HDMI audio.  I am able to get audio via HDMI to my receiver (Harmon Kardon 2650), but I have to reboot the X1 box daily to get it.  Throughout the day, if we turn the system (receiver, TV, DVR) on and off, the audio still comes through.  But every morning when we turn the system on, there is no audio via HDMI.  An DVR reboot resolves the problem, but is less than ideal since it takes several minutes and will also mess up any DVR recordings at the time. My sound output setting is set to surround.

Regular Visitor

Re: No audio out of the HDMI output

I too have issues with no audio through hdmi to samsung f8000 tv. Can get it back by various measures of power on-off, resetting box and reseating cables. Usually stops working when power goes off and on. This has to be a handshaking issue with certain TV sets, as my guess. Sometimes I can fix it fast and sometimes it takes awhile. Any firmware updates coming or advice? It is a top of line tv and never had this issue until I upgraded from moto Dvr to px Dvr.
Frequent Visitor

Re: No audio out of the HDMI output

I have been having the same problem ever since I got the X1 Platform almost a month ago.  Every morning I have to reset my box because I have a picture but no sound.  I can turn my TV off and on all day after that and it works fine.  It's just the first time that I turn my TV on for the day that I have this problem.  Customer Service is absolutely no help.  I even had the box replaced a couple of days ago and that didn't help either.  I thought that maybe it was because I was using my sleep timer on my TV at night but tested that theory and that's not the problem.  This is getting ridiculous.  There has got to be a fix for this.  

Regular Visitor

Re: No audio out of the HDMI output

I tried it on three different x1 devices. Some type of firmware compatibility issues with certain tv's.  Since my tv is a new Samsung set and they are one of the largest makers of TV's, my guess it is an X1 firmware issue with HDMI and/or handshake.  It would be interesting to know what types of TVs those with the problem are using.  Anyone know if Comcast is working on this or has commented?  

Frequent Visitor

Re: No audio out of the HDMI output

ComcastTED who is a moderator here has known about this for weeks...I have been PM him. Said it was being elevated but I have not heard anything else.

 

I can't get it to work on a Vizio or Panasonic

Frequent Visitor

Re: No audio out of the HDMI output

Just wanted to post service guy showed up. The volume was NOT working on the hdmi when I went to bed, but he just checked and said it was now (wife at home.....comcast did not show on last two appts, so i did not take off this time). He said he checked all signals and turned off and back on, and still working.

 

ComcastTeds, any chance they did a firmware update last night that could hvae fixed the problem? it is has been pretty frustrating to not get any response to this problem. Unfortunately for you other guys that have posted here about your same problem, maybe they will take some action since there are more experiencing the same problem.

 

The tech did tell me he has same setup at this house and has had issues with box resetting, rew recorded light staying on, etc. Said the X1 box seems to be very quirky.

 

Any anyone hears about a resolution, I hope they will most. I will move my other tv i have been waiting to set up with this box until the HDMI was fixed.....so we will see how it works. It only has one component input and I need itfor another device.

Regular Visitor

Re: No audio out of the HDMI output

I'm not sure when they uploaded 4910 firmware. I'm doubtful it addressed this issue since the moderator has not weighed in for some reason though we keep asking. I don't want to power off and experience no audio again and then spend 30 minutes or more trying to reboot several times until it takes. Today, still works though the box won't change to surround audio though I keep trying to select the option in the menu - I select it, exit and then it goes back to stereo. At least I have sound today.
Regular Visitor

Re: No audio out of the HDMI output

I've had the audio go out a couple of times. Instead of rebooting the box, try this, it works for me:

 

  • Go into Audio Settings and set the output from Surround to Stereo.
  • Exit Settings.
  • Go back in and set the output back to Surround.
Frequent Visitor

Re: No audio out of the HDMI output

Got home this evening and no audio again....call comcast and they have no clue about this problem.

MODERATORS PLEASE HELP US
Frequent Visitor

Re: No audio out of the HDMI output

Having the same issue - no sound in the morning. Using an X1 DVR with my Samsung TV. XRE version 1.32.05 (build 4910). Consistent every morning and hard restart is a consistent fix.

 

Any ideas?

Regular Visitor

Re: No audio out of the HDMI output

The workaround I'm doing now is to run audio through an optical cable to my receiver.  So far seems to work fine.

Frequent Visitor

Re: No audio out of the HDMI output

I can get volume through the other audio sources. I am currently using a 12 yr old tv that has multiple component inputs, but the new one I have been trying to install for 3 weeks only has one cmoponent, but multipe HDMIs. I have got to get the audio out of the hdmi.

 

I tried the change between stereo and surround, but that doens't help me at all. Hard reboots don't work everytime either.

 

I am presently on a call with Xfinity .....and seem to have a lady that has some clue, but most of the ones you get through 800 comcast have no clue, nor do the online chats. The online tickle me how they have american names, but write like they are Indian......crazy.

Frequent Visitor

Re: No audio out of the HDMI output

surlydirector, how do you force the sound to output via the optical connector? I have one as well but the TV seems to be sourcing the audio from HDMI and I don't know how to override that.

Gold Problem Solver
Moved:

Re: No audio out of the HDMI output

Frequent Visitor

Re: No audio out of the HDMI output

Sorry for so many replies, but maybe we are getting somewhere.

 

I just had a call from the tier 2 support who said he had elevated my issue (our issue) to engineering. I have his name and number, but don't think I need to share it here, but i will continue to follow up.

 

It is pretty clear this is a software issue and could be handled via an upgrade. I guess we will see what happens.

 

I will keep everyone here posted.

Bronze Problem Solver

Re: No audio out of the HDMI output

I would like to add my weird audio woes to the mix.  I’ve noticed something regarding 5.1 surround sound on my networked X1 DVR’s. 
 
My DVR’s are connected to A/V receivers with optical cables and to my HDTV's with HDMI.  I can watch original HD programming from each DVR in 5.1 surround sound.  And I can watch programming recorded on that specific DVR in 5.1 surround sound.  However, when I try to watch programming recorded on one of my other DVR’s – it will not replay with 5.1 surround sound – stereo only.  And, when that happens the DVR which played recordings from another DVR will no longer play any type of programming in 5.1 sound unless I reboot the box.  Once rebooted the box will play everything in 5.1 sound except for recordings from another DVR – then the cycle starts over again.
 
The device-audio setting for stereo or surround does not stay on surround no matter what I do.  It reverts to stereo as soon as I leave the page.  I think that is a known problem and isn’t affecting my problem mentioned earlier.

 

Frequent Visitor

Re: No audio out of the HDMI output

SOOOOO.....the latest is a call back from the Tier 2 guy. Engineers want to send out a tech to check becuase i have a couple of "irregular" signals. Kind of odd since the Tech there on Monday said all the signals were just fine. Oh well.....who knows.

 

SO, I have to wait on another tech tomorrow ( Of my last 3 appts, only 1 showed up). We will see how this goes, but I am not holding out much hope.

 

My question to everyone....have you had technicians come out and check your signal strength? I still say it is something in the software the way he operates. Otherwise, why would rebooting it solve the problem, even if only temporarily?

 

Amazing.....

Contributor

Re: No audio out of the HDMI output

sometimes when the tech installs the equipment the signal is fine but when the device gets up a running or usees more tunners ie x1 dvr then it can couse the signal problems

Frequent Visitor

Re: No audio out of the HDMI output

joejoejoejoe,

 

This has been installed for months...I have had this issue for a month and had 2 technicians check it and both said the signal was fine.

 

I hope it is the signal. I will have another cable ran and ready and we will see.

Contributor

Re: No audio out of the HDMI output

maybe it is not coused by your house line but my the outside line or the street line.

Frequent Visitor

Re: No audio out of the HDMI output

Yes, I had a tech out last Saturday and the signal was fine. He even replaced the box just to be sure. Of course I couldn't tell if the problem was fixed until the next morning and of course it wasn't.
New Poster

Re: No audio out of the HDMI output

My problem is the same as lots of other posts. When I power up my TV I will have audio. My DVR settings is set to Surround. As soon as I change the channel I will lose the audio. I can switch channels and still no audio. I like many others have rebooted, reseated cables etc. which in some cases work. Rebooting takes forever as we all know. What I found works for me is in the "Settings" I switch the "Output resoultion" from my current setting of 1080i to 720p. The audio comes back, I save it then switch it back to 1080i and save it. It works all day unitl I power down. When I power up the next time as soon as I switch channels I lose audio again. I go thru the same motions above and it works. It's easy and alot quicker than rebooting the DVR box. Hopefully there will be a "real" fix for the problem soon.

Regular Visitor

Re: No audio out of the HDMI output

@ioreper The setting would be on your TV.  The DVR outputs audio from both optical and HDMI simultaneously.

Frequent Visitor

Re: No audio out of the HDMI output

This is the latest.....

 

Tech came out yesterday and said there were some signal issues and some ingression in the line. After about an hour, he ended up changing a couple of ends of cables, moving the power supply to the splitter box and that resolved the signal issues. Audio on the tv worked fine.

 

Woke up this morning and......NO AUDIO. I tried the video output switch from 720 to 1080 and it worked, so I am HOPING that is at least a consistent, easy workaround for the time being.

 

Talked with the guy at National Support this AM. He checked and said all signals look good. he is going to pass the information onto engineering, but it sounds like this is a known issue since march and they are having a hard time finding a bug fix that works with all tv's. He is going to continue to work the issue.

 

What is crazy to me is I have NO problem on all my other x1 boxes, just the DVR. I hvae 4 other boxes with 2 hooked up to Vizio, 1 to Magnaox and 1 to Samsung.

 

If I learn more, I will let everyone know. Any fixes or workarounds that are discovered, let's all share. I cannot change from stereo to surround at all, so that doesnt' work, but the vidoe output does.  

Frequent Visitor

Re: No audio out of the HDMI output

Another morning with no audio.  Had to reset my box AGAIN.  I'm so tired of this.  If Comcast can't fix this, I may just go back to the regular box.  

 

What's really strange is, my other box is working just fine and it's on the same brand of TV.  Go figure.

 

I really hope that they find some kind of fix to this soon.

Frequent Visitor

Re: No audio out of the HDMI output

Sailingcp,

 

Have you tried the video output workaround?

Frequent Visitor

Re: No audio out of the HDMI output

Yes, that doesn't work for me.  

 

I'm on chat with Comcast right now.  They are scheduling a tech to come out to my house.

Frequent Visitor

Re: No audio out of the HDMI output

Good luck with the chats, but I have found them to be useless. I don't think there is anything a tech can do, but maybe you will be lucky. It is clearly a software issue that needs to be resolved.

Frequent Visitor

Re: No audio out of the HDMI output

Ok, got a call from national service guy that said all my signals are good and engineering says my issue is tied to the known issues that they are working on, but no timeframe on resolution.

 

The past couple of days, I have found a workaround that seems to work. Wake up EVERY day with no volume. If I change the resolution from 720p to 1080i, or vice versa, exit, THEN go to my tv and change input from HDMI to TV and then back to HDMI, I get volume. I have NO idea why....but it has worked the past 2 days.

Regular Visitor

Re: No audio out of the HDMI output

Did anyone ever get a resolution for this?

Frequent Visitor

Re: No audio out of the HDMI output

No. No luck yet. I had a technician at my house that couldn't figure it out and said he would check into it and give me a call back. That was two weeks ago. Never heard back from him or Comcast. What I did find out this weekend was that my other box resets itself every night. So now I have one box that I have to reset every morning just to get sound and one box that resets itself every morning. What the heck?
Frequent Visitor

Re: No audio out of the HDMI output

Mine has been working fine for a couple of weeks. May or may not be related but the only thing I did was switch from 1080p down to 720p and back to 1080p she. The sound came back one morning. No restart and no lost sound after doing that.
Frequent Visitor

Re: No audio out of the HDMI output

I still have to toggle the audio output on the cable box between 720p and 10780i, THEN change the tv input from HDMI to TV and then back to HDMI.

 

I am going to call the guy at national X1 support and see if there are any updates.

Frequent Visitor

Re: No audio out of the HDMI output

So, here's the latest.

 

The toggle from 720 to 1080 and back didn't work.  I woke up this morning and still had no audio.  I proceded to reset my box just like I've done for the last 6 weeks and my remote wouldn't work.  It worked on my volume but not on the box.  Really?  So I physically went to the box the reset it.  After a couple of tries, it attempted to reset.  I had video and sound for about 30 minutes and then my screen went black.  I thought it was the screen saver coming on but of course it wasn't.  Now I had audio but no video.  This is when I knew that this day wasn't going to turn out well.  So, I reset my box again and after 3 attempts which included me unplugging the box, I now had no audio or video.  Are you kidding me?

 

I contacted Comcast and told them what was going on and informed them that this has been happening in one fashion or another since I switched over to X1 six weeks ago.  They told me that they would elevate my problem and someone will contact me within 24 hours.  Yeah right.  I'm still waiting to hear back from them from 2 weeks ago.

 

I'm furious right now.  They either need to fix this now or I want my old cable back.  I may just drop them all together.  Their customer service guarantee...a joke.

Gold Problem Solver
Moved:

Re: No audio out of the HDMI output

Frequent Visitor

Re: No audio out of the HDMI output

I've been having a similar issue.

 

My Samsung F6300 doesn't receive any audio from my X1 DVR when I have the audio output set to surround. Switching it to Stero seems to solve the problem, but that seems rather unnecessary since the TV is capable of playing any format, including DTS-HD and TrueHD. I want to keep the audio set to surround since I share that box between two rooms using an HDMI matrix (and the other room has 5.1).

New Poster

Re: No audio out of the HDMI output

You are a life saver!!!! On my TV, I initially changed it from 720 to 1080 and click YES when it asked if I was sure I wanted to change it to 1080. The sound immediately came back which was fantastic, but I still didn't have sound the next day.

 

So.. the next day I changed it from 720 to 1080, but when it asked "Are you sure you want to change it to 1080?" (or something along those lines) I clicked NO and it stayed on 720. The audio still came back, but now I have had audio for the past few days when I've turned on the TV! I can't believe it-- I don't want to jinx myself but hoping this is a permanent fix!

 

You are a genius Smiley Happy Definitely try switching to 1080 but clicking "NO" when it asked if you're sure you want to change from 720-1080!

 

New Poster

Re: No audio out of the HDMI output *POSSIBLE SOLUTION!!!*

Hi all,

 

I have had this same problem with my X1 DVR box since I got it back in May. Every day when I try to turn on the TV, it has picture and fully functional DVR but no audio. If I go into settings and complete a system restart, the sound comes back. After doing this every day for at least 6 months (!) and having two additional Comcast technicians come out (also replacing the box once but neither of whom was able to to fix it), I came across this message board!!!

 

Someone suggested going into Settings, then VIDEO DISPLAY, and changing the Output Resolution from 720 to 1080 HD. I first changed it to 1080, clicked YES when it asked if I was sure, then changed it back to 720 and clicked YES again. The sound immediately came back without having to do an entire system restart. I thought this would at least be a faster fix than having to do a system restart every day. A day or two later (still with no audio in the morning), I went in to change the Output Resolution again, but when I clicked 1080 and it sayid "Would you like to change the output to 1080?" (or something to that effect) I said "NO." The output just stayed on 720, but the sound still came back. To my surprise, the next day.. and the next.. and the next.. I still had audio when I turned on the TV. Hooray!!! I'm really hoping this is not a fluke and that I haven't jinxed myself by writing this.

 

So, this is worth a shot--- Settings--> Video Display --> change Output Resolution from 720 to 1080 but then CLICK NO when it asks you if you're sure you want to change it. It looks like it may have worked for me, and at the very least I have a quicker way to bring the sound back (than system restart!) So glad I found this thread!!

New Poster

Re: No audio out of the HDMI output

I went to audio and selected advanced and it worked. Don't know why, but it did
Good luck
New Poster

Re: No audio out of the HDMI output

one more option that i found working is, simply unplug the hdmi cable and plug it back... whicever is easier. For me this is easier.

Special Events
FIFA World Cup 2018 on Xfinity See More
Discussion stats