Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,806,719

members

37

online now

1,952,681

discussions

Top

Adding a device, settings page doesn't fill in

New Poster

Adding a device, settings page doesn't fill in

I set up Xfinity Home and added my first camera during the process. It completed successfully and I can access hat device. But now to add additional devices, I go to add a device it takes me to the Online Service Manager page. I click on Settings, and I get the screen in the attached screenshot. The page never fills in with the buttons for me to select what I want to add. Help? I've tried clearing browser cache, made sure I was using a supported version of Chrome. What next?

Tags (3)
settings.PNG
Official Employee

Re: Adding a device, settings page doesn't fill in

It looks like you may be using an outdated version of the portal. Try http://home.xfinity.com

Note that if you have the full security system with a Touchscreen, you will need to add your devices using that instead of the portal.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Adding a device, settings page doesn't fill in

I go to that page, but then I click on Device>Add Device> it pops up and tells me that it is taking me to another page.  That page is: https://www.xfinityhomesecurity.com/sp/homepage.html?checkAlarms=true

 

Once there I click on Settings as it shows in the guide.  Then it is supposed to display a bunch of buttons so that I can choose what I want to add, but those buttons don't appear.

Valued Contributor

Re: Adding a device, settings page doesn't fill in

As mentioned above, do you have a touchscreen?  If so then you will need to use that to add devices.  Enter your security password and then select the add/edit devices.  You can add cameras, lights, locks and thermostats this way.  To add sensors you need to enter the Tech password.

Discussion stats
  • 3 replies
  • 1598 views
  • 0 kudos
  • 3 in conversation