Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,858,004

members

1,642

online

30,070

topics

Top

Audio Issues (Low audio, no audio, Spanish audio, Narraration, DVS)

ANSWERED
Highlighted
New Poster

Audio Issues (Low audio, no audio, Spanish audio, Narraration, DVS)

I got cable about a week or two ago. It has been working fine. All of a sudden the sound stopped working. I tried hooking another device to the tv to make sure that wasn't the problem. The cable is hooked straight to the TV, I don't have any dvd players or other devices hooked to the tv.

 

Thanks, Adam

Accepted Solution

Re: No Audio with cable tv


adam71601 wrote:

I got cable about a week or two ago. It has been working fine. All of a sudden the sound stopped working. I tried hooking another device to the tv to make sure that wasn't the problem. The cable is hooked straight to the TV, I don't have any dvd players or other devices hooked to the tv.

 

Thanks, Adam


Without knowing all of the specifics in your situation, you may want to try these options:

 

If you have an X1 Box you need to access the Menu Language Settings:

  1. Press the xfinity button on your remote.
  2. Use the right arrow or left arrow button on your remote to select the gear icon. Press the OK button on your remote to access the Settings menu.
    XFINITY on the X1 Operating System home screen with gear icon, furthest icon to the right, highlighted.
     
  3. Use the up arrow or down arrow button to highlight Language, then press the OK button on your remote.
    Settings menu with Language option highlighted.
     
  4. Using the down arrow button on your remote, highlight Menu Language and press the OK button on your remote.
    Settings > Language menu with Menu Language highlighted.
     
  5. Using the down arrow button on your remote, highlight Español or English (Canada) and press theOK button on your remote.
    Menu Language screen displays language options.
     
  6. To confirm changing your menus and guide language to Spanish or Canadian English, highlight OK on the screen and then press the OK button on your remote.
    Change language confirmation message:  "This requires a refresh and will take a moment to complete. Would you like to continue?"



- If you have a DTA, and your remote control has a LANG button on it, press it. 

-  If you have an HD or SD full cable box:

Most low or no audio issues can be corrected by setting the Optimal Stereo output of the cable box. Here are the steps: Press the Menu button twice on your remote control. Select Setup. Select Audio Setup Under the Optimal Stereo setting, choose "Select to Optimize" and press OK/Select on the remote control

 

- The audio settings on your cable box may have accidentally been changed:

Press the Menu button twice on the Comcast Universal Remote Control. A new screen below will appear, with the top-left option automatically selected.

Use the down-arrow key (above the Info button) to navigate to Setup and press OK/Select (the center key on the remote control in the middle of the 4 arrow/directional buttons).

Use the down-arrow key (above the Info button) to navigate to Audio setup and press OK/Select.

The Default Audio Track will default to the first option–Channel default–which which is always the channel’s main audio track (unless it was previously changed).

Press the right-arrow navigation key to change the audio track. Changing this selection will instantly change the audio.

1. Press once for English
2. Press twice for Spanish (Español) OR to activate Video Description (DVS)
3. Press three times for French (Français) 4. Press four times for Portuguese (Portugues).
5. Then press the Exit button (above the Volume button) to resume program viewing

Please note: These audio options can only be heard if the program provider or cable channel is providing that additional audio option.

- If the above does not help, look at the remote control for your TV set (not your cable box) as the TVs language settings may have been accidentally changed (sometimes labeled as MTS or SAP on the remote or via your TVs settings menu).

View answer in context
Official Employee

Re: No Audio with cable tv


adam71601 wrote:

I got cable about a week or two ago. It has been working fine. All of a sudden the sound stopped working. I tried hooking another device to the tv to make sure that wasn't the problem. The cable is hooked straight to the TV, I don't have any dvd players or other devices hooked to the tv.

 

Thanks, Adam


Without knowing all of the specifics in your situation, you may want to try these options:

 

If you have an X1 Box you need to access the Menu Language Settings:

  1. Press the xfinity button on your remote.
  2. Use the right arrow or left arrow button on your remote to select the gear icon. Press the OK button on your remote to access the Settings menu.
    XFINITY on the X1 Operating System home screen with gear icon, furthest icon to the right, highlighted.
     
  3. Use the up arrow or down arrow button to highlight Language, then press the OK button on your remote.
    Settings menu with Language option highlighted.
     
  4. Using the down arrow button on your remote, highlight Menu Language and press the OK button on your remote.
    Settings > Language menu with Menu Language highlighted.
     
  5. Using the down arrow button on your remote, highlight Español or English (Canada) and press theOK button on your remote.
    Menu Language screen displays language options.
     
  6. To confirm changing your menus and guide language to Spanish or Canadian English, highlight OK on the screen and then press the OK button on your remote.
    Change language confirmation message:  "This requires a refresh and will take a moment to complete. Would you like to continue?"



- If you have a DTA, and your remote control has a LANG button on it, press it. 

-  If you have an HD or SD full cable box:

Most low or no audio issues can be corrected by setting the Optimal Stereo output of the cable box. Here are the steps: Press the Menu button twice on your remote control. Select Setup. Select Audio Setup Under the Optimal Stereo setting, choose "Select to Optimize" and press OK/Select on the remote control

 

- The audio settings on your cable box may have accidentally been changed:

Press the Menu button twice on the Comcast Universal Remote Control. A new screen below will appear, with the top-left option automatically selected.

Use the down-arrow key (above the Info button) to navigate to Setup and press OK/Select (the center key on the remote control in the middle of the 4 arrow/directional buttons).

Use the down-arrow key (above the Info button) to navigate to Audio setup and press OK/Select.

The Default Audio Track will default to the first option–Channel default–which which is always the channel’s main audio track (unless it was previously changed).

Press the right-arrow navigation key to change the audio track. Changing this selection will instantly change the audio.

1. Press once for English
2. Press twice for Spanish (Español) OR to activate Video Description (DVS)
3. Press three times for French (Français) 4. Press four times for Portuguese (Portugues).
5. Then press the Exit button (above the Volume button) to resume program viewing

Please note: These audio options can only be heard if the program provider or cable channel is providing that additional audio option.

- If the above does not help, look at the remote control for your TV set (not your cable box) as the TVs language settings may have been accidentally changed (sometimes labeled as MTS or SAP on the remote or via your TVs settings menu).


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: No Audio with cable tv

I have a similar audio problem with select HD channel.

 

My setup is:  TV is plugged into my Pioneer receiver via HDMI which is then plugged into the cable box via HDMI.  I performed the instructions, but this does not fix the problem.  I still have HD channels with no "speaking" audio (I do get background audio such as crowd cheering in football games.)  I have verified SAP/other settings on both my TV and Stereo to be English only and from my receiver manual, but I'm not sure the receiver even cares.

 

NOTE:  With my TV plugged (HDMI) directly into my cable box (no receiver), there is NO ND audio problem. 

 

Does Comcast have a recommendation for this, or is this a receiver/other issue?

 

Thanks,

 

Mike

Silver Problem Solver

Re: No Audio with cable tv

If I am not mistaken it is recommended that the HDMI cable go to the tv and that you use a alternate method to connect the cable box to your sound system such as audio cables or a digital audio out connector if your sound system has that input.

 

New Poster

Re: No Audio with cable tv

I think it's just terrible that I can't talk to alive person!!!!!! 24/7 like you advertise!!!

 

Valued Contributor

Re: No Audio with cable tv

I called for help all hours but a night you usually get india is all.

Frequent Visitor

Re: No Audio with cable tv

Do you have a center channel speaker connected to your pioneer receiver??  On most channels, digital audio has speech coming from the center only. On the pioneer receiver change the sound mode to " ext stereo ". That should work.

Forums Tips and Tricks:
Tagging Posts... See More
Discussion stats
  • 6 replies
  • 224697 views
  • 18 kudos
  • 7 in conversation