Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,875,364

members

1,271

online

29,328

topics

Top

"Now Connecting To My Entertainment Experience" forever and ever...

Regular Visitor

"Now Connecting To My Entertainment Experience" forever and ever...

Up until over a month ago I was able to watch Xfinity TV online with no problem.  Then it suddenly disappeared.  Now, when I try to log on, all I get is the "Connecting to Your Entertainment Experience" screen, and it just stays there.  That screen will stay there for hours if I let it, without connecting.  I'm unable to watch anything at all.  There are no error messages, just the "Connecting to etc" screen.

 

I'm using my desktop computer that's directly connected via ethernet.  I've made sure my browser is set to accept cookies and save history.  I have the most current version of Flash.  I've turned all ad blockers off.  I've tried it with no firewall.  I've tried reactivating my modem.  I've tried connecting using different browsers (currently I'm using Chrome), and even different operating systems.  I've reset my modem and cable box.  I've turned everything off and back on again thousands of times.  I've tried using different computers.  The ONLY thing I can connect on is my phone, and I'm assuming that's because it's going through the Xfinity TV app, (which I can't use on my computer).  I'm getting extremely tired of having to watch TV on a 5" phone screen.

 

Up until about a week ago I was at least able to go directly to the CNN, MSNBC and FOX websites, and log in to watch their programming directly on those sites.  Now I can't even do that.  I get as far as telling them I use Comcast Xfinity, and signing in with my user name and password, but then I get stuck on a screen that says "Verifying" and then sticks there, same as the "Connecting to Your Entertainment Experience" screen on the Comcast homepage.

 

Does anyone have any other ideas to try to get this thing to work?  Please don't tell me to call or chat with customer support.  I've had a number of really horrible experiences with them and don't want to have another.  Can anyone here please help me?

Tags (3)
Regular Contributor

Re: "Now Connecting To My Entertainment Experience" forever and ever...

A big question is why is Comcast interfering when you go to the network sites directly. They are blocking your access to their sites. Which is a net neutrality issue. Comcast is obviously monitoring your content and then acting to interfere when you go to certain sites.

You could try to use some kind of VPN or TOR browser to conceal from Comcast what sites you are going to. Unless Comcast is blocking those things as well.

Regular Visitor

Re: "Now Connecting To My Entertainment Experience" forever and ever...

I think whatever it is has to do with somehow not recognizing my login credentials.  The CNN, MSNBC and FOX sites all make you log in with your Comcast user name and password in order to watch their live content, which is what I want to watch.  They apparently have agreements with the various cable companies, that their live streams will only be available to the cable companies' subscribers.  Their pre-recorded content is available to everyone, and I can view that just fine, (which indicates to me that the problem isn't with my software or Flash settings).  But I don't want to watch day old news.  The problem happens with anything where I have to log in using my Comcast credentials, and I don't know why.  

 

I'm paying WAY too much to only be able to access a fraction of what I'm paying for.  Smiley Sad

New Poster

Re: "Now Connecting To My Entertainment Experience" forever and ever...

I am having a silimar issue wish I knew how to resolve this.
Frequent Visitor

Re: "Now Connecting To My Entertainment Experience" forever and ever...

Same exact issue. Have problem solved everything and it is not my computer.  Loads plerfectly on ipad app...it is just  PC (Windows 10) that is hanging when loading 'my experience'. Not an experience I want to have!!!

 

Began at beginning of  April.  Have used this site daily since before it was changed to this new experience--which leaves quite a bit to be desired when working properly.  

 

I have reinstalled all browsers...same issue on every browser...Chrome IE Firefox Edge...have checked all security settings on all browsers and Windows 10...have reinstalled Flash where needed and checked all flash settings on all broswers...flash works fine on other sites just not xfinity...this is NOT at my end...HELP COMCAST JOE, BOB, TOM....ANYONE!!!

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 4 replies
  • 1674 views
  • 4 kudos
  • 4 in conversation