Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,859,427

members

1,162

online

29,146

topics

Top

Xfinity.com or Xfinitytv website wont stream HD

New Poster

Xfinity.com or Xfinitytv website wont stream HD

Hello, My name is Casey, and I am having a problem... For some reason when I use the xfinity website to watch movies and shows ondemand the website wont stream in HD. I have called the customer service multiple times regarding this issue, ive updated all forms of software related to streaming problems. Ive troubleshooted the heck out of every single thing I can think of and the technicians thru customer service can think of. Ive even went so far as to buy a new computer.... I purchased a brand new laptop and made sure everything was up to spec before attempting to watch an HD show. And alas, it still doesnt work. It doesnt matter what show im watching, it wont stream in HD. Ive upgraded my desktop computer to run HD movies and shows... It can stream in 3D, and is TOP OF THE LINE. Here are my specs of my desktop. 

 

1. GIGABYTE GA-X99-GAMING 5P EATX MOTHERBOARD

2. CORSAIR VENGEANCE LPX 32GB (4X8G 2400

3. INTEL CORE I7-5820K PROCESSOR

4. EVGA GEFORCE GTX 980 TI ACX SC+

5. SAMSUNG EVO 250GB SOLID STATE DRIVE

6. Phillips 27inch monitor 1080p 3d ready with G-Sync. 

7. Windows 10

 

If Ive left anything out petaining to this issue, let me know and I will remedy it immediately. Also, I have the 100+mb per second internet plan active ATM, and ive done multiple speed tests, before, after, and during streaming difficulties. All the tests come back as speed test results speedtest.net . And every speed test site I have gone to other than speedtest.net is the same or comparable to this test. And like I said, I have done it before, after, and during the playing of the movie or show. And the quality is abismal. Visable pixal boxes, and grainy picture.. Its really bad. And I dont know what else to do. I have replaced the cord going from my coax outlet, ive replaced my eithernet cord to catagory 6 cord... (the best & fastest from what im told) oh and yes, Im using a corded connection NOT WIFI. SO, any suggestions for me? Im lost. I want what I pay for. I need help. The only thing I havent done, is have an actual tech come out and look at stuff.. but I honestly dont know what he can do.  

 

thanks for reading. Hope I can find help. 

Service Expert

Re: Xfinity.com or Xfinitytv website wont stream HD

taterzNcorn,

 

The Comcast Team available to the Forums has been alerted to your issue. Check back often for a reply in this thread or via Private Message from a Comcast Official Employee.


The Support Forums are "public" forums and you should not post identifiable information - (full name, account number, address, phone numbers & email addresses).  Users of these forums are Comcast customers, the same as you & me and volunteer their time to assist with the issues and/or problems that you may be experiencing. Comcast Official Employees (OE) are identified with RED lettered User Names. Comcast Appointed Experts are identified with GREEN lettered User Names.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Admin1

Re: Xfinity.com or Xfinitytv website wont stream HD

Hi taterzNcorn -- Apologies for this streaming issue. I have asked a higher level technical support team to help with this issue. We will contact you for further troubleshooting. 


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 2 replies
  • 393 views
  • 0 kudos
  • 3 in conversation