Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








Xfinity app only works on a single 360?

Frequent Visitor

Xfinity app only works on a single 360?

I've recently changed my service, planning to stream most of my tv and video, rather than using live tv. Because of this I ran into a problem that I encountered a long time ago and never solved.


The problem is this:

I have multiple XBOX 360 consoles in my house. I user them for both gaming (with my kids) and to allow streaming video in each room. I hakd the x1 platform with any room service before, but wanted to just user the xfinity app for most on demand stuff. The first console I installed the app on its in the living room, and everything and fine, and still works great. My second install was in my bedroom. This is when the problems started. When I first launch the app, it verifies authorization successfully. The next step of initial setup is to enter the primary comcast account holder's login information. This is where it breaks, every time. 


I don't remember the specific error number I was getting back when I first tried this, but I attempted to use the comcast support number, and opened a new ticket. In the end, we never got it to work, and nobody could tell me why. Fast forward a year or two to now. I'd forgotten that I experienced the issue, and was repeating the same frustrating steps. Ive successfully installed foxnow, cwnow, and a couple other channel-specific apps, and those work beautifully after going through the whole activation over the web to verify you have valid service through comcast thing. But the freshly installed xfinity app starts up, verifies my authorization (I guess just that I'm on a comcast Internet connection), then prompts me to complete setup by entering my xfinity account login information. Once I do that, I get a few seconds of xbox spinning symbol (busy), then an error message yelling me that it was unable to complete setup right now, try again later or contact support. The displayed error code is 7995.


I've attempted the same thing on my son's console, just to make sure it's not console specific. Same exact results. 


So. . What do I do to get this working?  Or is there an unpublished limitation of using only one xbox 360 with the app per account? 


While I'm at it, I might as well ask about the other (less serious) issue I've seen.  I just installed the history app, and have gone to their website to activate it using the code they display, but comcast isn't in their (huge) list of providers, nor is xfinity (sometimes listed instead with the other channels' sites). I'm sick at this step, since I need the code to completely unlock all full video content. I've found references to a specific web url to enter (using the specific displayed code) to get around this for other history channel apps (roku, apple tv), but not for the xbox 360. Any ideas for this one? 

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 0 replies
  • 0 kudos
  • 1 in conversation