Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








Xfinity TV app for Samsung Smart TV not loading

New Poster

Xfinity TV app for Samsung Smart TV not loading

I have a samsung smart tv with the xfinity app installed. Unfortunately the app will not load and sits on the splash screen with three messages; authorizing service, loading parental controls, loading settings. I am unable to login with my account information. I tried again and again with no success. I am able to use the service on other devices.
New Poster

Re: Xfinity TV app for Samsung Smart TV not loading

Must be nice. O got the Samsung smart TV hoping to watch the app and cant even get it onto my TV. And so i get my XBox360 adn buy gold to use it on there. Nope service not offered in my area. Would have been nice to know before wasting time and money. 


Take it anywhere with me(Yeah right). I cant even get it in my own house unless i want to be teethered to my PC. Glad i pay full price for half the services

New Poster

Re: Xfinity TV app for Samsung Smart TV not loading

Nothing on this???? Thanks for the support comcast!!!
Frequent Visitor

Re: Xfinity TV app for Samsung Smart TV not loading

PressureDrop, I have a PN60e7000FF television and I am having the same issue.  I having been talking with Comcast out of Colorado since my initial ticket on Jan 11, 2014.  I talk to them about once per week.  I will forward a link to this forum to my contact.   Please send me an email at bobkunkle@hotmail.com becuase I can't paste the list of TV's in this tool.


New Poster

Re: Xfinity TV app for Samsung Smart TV not loading

Not sure if my problem is the same or not. I have a Samsung Smart TV that I purchased last year. I can't remember the model number at the moment but I think it was something along the lines of ES7500 or ES8500 or something along those lines (if it helps, it does have the ability to be upgraded with an Evolution Kit).


Anyway, yesterday, on a whim,  I searched for "Xfinity" on Smart Hub. I found that there was an xfinity app and downloaded it to the TV. All of that seemed to work fine and the app opened up to the username/password prompts. I entered my primary account username (it will not work on secondary accounts for some strange reason) followed by the password and hit "Done". It thought about things for a few seconds and came back with an error message telling me that my account could not be provisioned at this time (or something like that) and to try again later. I tried it again and this time, it would just spin and spin and spin like it was thinking about something but nothing would happen. I let it go like that for probably about 10 minutes with no result. Finally I just gave up and turned it off.


About an hour later, I tried again with the same exact results. After the first login attempt, I get the provisioning error. Second attempt just get's me the spinning circle thing that never finishes...


Any thoughts or advice on this?



Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 4 replies
  • 0 kudos
  • 4 in conversation