Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








Xfinity TV Player App & iPhone 3GS with iOS 5.1.1

New Poster

Xfinity TV Player App & iPhone 3GS with iOS 5.1.1

I've installed the Xfinity TV Player App on my iPhone 3GS and it does not play any movies.  The network splash screens play (or advertisements in other channels) and then the movie starts with full sound but no video.  I've tried multiple premium channels and regular channels and different movies.


The Xfinity TV Remote App does play video fine, utilizing the "Play Now" feature.  The GUI looks the same in both apps so that should establish that the physical capability is there.


My zip code is 97230 and I am using an iPhone 3GS on iOS 5.1.1


Please do not simply reply stating that iOS 6 is required because I know that is not the case and I do not wish to update to iOS 6.  I have other friends using Xfinity TV Player App on iOS 5.


Thank you for your assistance.

Tags (1)
Silver Problem Solver

Re: Xfinity TV Player App & iPhone 3GS with iOS 5.1.1

the only things you can watch are on the play now tab on both the apps and the content is basically the same its on demand type content.  do you have hbo?  if so do you have the app and does that work?  Normally if you get sound and no video that means you are to far away from the wirless signal.  Try signing out of the app then restart your device now sign back in, clear cookies and cache.  Is your phone jailbroke?  If so there really is not way to tell what could be doing it. 

New Poster

Re: Xfinity TV Player App & iPhone 3GS with iOS 5.1.1

Yes, but I can only watch the "play now" on Xfinity Remote and not TV Player.


I have tried rebooting the iPhone (hard reset) and signing back in, but with the same results (Xfinity Remote works, TV Player does not).  I did clear the cache inside the TV Player app (I did not see the 'cookies' mentioned..)  I didn't try this in succession to a hard reset, however.  I tried it separately as another possible solution.  I will try it in succession as written in your reply.


I am not jailbroken.


Thank you for your assistance.  I hope I can get it sorted out.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation