Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,843,964

members

770

online

36,492

topics

Top

Xfinity Remote TV app is broken

Frequent Visitor

Xfinity Remote TV app is broken

I had 2 Comcast Xfinity STBs (Motorola DCH 3200).  Both were seen by the Remote TV app.  Both used to work flawlessly...

unfortunately, the app became unstable with one of the STBs.  I finally took that in and exchanged it (Nov 2014). The app worked perfectly for a couple weeks then was unstable (worked, didn't work).  Since the handheld remote was not working well I took this one back too (May 2015).

In exchange, I received a different STB (Motorola RNG150).

The app 'sees' both STBs, and the app controls the DCH 3200 no problem; however the new RNG150 stopped working about 2 days after I got it. Whenever I select "Test this TV" I receive a "Request Error.  An unknown error has occurred during this request. Please try again."

Of course when I try again it displays the same error.

Tech support tells me that my TV is not supported.

How can that be?  I am not controlling my Samsung SmartTV with the app - it is a dumb monitor receiving content via its HDMI port - and that STB is supported (according to the FAQ).

Anybody have this happen and get it solved?

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 0 replies
  • 347 views
  • 0 kudos
  • 1 in conversation