Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,859,753

members

702

online

29,208

topics

Top

TV Listings Still won't Load

New Poster

TV Listings Still won't Load

This problem has been complained about since 2012 and it still hasn't been fixed. (Look it up).  I'm getting the message: "There was a problem loading the grid, reload your browser."  --NOT the problem, NOT the fix, and Xfinity knows it! 

 

Other fixes that don't work: changing locations, changing browsers, changing whole computer systems....  Yeah, we can get our listinings elsewhere, but Comcast, can't you show a little professionalism  on your own website?

Problem Solver

Re: TV Listings Still won't Load

Mine is also messed up.  Tried it on 2 different computers (Vista and Win 8.1) and 2 different browsers (Chrome and IE).  Can see the grid prior to logging into the Xfinity site, but as soon as I log in, grid doesn't show up.  This started happening a couple of days ago.

 

Also, I could use a different website to view listings (TV Guide, Zap2It), but I use the Xfinity guide to program my DVR.  No listing causes me to default back to using the crappy DVR guide which is painfully inadequate.

 

X.jpg

Problem Solver

Re: TV Listings Still won't Load

Got the guide to load again, thanks to no help from Comcast.  I decided to try changing my location and then putting it back to my original location, and the guide repopulated correctly.  I'm not sure what caused it to get screwed up to begin with, but now it works.  Yeah. 

Frequent Visitor

Re: TV Listings Still won't Load

I  know what you mean.  I called and went through five different service people, two of whom hung up.  The fifth listened and had someone reset the website then had me change from digital to standard then back.  It actually worked.  Almost worth the two hours of patience on the phone answering the standard questions.  Mine works every time again.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 3 replies
  • 2596 views
  • 1 kudo
  • 3 in conversation