Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








TV GO will not play on ASUS Android

Regular Visitor

TV GO will not play on ASUS Android

TV GO will install on my wifes ASUS tablet model K007 Android version 5.0.1, lolipop. but when I select something and hit play it acquires the license, shows the rating of show then jumps back to the play dialog box. I have an older android tablet running lolipop and it works fine on it. This is driving me crazy. Please help.

Tags (1)

Re: TV GO will not play on ASUS Android

I have the same tablet and I've been battling these jackwagons on this for a few months now. I have called in to Comcast 3 times for this specific issue ane chated with them at least 3 times and EVERY SINGLE TIME I DO they tell me this is the first they are hearing about the problem.

Regular Visitor

Re: TV GO will not play on ASUS Android

I have the exact same issue. I have the ASUS K007 with Android 5.0.1, and the Xfinity Apps ('TV' and 'TV Go') worked great until I did a Factory Reset on the tablet two days ago. After reinstalling all Apps as before I cannot get the Xfinity ones to work!! Same behavior, the install is just fine, but when choosing a program, it tries to load and displays the 'Acquiring Playback License' and will then jump right back to the Programming Selections Dialogue. My wife has the exact same tablet and it works just fine!! I can even provide the Debug Reports when it crashes. Any help is appreciated!  

Regular Visitor

Re: TV GO will not play on ASUS Android

I have found a solution! The Asus K007 Tablet (ME572C) that was giving the issue with Xfinity Apps had  Firmware: V12.14.1.23. I was able to downgrade to Version: V12.14.1.12 and now it works!!  


If you want to do this, go to the ASUS website and navigate to the Drivers and Tools Downloads page: 



Download the corresponding Firmware package.

In my case I used: ASUS MeMO Pad (ME572C)Software Image Version: V12.14.1.12 For WW SKU only*


Copy the downloaded ZIP file on to an SD Card and rename it as MOFD_SDUPDATE.zip


Consider backing up all your information as needed being that this will do a clean wipe factory reset!!! 


Go ahead and Power Down your tablet. 


Insert the SD Card


Then press the Volume-Up and Power Buttons Simulatenously for about 5-10sec.


The tablet will power on and go to Boot Menu. --> Choose Recovery option by pressing Volume-up button -->When selected, then press Power Button once and the Tablet will start to update. 


After the update, the Tablet should power on as normal. Go thru all the initial setup menus, then try installing the Xfinity Apps and it should work!! 


Good Luck!! 


Re: TV GO will not play on ASUS Android

ok I tried this twice using two different sd cards and downloaded the program twice just to be sure, and both times I just got a dead looking robot with an error in his stomach. It started to load but then gave me an error about 1/3 of the way through. Any thoughts?



Hour and a half later than original post

I've tried including the corresponding kernal

formatting the sd card to fat32

I tried a previous version to the version you suggested. Each time I end up with the error. Any advice would be greatly appreciated

Regular Visitor

Re: TV GO will not play on ASUS Android

Sounds like you are doing everything correctly. Not sure what the problem might be...Make sure the file is renamed as MOFD_SDUPDATE.zip  and make sure the download is for the correct region for your tablet (SKU). Mine was WW, make sure you are not downloading something else like JP. 





Re: TV GO will not play on ASUS Android

Yeah I've done it a number of times. No joy. After a while on the phone with Asus tech support they say it is not possible to downgrade. Oh well.

Regular Visitor

Re: TV GO will not play on ASUS Android

 I understand your frustration...I know ASUS states that a downgrade is not possible but I was able to do it, following the steps I posted.

One other thing you could try:

When I was first researching which Firmware to download from ASUS I found link for a ME572CL Tablet. I downloaded several firmware files including the current version (WW_12.14.1.23) I had on it and those files did not work for me either. I then found a link for ME572C (without the 'L' at the end) and then these files worked for me. I am not sure what the difference is between these two models but you might want to give it a try...


Here is the Downloads Link for the ME572CL: 



Hope this works for you! 


Re: TV GO will not play on ASUS Android

Hey I sure appreciate you taking the time to try and help me out. Having said that, the CL version errored out too. I looked at the log and it keeps telling me sku mismatch. When I checked it out under settings it said it is part of the worldwide batch. I'm gonna try downloading the Taiwan and Japan versions just to see what happens.

Frequent Visitor

Re: TV GO will not play on ASUS Android

The Xfinity TV app release today looks like it fixes Asus issues. 


Re: TV GO will not play on ASUS Android

Xfinity TV is not the same as the Xfinity tv go app. TV go still not working on Asus tablets but I am having luck with the Xfinity TV. I'll have to play with it a bit more. Thanks whereamigoing

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 10 replies
  • 0 kudos
  • 4 in conversation