Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,844,773

members

1,239

online

36,651

topics

Top

Sound but no video!

New Poster

Sound but no video!

Using the following logon: http://xfinitytv.comcast.net/watch-live-tv?cid=customer

 

Whenever I try to watch live TV (eg., CNN) the sound is perfect, the picture shows the channel and show, but there is no video.

Service Expert

Re: Sound but no video!


FRUSTRATEDDUDE9 wrote:

Using the following logon: http://xfinitytv.comcast.net/watch-live-tv?cid=customer

 

Whenever I try to watch live TV (eg., CNN) the sound is perfect, the picture shows the channel and show, but there is no video.


Ensure you have any adblocking extensions disabled for the website.... many users report turnng this off allows the video to load.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 433 views
  • 0 kudos
  • 2 in conversation