Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,873,971

members

886

online

29,066

topics

Top

STB swref desi issue

ANSWERED
New Poster

STB swref desi issue

Purchased and installed new Yamaha receiver.  Connected all devices (STB and TV) HDMI.  Receiver states a constant STB swref desi error message on the display.  HDMI signalling appears to be fluctuating in and out causing interruption in video and audio delivery.  This seems to be a known issue as there is lots of postings on the Internet.  However, there does not seem to be a specific example with X1 platform STB.

Accepted Solution

Re: STB swref desi issue

First time I have seen that error message in this forum.

Tried different inputs on the receiver? Tried different HDMI cables?

Is the firmware in the receiver up to date?
View answer in context
Gold Problem Solver

Re: STB swref desi issue

Can you provide us with more information on the error code?

Sounds like the receiver is either bad or had an incomplete firmware update?

Do you have any other HDMI devices that you can connect to test?
New Poster

Re: STB swref desi issue

The error code given is exactly as described in the Subject line.  Yes, I have a blue ray player also connected that is working fine.  From what I have seen in other postings online it seems like potentially the default settings on the STB are conflicting with the receiver.  Clearly I am not an expert in this and was hoping someone online would have seen or experienced a similar situation. A Google search turned up a plethora of postings including this one:

http://forums.audioholics.com/forums/threads/how-to-solve-stb-refsw-desi.108081/

However, as stated in my original it does not single out what to troubleshoot with the X1 platform. 

Gold Problem Solver

Re: STB swref desi issue

First time I have seen that error message in this forum.

Tried different inputs on the receiver? Tried different HDMI cables?

Is the firmware in the receiver up to date?
New Poster

Re: STB swref desi issue

Hi Rick,

Thanks for the quick response... The answer is yes again.  I have switched out the HDMI cables and tried different inputs and downloaded the latest firmware to the receiver. Not sure about the X1 STB.  It seems as though I am having an HDMI handshake issue where the STB and receiver are not communicating correctly.  I noticed there were some postings where it seems the issues were somehow connected to the 1080i or 720p default settings.  If these settings were not in alignment would it cause disruption in video signalling and if so what is the fix?

Gold Problem Solver

Re: STB swref desi issue

Try a different X1 box...

Many of the previous issues mentioned in this forum regarding Yamaha receivers involved projectors not TVs.
Service Expert

Re: STB swref desi issue


jgruitch wrote:

Hi Rick,

Thanks for the quick response... The answer is yes again.  I have switched out the HDMI cables and tried different inputs and downloaded the latest firmware to the receiver. Not sure about the X1 STB.  It seems as though I am having an HDMI handshake issue where the STB and receiver are not communicating correctly.  I noticed there were some postings where it seems the issues were somehow connected to the 1080i or 720p default settings.  If these settings were not in alignment would it cause disruption in video signalling and if so what is the fix?


My a/v receiver has two TV HDMI ports, one of which is ARC.  That port died so I just plugged the TV into the other HDMI port.  Are you saying you tried other HDMI ports for the TV?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: STB swref desi issue

Did anyone figure this out? I just bought a new Yamaha reciever and the HDMI 1 with the X1 cable box only displays "STB Refsw Desi"

unnamed.jpg
Gold Problem Solver

Re: STB swref desi issue

In a similar thread another user reported that they fixed the problem by renaming the input on the Yamaha. Apparently it is not a Comcast issue.
Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 8 replies
  • 2118 views
  • 0 kudos
  • 4 in conversation