Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,873,971

members

839

online

29,066

topics

Top

Remote quit working

New Poster

Remote quit working

My remote quit working this am.  Can anyone help?

Service Expert

Re: Remote quit working

Do you know how to change the batteries?  The XR11 remote has a small tab on the lower back; press on it and pull it down to break the seal.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Frequent Visitor

Re: Remote quit working

Or, you could take it to an Xfinity store or call 1-800-XFINITY

Regular Visitor

Re: Remote quit working

You can check the remote battery level by pressing setup until the led changes from red to green.  Then press 999.  The led will blink to indicate the battery level.  4 geen blinks is excellent, 3 is good, 2 is low and 1 red blink is very low.  If battery is good try using my account app or site to see if there is an outage or issue reported with you system.  If everything looks good and there are no outages or signals you can send out then try unpairing the remote by pressing setup till the led turns green and enter 981.  This should reset the remote and then go through the normal pairing process of pressing setup till the led turns green and then press xfinity till the remote pairing code appears on the screen

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 3 replies
  • 361 views
  • 0 kudos
  • 4 in conversation