Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,872,310

members

1,284

online

28,754

topics

Top

Re: Error RDK-03003, HELP PLEASE!

Frequent Visitor

Re: Error RDK-03003, HELP PLEASE!

Well it's not the cabling or signal strength. I had a TiVo box working just fine in the same location for years with a Comcast cable card. During debugging this problem I removed a two way splitter with a dead tail and direct connected to the cable in. Still no joy. The tivo has been flawless for over five years.
Official Employee

Re: Error RDK-03003, HELP PLEASE!


garycoryer wrote:
Well it's not the cabling or signal strength. I had a TiVo box working just fine in the same location for years with a Comcast cable card. During debugging this problem I removed a two way splitter with a dead tail and direct connected to the cable in. Still no joy. The tivo has been flawless for over five years.

What worked for your previous equipment may not work for X1. Can you give more details on your cable routing/ Which box is having issues?


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Frequent Visitor

Re: Error RDK-03003, HELP PLEASE!

Yep, turned out it was a cabling problem. Swapped the new box to run off a splitter on the run to my cable modem and it's happy now. Doesn't seem right that the new boxes are less able to lock on signal than the old boxes. But I've got the two primary boxes running. Two of the satellite units to setup this weekend.
Official Employee

Re: Error RDK-03003, HELP PLEASE!

Good to hear, comparing X1 to Legacy equipment is like comparing apples and oranges, both have different specs and configurations that optimize their use

Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 3 replies
  • 2036 views
  • 0 kudos
  • 2 in conversation