Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,841,857

members

1,364

online

36,142

topics

Top

No signal from Xi3 box

ANSWERED
New Poster

No signal from Xi3 box

Installing new Xi3 companion box.  Powers up then after about 30 secs goes to TV blue screen "no signal".  Main X1 DVR box works fine.  Whats the fix?

Accepted Solution

Re: No signal from Xi3 box

I am glad that switching your ports took care of the blue screen issue you were having @djglxxii. Normally when you get a blue screen that says no signal it is directly related to your connection from the TV to the cable box, you may use a HDMI cable, or direct coax cable, or any other means of connecting your cable box to your TV this would be the first place to check. If the service is having issues, or is disconnected for any reason there will be an error message following with black or red screen behind it. 

View answer in context
Regular Contributor

Re: No signal from Xi3 box

Sounds more like the TV is not set to the correct video input. Make sure you have the TV input set to the correct HDMI input that's connected to the Xi3.

If the Xi3 itself was having an issue, pulling the power cord and reconnecting would start it through a boot sequence, and you should see that on your TV screen. If the connection to Comcast wasn't good, then you'd see an error during the boot sequence.
Official Employee

Re: No signal from Xi3 box

Do you ever get to an activation screen? Or see any "welcome" screen?

Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: No signal from Xi3 box

TV input is set to correct HDMI slot.  After reconnecting power cord, I do see the "powering up" screen for around 15-30 secs then goes blank.

 

Related comment:  the companion box has to be 'paired' with the main DVR box, right?  I sat up DVR couple weeks ago and it continues to work fine.  But I cant find anyway for it to search for a companion box.  Is that necessary?

New Poster

Re: No signal from Xi3 box

No Andrew.  I only see powering up. Then it goes blank.

Official Employee

Re: No signal from Xi3 box

The only thing that comes to mind is that your TV isn't compatible with 720p and the box's default is 720p. Do you have a different TV to try it with?

Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Official Employee

Re: No signal from Xi3 box


Related comment: the companion box has to be 'paired' with the main DVR box, right? I sat up DVR couple weeks ago and it continues to work fine. But I cant find anyway for it to search for a companion box. Is that necessary?
_____________

Not necessary it's automatic

Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Official Employee

Re: No signal from Xi3 box

Is the blue light on or off when this happens?

Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: No signal from Xi3 box

Its a 720 tv.

 

Who knows.  Frustrating.  May have to call in for service call.

 

Thanks for trying guys.

New Poster

Re: No signal from Xi3 box

Blue light blinks for a few secs when first plugged in, then stays lit.

Service Expert

Re: No signal from Xi3 box

Try using the remoted to enter these keys -

 

exit

exit

exit

7

2

0




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: No signal from Xi3 box

Thanks but still didnt work.

 

Maybe it is a poor signal.  Its ALWAYS something with comcast.....

Official Employee

Re: No signal from Xi3 box

Have a tech out to figure it for you, 


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: No signal from Xi3 box

FYI, for anyone else experiencing this problem: I have a Sony Bravia TV and I had to switch to HDMI port 1 in order for the X1 to properly display its picture.  

Official Employee

Re: No signal from Xi3 box

I am glad that switching your ports took care of the blue screen issue you were having @djglxxii. Normally when you get a blue screen that says no signal it is directly related to your connection from the TV to the cable box, you may use a HDMI cable, or direct coax cable, or any other means of connecting your cable box to your TV this would be the first place to check. If the service is having issues, or is disconnected for any reason there will be an error message following with black or red screen behind it. 


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 14 replies
  • 1258 views
  • 0 kudos
  • 6 in conversation