Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,873,957

members

517

online

29,060

topics

Top

New X1box not working

New Poster

New X1box not working

Just upgraded to X1 and got two new X1 boxes. The main X1 box is working fine but the second box is not working. The TV screen is showing connecting to your entertainment experience. I spent more than an hour on the phone with a technician. She activated the box, sent the signal too many times, asked me to move the box to new coaxial outlet but the box is still not working. I connected the old box which I still have not returned to the same outlet and it was working fine. Any solution? Please help!

Gold Problem Solver

Re: New X1box not working

Seeing any error messages? What are they?

Secondary X1 boxes boxes must be able to see and communicate with the X1 DVR in order to work. In most cases when this happens the secondary box cannot see the DVR across the wiring in your house. You need to find out why. It could be as simple as you aren't plugging in to a live outlet.

You could always have Comcast send a tech out to investigate.
Regular Contributor

Re: New X1box not working

Rick can you message me? I have a question about the XG1v4. I’m looking for private message to contact you but don’t see it anyplace. Wondering how you got your XG1v4 to hook up through a receiver via hdmi to get both sound and picture working.
Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 2 replies
  • 297 views
  • 0 kudos
  • 3 in conversation