Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,857,893

members

1,939

online

30,037

topics

Top

Linux: XFINITY® TV requires a more recent version of Flash.

Contributor

Linux: XFINITY® TV requires a more recent version of Flash.

https://tv.xfinity.com/listings#filters=favorites

 

Firefox 49.0, Fedora 23 Linux, up to date on Flash:

 

https://www.mozilla.org/en-US/plugincheck/?utm_source=firefox-browser&utm_medium=firefox-browser&utm...

Common plugins you should check often.

 

Flash compatibility issue

 

XFINITY® TV requires a more recent version of Flash.
Please update to the latest version of Flash and ensure your browser is Flash compatible. Download the latest version of Flash

 

All I want is the TV listings with the favorite channels!

Contributor

Re: Linux: XFINITY® TV requires a more recent version of Flash.

Linux Chrome (Version 53.0.2785.116 (64-bit)) doesn't work, either.  Running chrome I get:

 

 


Now connecting to your entertainment experience

 

and it just sits there.

 

Contributor

Re: Linux: XFINITY® TV requires a more recent version of Flash.

Oh yeah, yesterday (9/28) morning it was fine using Linux Firefox or Chrome.  Please fix!!!!

New Poster

Re: Linux: XFINITY® TV requires a more recent version of Flash.

Yep, same here on Ubuntu 16.04 with latest Flash available from Adobe.

 

Flash?  Really???  No one should be developing new sites or content using Flash!

 

HTML5, please or at least allow for a "legacy" mode.

 

Naughty, Comcast; very naughty!

Contributor

Re: Linux: XFINITY® TV requires a more recent version of Flash.

xxx.png

 

Linux Adobe Flash 11.2.202.635 is the latest!

Bronze Problem Solver

Re: Linux: XFINITY® TV requires a more recent version of Flash.


rickrich wrote:

Linux Chrome (Version 53.0.2785.116 (64-bit)) doesn't work, either.  Running chrome I get:

 

 


Now connecting to your entertainment experience

 

and it just sits there.

 


Not sure if this will help you, but in the windows world, users having this problem found that they had to enable third party.cookies to get beyond "Now connecting to your entertainment experience"

Contributor

Re: Linux: XFINITY® TV requires a more recent version of Flash.

Third party cookies are enabled!

New Poster

Re: Linux: XFINITY® TV requires a more recent version of Flash.

I have the same problem.  They need to redirect  linux users to the old site until they get this fixed.

Contributor

Re: Linux: XFINITY® TV requires a more recent version of Flash.

FYI: New flash today (10/11/2016):

 

# dnf update
RPM Fusion for Fedora 23 - Free 1.7 MB/s | 457 kB 00:00
RPM Fusion for Fedora 23 - Nonfree - Updates 120 kB/s | 68 kB 00:00
google-earth 70 kB/s | 4.8 kB 00:00
google-talkplugin 35 kB/s | 2.6 kB 00:00
RPM Fusion for Fedora 23 - Free - Updates 1.3 MB/s | 323 kB 00:00
google-chrome 53 kB/s | 3.8 kB 00:00
Fedora 23 - x86_64 - Updates 5.3 MB/s | 25 MB 00:04
google-musicmanager 21 kB/s | 1.5 kB 00:00
RPM Fusion for Fedora 23 - Nonfree 817 kB/s | 156 kB 00:00
Adobe Systems Incorporated 16 kB/s | 1.8 kB 00:00
Dependencies resolved.
================================================================================
Package Arch Version Repository Size
================================================================================
Upgrading:
flash-plugin x86_64 11.2.202.637-release adobe-linux-x86_64 6.9 M

Transaction Summary
================================================================================
Upgrade 1 Package

Total download size: 6.9 M
Is this ok [y/N]: y
Downloading Packages:
flash-plugin-11.2.202.637-release.x86_64.rpm 2.6 MB/s | 6.9 MB 00:02
--------------------------------------------------------------------------------
Total 2.6 MB/s | 6.9 MB 00:02
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Upgrading : flash-plugin-11.2.202.637-release.x86_64 1/2
Cleanup : flash-plugin-11.2.202.635-release.x86_64 2/2
Verifying : flash-plugin-11.2.202.637-release.x86_64 1/2
Verifying : flash-plugin-11.2.202.635-release.x86_64 2/2

Upgraded:
flash-plugin.x86_64 11.2.202.637-release

Complete!

$

 

Same old thing, tho.

New Poster

Re: Linux: XFINITY® TV requires a more recent version of Flash.

Same here, please fix this Xfinity.  Not working with anything I try, even using browsers under wine doesn't work.

 

The error I'm seeing in the debugger:

 

Uncaught Error: Error #2014

Uncaught Error: Error: Failed conversion between PP_Var and V8 value

New Poster

Re: Linux: XFINITY® TV requires a more recent version of Flash.

Hey guys, I just figured out how to get this working.  I did it for Arch Linux specifically however, you should be able to install the same packages from a different location specific for your distro to get this working.  Full write up:

 

http://collaboradev.com/2016/10/12/how-to-xfinity-tv-and-arch-linux/

New Poster

Re: Linux: XFINITY® TV requires a more recent version of Flash.

XFINITY Please fix this regardless!!!!  As paying customers, we should be able to use the prodcts that we pay for.

 

Please provide support for HTML5, no one should be useing Flash anymore.  

If a customer is technically savy enough to be watching TV on their computer,  they are NOT using IE8.

Contributor

Re: Linux: XFINITY® TV requires a more recent version of Flash.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 12 replies
  • 3540 views
  • 7 kudos
  • 6 in conversation