Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,842,048

members

1,359

online

36,162

topics

Top

Internet Subscriber is showing false on my account information

New Poster

Internet Subscriber is showing false on my account information

so last week when i would try and stream video from the xfinity tv website i would get a subscription required error on everything i would click on. I just used it last week and it worked just fine. i logged into a friends account to see if it was my computer and theirs worked just fine. I found out that if you log into your account and go to this xfinity website it will show your user info(http://xfinitytv.comcast.net/computer). On my friends info it say Internet Subscriber:true but for some reason mine now shows false. i called customer support and for some reason they had no idea how to turn it back on. has anyone else had this issue or resolution to this issue or have any idea why it would turn off for no reason?

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 0 replies
  • 363 views
  • 0 kudos
  • 1 in conversation