Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,873,221

members

1,785

online

28,934

topics

Top

Installed Silverlight plug-in but won't play video

New Poster

Installed Silverlight plug-in but won't play video

xfinity requested that i install the silverlight plug in, which i have multiple times, but it cannot detect it apparently. keeps requiring me to install. even with multiple restarts and installs won't recognize that i've installed the player and thus refuses to play.

 

any recommendations?

Tags (1)
Official Employee

Re: Installed Silverlight plug-in but won't play video


ld28 wrote:

xfinity requested that i install the silverlight plug in, which i have multiple times, but it cannot detect it apparently. keeps requiring me to install. even with multiple restarts and installs won't recognize that i've installed the player and thus refuses to play.

 

any recommendations?


You need our patched version which you cannot get at Silverlight's website.

 

Completely uninstall Silverlight from your computer again. Then download and install Silverlight from the link below:

 

Mac users 

 

Follow all the on-screen instructions and then try playing videos again. Let me know the results.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Installed Silverlight plug-in but won't play video

That is a link for Mac,m what if I am running windows?

New Poster

Re: Installed Silverlight plug-in but won't play video

I did the same thing, but to no avail. U did not provide a link for windows users. I guess you want us to subscribe/pay for something in order to access CNN. What a joke

Official Employee

Re: Installed Silverlight plug-in but won't play video

For Windows users:

 

Windows users

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Installed Silverlight plug-in but won't play video

I used your Windows link, unistalled than reinstalled and still nothing. Screen just stays black when it usually shows that the movie or show is loading. After a few moments it just stops loading and nothing happens

Official Employee

Re: Installed Silverlight plug-in but won't play video


Heatherlanning4 wrote:

I used your Windows link, unistalled than reinstalled and still nothing. Screen just stays black when it usually shows that the movie or show is loading. After a few moments it just stops loading and nothing happens


Please go to www.xfinitytv.com/computer and copy the information you see on-screen and paste it in this thread so we can further assist you.

Also, please send the URLs of the videos that you are trying to watch.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Installed Silverlight plug-in but won't play video

Here is my User Device information, still can not watch any movie or shows on HBO or Encore. 

 

 

 

 

 

My Zip Code:98155My Cable Provider:Not InstalledMy myDVR Manager Status:UnknownMy Set Top Box Names:UnknownMy Queue setup:FalseFacebook Queue Syncing:FalseFacebook Connect:FalseMy public IP address:76.121.139.96My operating system:Windows - UndefinedMy web browser:Chrome 23 - Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, Like Gecko) Chrome/23.0.1271.97 Safari/537.11My system typeesktop Computer Or Other DeviceMy Move player version:Not InstalledMy Silverlight version:5.1.10516.0My flash version:11.5 R31Javascript:EnabledCookies:Enabled (1339 Bytes)

Official Employee

Re: Installed Silverlight plug-in but won't play video


Heatherlanning4 wrote:

Here is my User Device information, still can not watch any movie or shows on HBO or Encore. 

 

 

 

 

 

My Zip Code:98155My Cable Provider:Not InstalledMy myDVR Manager Status:UnknownMy Set Top Box Names:UnknownMy Queue setup:FalseFacebook Queue Syncing:FalseFacebook Connect:FalseMy public IP address:76.121.139.96My operating system:Windows - UndefinedMy web browser:Chrome 23 - Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, Like Gecko) Chrome/23.0.1271.97 Safari/537.11My system typeesktop Computer Or Other DeviceMy Move player version:Not InstalledMy Silverlight version:5.1.10516.0My flash version:11.5 R31Javascript:EnabledCookies:Enabled (1339 Bytes)


What specific HBO titles are you trying to watch? Please send the links.

 

Also, try using a different web browser and let me know if it works. This is not a permanent solution but it will help us narrow down your issue.

 

Do you have any anti-virus software or pop-up blocking software installed?

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Installed Silverlight plug-in but won't play video

Official Employee

Re: Installed Silverlight plug-in but won't play video


Heatherlanning4 wrote:

Tried viewing movies on Mozilla also and still had no luck.The only movie I can get to play on HBO is "Safe House", here are some of the movies that are not working.

 

http://xfinitytv.comcast.net/watch/Tinker-Tailor-Soldier-Spy/6934795956717460112/2285834898/Tinker-T...

 

http://xfinitytv.comcast.net/watch/New-Year-s-Eve/7738005584558515112/2307542879/New-Year-s-Eve-%28H...

 

http://xfinitytv.comcast.net/watch/Joyful-Noise/6896026317382030112/2308993059/Joyful-Noise-%28HBO%2...

 

http://xfinitytv.comcast.net/watch/Anchorman%3A-The-Legend-of-Ron-Burgundy/8042110496009347112/23023...

 

http://xfinitytv.comcast.net/watch/Contraband/9194442764249199112/2292882528/Contraband-%28HBO%29/vi...

 

http://xfinitytv.comcast.net/watch/Love-and-Other-Drugs/6793654968900124112/2154901046/Love-%26-Othe...

 

It literally is every movie on HBO and Encore that do not work. Except for Safe House.

 

Let me know if there is any other information I can give you, thanks for your help.


Do you have any anti-virus software or pop-up blocking software installed?

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Installed Silverlight plug-in but won't play video

Yes I do, Microsoft Security Essentials

Official Employee

Re: Installed Silverlight plug-in but won't play video


Heatherlanning4 wrote:

Yes I do, Microsoft Security Essentials


Go to your Microsoft Security Essentials settings and make sure that you are allowing Xfinitytv.com and xfinity.com to pass through your firewall. Also allow pop-ups on xfinitytv.com and xfinity.com.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Installed Silverlight plug-in but won't play video

I have the same problem. I clicked on the link and it does not go anywhere. I have a subscription to Netflix and never have a problem playing the videos on silverlight there. You guys have shows they don't. Please help!!!!

Official Employee

Re: Installed Silverlight plug-in but won't play video


jasminemarie515 wrote:

I have the same problem. I clicked on the link and it does not go anywhere. I have a subscription to Netflix and never have a problem playing the videos on silverlight there. You guys have shows they don't. Please help!!!!


Please go to www.xfinitytv.com/computer and copy the information you see on-screen and paste it in this thread so we can further assist you.

Also, please send the URLs of the videos that you are trying to watch.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Installed Silverlight plug-in but won't play video

i cant get it to work either. here is my info:

My Zip Code: Unknown My Cable Provider: Unknown Use Dac: True My Conroller ID: 132 My Map ID: 60 My Persona ID: 6868 My myDVR Manager Status: Not Installed My Set Top Box Names: Not Installed My Queue setup: False Facebook Queue Syncing: False Facebook Connect: False My public IP address: 66.229.92.124 My operating system: Mac - Undefined My web browser: Chrome 23 - Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.11 (KHTML, Like Gecko) Chrome/23.0.1271.101 Safari/537.11 My system type: Desktop Computer Or Other Device My Move player version: Not Installed My Silverlight version: Unknown My flash version: 11.5 R31 Javascript: Enabled Cookies: Enabled (2451 Bytes). Time Information My Clock Time: Thu Jan 31 2013 22:24:28 GMT-0500 (EST) Server Clock Time: Thu Jan 31 2013 22:24:14 GMT-0500 (EST)
My Account Information Primary Account: False Provider Codes: Cy, Bq, Ce, Cd, Cf, Aw, Cg, Da, Cu, Bv, B, Cz, Cr, C, Cx, Cm, Bw, D, Al, Ci, A, Y, Bx, Bb, Bc, Cp, Bu, By, Cn, Ax, Bs, At, Ct, Cb, Ch, Cs, E, Aj, Cv, Bm, Co, Bl, Bk, Cw, Bo, Cc, Bn Internet Subscriber: True Cable TV Subscriber: True Voice Subscriber: True
 
Official Employee

Re: Installed Silverlight plug-in but won't play video


quigleydesigns wrote:

i cant get it to work either. here is my info:

My Zip Code: Unknown My Cable Provider: Unknown Use Dac: True My Conroller ID: 132 My Map ID: 60 My Persona ID: 6868 My myDVR Manager Status: Not Installed My Set Top Box Names: Not Installed My Queue setup: False Facebook Queue Syncing: False Facebook Connect: False My public IP address: 66.229.92.124 My operating system: Mac - Undefined My web browser: Chrome 23 - Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.11 (KHTML, Like Gecko) Chrome/23.0.1271.101 Safari/537.11 My system type: Desktop Computer Or Other Device My Move player version: Not Installed My Silverlight version: Unknown My flash version: 11.5 R31 Javascript: Enabled Cookies: Enabled (2451 Bytes). Time Information My Clock Time: Thu Jan 31 2013 22:24:28 GMT-0500 (EST) Server Clock Time: Thu Jan 31 2013 22:24:14 GMT-0500 (EST)
My Account Information Primary Account: False Provider Codes: Cy, Bq, Ce, Cd, Cf, Aw, Cg, Da, Cu, Bv, B, Cz, Cr, C, Cx, Cm, Bw, D, Al, Ci, A, Y, Bx, Bb, Bc, Cp, Bu, By, Cn, Ax, Bs, At, Ct, Cb, Ch, Cs, E, Aj, Cv, Bm, Co, Bl, Bk, Cw, Bo, Cc, Bn Internet Subscriber: True Cable TV Subscriber: True Voice Subscriber: True
 

What error message are you getting when trying to play a video online?

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 16 replies
  • 6733 views
  • 0 kudos
  • 7 in conversation