Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,843,453

members

612

online

36,424

topics

Top

I lost the X11 TV app connection.

Regular Visitor

I lost the X11 TV app connection.

Lost the connection on iPad and iPhone.  Screen tells me service is available in my area, I log in to add device, but it takes me right back to Service available page. 

 

I tried to call comcast last night...spoke to TV rep...the transferred to wireless...then to app dept....then back to TV. That's when I hung up because I was tired of the run around and giving my account info again  and again. 

 

any ideas on what dept to call and if it's been solved before, can I give them some direction? 

Service Expert

Re: I lost the X11 TV app connection.


Salgal33 wrote:

Lost the connection on iPad and iPhone.  Screen tells me service is available in my area, I log in to add device, but it takes me right back to Service available page. 

 

I tried to call comcast last night...spoke to TV rep...the transferred to wireless...then to app dept....then back to TV. That's when I hung up because I was tired of the run around and giving my account info again  and again. 

 

any ideas on what dept to call and if it's been solved before, can I give them some direction? 


on a desk/laptop use a browser to go to http://xtv.comcast.net and login. If it works there try uninstalling and reinstalling the smart device apps.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 287 views
  • 0 kudos
  • 2 in conversation