Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,859,006

members

1,162

online

29,075

topics

Top

HD Channel not working

New Poster

HD Channel not working

I watch and record shows off BravoHD. Tonight I went over to my channel and it says I need a subscription to watch. Obviously it's part of my package so why is it not working? I never had issues with my old hd box but I moved and switched to a X1 DVR.

Fix this please.
Problem Solver

Re: HD Channel not working

Sorry to tell you this, but I really believe you need to call in and speak to Billing to get this taken care of.  This happened to me when I had x1 installed.  I needed to talk to someone in Billing to get the proper codes added to my account.  Good luck.

 


Mzgreen wrote:
I watch and record shows off BravoHD. Tonight I went over to my channel and it says I need a subscription to watch. Obviously it's part of my package so why is it not working? I never had issues with my old hd box but I moved and switched to a X1 DVR.

Fix this please.

 

Service Expert

Re: HD Channel not working


Mzgreen wrote:
I watch and record shows off BravoHD. Tonight I went over to my channel and it says I need a subscription to watch. Obviously it's part of my package so why is it not working? I never had issues with my old hd box but I moved and switched to a X1 DVR.

Fix this please.

As HowAboutThisOne stated, many times when you upgrade services, the Billing CSR's do not put the rate codes back in properly for what you had before...   example, I just had cloud enabled and my entire rate code had to be erased and put back in correctly inorder for the cloud to work!!!   Call into Comcast and have them ensure the proper codes are on your account!!!




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 2 replies
  • 313 views
  • 0 kudos
  • 3 in conversation