Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,860,067

members

1,416

online

29,285

topics

Top

Error message 400

New Poster

Error message 400

I am receiving error message 400 for the past month.  No one from tech support seems to have a solution for me.  I did the clearing of cache and cookies, uninstalled and reintalled silverlight, I have latest versions of flash player, firefox...I have HBO, Preferred Collection, Encore, TBS, etc and none are working.  I get the same error message.  Please help.

New Poster

Re: Error message 400

same here - all apps up to date and silverlight reinstalled.  happens on IE and Firefox.  it used to work great but then became inconsisten about two weeks ago.   this is happening with all premium channels, Hulu works fine.

 

Please help, this is the primary reason I keep my comcast service, watching movies on the computer.

Silver Problem Solver

Re: Error message 400

Try this.,

 

1. Log into Comcast Customer Central (the normal login to manage your account). 2. Go to: http://xfinity.comcast.net/profile/ 3. Look to the right of the page (you may have to scroll down) under a box with the header "Devices & Diagnostics." 4. Scroll down within that box and click on the link called "Authorized PC devices." 5. You will see the following message: "In order to protect your account from abuse, there is a 3 device limit per Comcast Digital Cable subscription. Please manage your devices below. Removed devices can be added again upon next use." 6. When I navigated to this page, I discovered that the "3 devices" listed were ALL MY ONE SAME DEVICE I've been using to access my premium content (Showtime / HBO) online. Xfinity was not recognizing my various logins from the same device (my Mac) as such---but instead recognizing each subsequent login as a "new device." Apparently clearing the cache, etc. does not fix this. 7. I simply clicked "REMOVE" for all "three devices" (actually just my one device, but listed as "three devices" from three separate logins), thus completely clearing the list and thereby removing the block triggered by Xfinity's aforementioned "3 device limit." 8. I then logged out completely, cleared my cache just to be sure, launched Firefox again, accessed Xfinity TV online and guess what? Those annoying orange "locked" buttons have been replaced with pretty green "play" buttons once again, and I can watch my premium content online. ----- You might have "3 devices" (possibly from actually reaching your 3 device limit, but possibly also just from multiple logins from a single device) listed in this section of your account. Once you hit the "3 limit," Comcast locks you out of premium content on what it seems to be perceiving as "any device beyond your 3 device limit." Delete these "3 devices" (as it says, you effectively add them back when you log in again, so deleting can do no harm), log out, clear your cache, close and reopen your browser, and then log back in again

 

 

If that does not work, make sure your zip code is correct when you go to the my account tab top of this page.  

 

Also you can try uninstalling silverlight and then restart your computer then reinstall it.  If that does not work try turning off any pop up blockers or firewalls and antivirus.  

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Labels
Discussion stats
  • 2 replies
  • 663 views
  • 1 kudo
  • 3 in conversation