Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








Cannot Access Xfinitiy TV Remote on Tablet

Regular Visitor

Cannot Access Xfinitiy TV Remote on Tablet

I have watched/streamed content before on this tablet - Samsung Galaxy tab 3.0 (not the latest 4.0). However, now I want to be able to download the content and watch it later offline. I installed the app but when I try to sign in (using email and password), I receive a message to "enter a valid id and password." I have re-entered multiple times. The id and password I am using IS valid. If I go to comcast.com via the browser, I access successfully using the same id and password. I tried uninstallling and reinstalling the app and stil the same result. Does anyone have any idea how to fix this? Thanks!!

Regular Contributor

Re: Cannot Access Xfinitiy TV Remote on Tablet

Can you direct message me with your comcast ID so we can try to resolve?

Regular Visitor

Re: Cannot Access Xfinitiy TV Remote on Tablet

I just sent it to you.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation