Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,844,674

members

1,306

online

36,639

topics

Top

Can't watch premium content...again!

New Poster

Can't watch premium content...again!

Every time I transfer my Comcast services to a new address, the premium channels that I am subscribed to get disabled in xfinitytv.com. This is the FOURTH time this has happened. I contacted a customer service agent who said that he needed to finish transferring the accounts, since the new account was set up for some reason with no email address/Comcast ID rather than my existing one. That is done, but the videos still won't play. The message still says that I am not subscribed. It took several tech support people working on this each of the previous times. Why is it so difficult? 

 

I have all of the necessary software, and my computer settings are correct. I just watched a video online last week under the old account. It is NOT a problem on my end. 

Tags (1)
New Poster

Re: Can't watch premium content...again!

Other problems I am having with the new cable box and account include the Xfinity TV mobile app cannot pair with the cable box/DVR. The new box should be compatible with the app. 

 

MyDVR manager isn't working, although I have a brand new box that should have this capability. I get a message saying no eligible device is detected. I have a Motorola RNG200N box. 

 

Finally, on my account, under my devices, I get no information on my devices but a message saying "the problem appears to be on our end. Check back later."  

 

Did the technician not actually get the new box registered to my account? I heard him call in the modem to register it yet I still had to do the modem registration again myself a couple of days later when my internet was interrupted and Comcast resent the registration/activation links. 

 

Official Employee

Re: Can't watch premium content...again!


aicabsolut wrote:

Other problems I am having with the new cable box and account include the Xfinity TV mobile app cannot pair with the cable box/DVR. The new box should be compatible with the app. 

 

MyDVR manager isn't working, although I have a brand new box that should have this capability. I get a message saying no eligible device is detected. I have a Motorola RNG200N box. 

 

Finally, on my account, under my devices, I get no information on my devices but a message saying "the problem appears to be on our end. Check back later."  

 

Did the technician not actually get the new box registered to my account? I heard him call in the modem to register it yet I still had to do the modem registration again myself a couple of days later when my internet was interrupted and Comcast resent the registration/activation links. 

 


Our team is looking into your issue now. Someone will contact via phone within the next 72 hours. If they do not reach you, they will leave a message so please check your messages.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Can't watch premium content...again!

Someone called while I was at work this afternoon and said they made changes to my account to resolve the issue. Since I was on a computer not authorized for XfinityTV playback, I could not check on my account. The channels are still not working. The agent was also unaware of the other problems. 

 

The agent said that my account had been set to "restricted" for viewing xfinitytv online. This is the same problem I have experienced 3 times before. why can things not be set up correctly by Comcast from the start? Nevertheless, changing my account to unrestricted still hasn't resolved the problem. 

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 3 replies
  • 664 views
  • 0 kudos
  • 2 in conversation