Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,727,462

members

12

online now

1,889,359

discussions

Back to Top

iOS TV Remote App - no devices

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 6
284 Views

All devices are gone and there is no way to add them back in the TV Remote app for iOS.  This was not fixed in the latest release so the problem persists. Without the ability to change channels the app is not very useful. 

5 REPLIES
Posted by
Official Employee

Message 2 of 6
247 Views

Thank you for writing in! We've had reports of disappearing devices via app reviews for some time now, and it started happening between app releases, which points strongly to it being a problem on the API side—but we needed an actual user account to investigate. We'll start digging in to see what happened. Thank you for your patience, and apologies for the inconvenience in the meantime. 

 

LHC




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 6
215 Views

The App seems to be working normally again.  Thanks for fixing. 

Posted by
Official Employee

Message 4 of 6
174 Views

So the thing is: We didn't. We haven't changed the app at all, and afaik no back-end services were changed, either.... which leads me to believe that the request to get your device list is failing sometimes, and when it does, the app treats it as if all your devices have been removed from your account. Device removals are somewhat common—people trade in or upgrade equipment all the time—but not so frequent that we shouldn't bias toward assuming that if we have a device or devices and then are told there are 0, we should keep the existing set instead overwiting it with an empty one. Will get that onto the team's radar.

 

Thanks again for posting.

 

LHC




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 6
125 Views

I have this same problem with no devices that has persisted since moving to a new address last month.  Since relocating to this new address, my existing X1 box, as well as an added box do not show up as devices.  Disappointing. 

 

In the application, under settings-> edit devices, it states: YOU HAVE [0] TVS SET UP WITH XFINITY REMOTE.  YOU CAN NAME THEM FOR EASIER IDENTIFICATION.

 

App version is 3.07.204

Posted by
Official Employee

Message 6 of 6
98 Views

That sounds like a slightly different problem than the one I described above, even though the result is the same (no boxes show up). Moves can wreak havoc on accounts—usually because you get a new account when you move. :-/ Can you try signing out and back in again?

 

LHC




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon