Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,727,462

members

12

online now

1,889,359

discussions

Back to Top

Xfinity Stream on Roku Missing all my HD channels???

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 13
373 Views

I signed up for xfinity a few days ago.  Everything was working great on my Roku.  When I went to live Tv, only the channels I was subscribed to showed up.  I could watch every channel I was subscribed to w/o issue on my roku.

Now, I am having problems..

Lots of channels now show up under LiveTv which I am not subscribed to.  More importantly ALL of my HD channels are missing.  When I search for one of the missing channels it says channel not found. When I filter the channels, i no longer have the options of choosing HD channels.

 

The missing channels still show up and work w/o issue on both my phone and PC using xfinity stream.

12 REPLIES
Posted by
Service Expert

Message 2 of 13
348 Views

cashedoutent wrote:

I signed up for xfinity a few days ago.  Everything was working great on my Roku.  When I went to live Tv, only the channels I was subscribed to showed up.  I could watch every channel I was subscribed to w/o issue on my roku.

Now, I am having problems..

Lots of channels now show up under LiveTv which I am not subscribed to.  More importantly ALL of my HD channels are missing.  When I search for one of the missing channels it says channel not found. When I filter the channels, i no longer have the options of choosing HD channels.

 

The missing channels still show up and work w/o issue on both my phone and PC using xfinity stream.


generally you can logout of the app, uninstall it. then install it again and login and the app will return to working again.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 13
342 Views
I have done that and also powered down, etc.
Posted by
Service Expert

Message 4 of 13
333 Views

cashedoutent wrote:
I have done that and also powered down, etc.

logout of the app. call 800-Comcast and select billing. ask the billing representative to do a deep background database refresh (will take about an hour). then login and see if it fixed the problem.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Admin1

Message 5 of 13
261 Views

Hi cashedoutent -- I can help with your channel issue. I did want to check in first to see if this issue has cleared itself or not. 




Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 13
202 Views

I am having the same problem. I was able to get HD channels on Rokuy before, but not anymore. Still able to get HD channels on the iPad app.

Posted by
Service Expert

Message 7 of 13
189 Views

frakseno wrote:

I am having the same problem. I was able to get HD channels on Rokuy before, but not anymore. Still able to get HD channels on the iPad app.


on your monthly cable bill, do you see a line for Hd technology fee $10 ?  




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 13
159 Views

This problem occurs for me as well.  All was well on the Stream app for a time, but after a restart the HD channels disappeared.  My cable package includes HD but there's no separate HD charge on my bill.  This is apparently not an uncommon  problem.  What should I do or ask for?

Posted by
Service Expert

Message 9 of 13
151 Views

Rsolie wrote:

This problem occurs for me as well.  All was well on the Stream app for a time, but after a restart the HD channels disappeared.  My cable package includes HD but there's no separate HD charge on my bill.  This is apparently not an uncommon  problem.  What should I do or ask for?


do your local rebroadcast channels appear in HD?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 10 of 13
130 Views

No local channels, or any other channels, appear in HD.  The app worked fine until yesterday even though I have no HD line on my bill.  When I call support what do you suggest I tell the CSR?

 

Thanks for your help it's a real public service.

Posted by
Service Expert

Message 11 of 13
126 Views

Rsolie wrote:

No local channels, or any other channels, appear in HD.  The app worked fine until yesterday even though I have no HD line on my bill.  When I call support what do you suggest I tell the CSR?

 

Thanks for your help it's a real public service.


a couple of months ago the decision was made to stop HD if there was no separate bill line for HD technology. I suspected it was a billing test that would later be a separate line for Roku outlet charge (currently free) but again, just my guess. The question came up when the HD went away and the answer was 'if' HD was included in the subscriber's package but not charged separately then the Roku would not have HD access. That's where the subject has stayed. I doubt any CSR could fix it while in beta.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 12 of 13
43 Views

Rustyben and ComcastPhil (and others):

After some time on the phone with a first-level CSR he discovered that HD authorization cannot be added to my account because I'm using a CableCard device for TV tuning and not a Comcast STB.  So I'm out of luck I guess for using the Stream beta on a ROKU.  There are alternatives, so no big whoop, but still a PITA.  HD works elsewhere for me but not for this app on ROKU.  Five days ago my account was modified to "Digital Starter" without telling me (by whom is not clear) and that seems to be what caused HD on the Stream app to stop working.  Go figure.  This is all still pretty murky so I'll keep trying.  Any thoughts?

Posted by
Official Employee

Message 13 of 13
13 Views

Hi Rsolie, I can look into getting HD added on your account for you, please let me know and we can try.

 

Thank you




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon