Xfinity plant
Xfinity globe
Community Forum

Xfinity Stream Beta App/Samsung TV not working

New Poster

Xfinity Stream Beta App/Samsung TV not working

The Streaming Beta App won’t load. I was working fine, then the screen froze, and app crashed. Now when I open the app all I get is a black screen, and when I try playing content previewed in the smart hub it just says “Xfinity Stream Beta Loading” for way too long until it just stops trying. I reinstalled it, deleted and reinstalled it, unplugged the TV, reset the Smart Hub... I’m connected to my Xfinity wifi, TV is model (MU6290), updated firmware, plenty of free memory, logged in to my Samsung acct. and EVERY other app is working fine. Any ideas?
Expert

Re: Xfinity Stream Beta App/Samsung TV not working


@amtmlt wrote:
The Streaming Beta App won’t load. I was working fine, then the screen froze, and app crashed. Now when I open the app all I get is a black screen, and when I try playing content previewed in the smart hub it just says “Xfinity Stream Beta Loading” for way too long until it just stops trying. I reinstalled it, deleted and reinstalled it, unplugged the TV, reset the Smart Hub... I’m connected to my Xfinity wifi, TV is model (MU6290), updated firmware, plenty of free memory, logged in to my Samsung acct. and EVERY other app is working fine. Any ideas?

is that a Roku TV? (built in)

New Poster

Re: Xfinity Stream Beta App/Samsung TV not working

Any luck? Same problem here
Expert

Re: Xfinity Stream Beta App/Samsung TV not working


@Jacobcooke6490 wrote:
Any luck? Same problem here

does the xfinity stream app appear in your TV set's 'store'?