Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,650,626

members

13

online now

1,826,141

discussions

Back to Top

UHD sampler App

SOLVED
Posted by
Problem Solver

Message 1 of 13
3,058 Views

I have been using the Xfinity Ultra High Definition Sampler App on my Samsung UHD 3D smart TV since the middle of March 2016 without any problems.

 

Xfinity has finally added some new 4K shows and removed a few others. Since this change I tried watching some of the new material.

 

The app loaded fine, the new shows and others showed up normally.

 

The problem occured when choosing a show and clicking "Watch" icon. The download (3 dots blinking) indicator showed as usual but the show never started. Shows normally start with 15 to 60 seconds and stream without problems. I waited up to 15 minutes with nothing happening. I checked different show offerings without luck. I exited app and signed on app again with no luck getting any shows to start and stream.

 

I suspect the updating of programing on the app may have altered the program code for the app.

12 REPLIES
Posted by
Problem Solver

Message 2 of 13
3,032 Views

Yesterday I tried the Comcast "Chat" with the same question. The message that I would be connected shortly never happened after about 30 minutes.

Is the "Chat" working? 

 

I assume the UHD App is only used by a few of us who have a Samsung UHD TV and are even aware of this app. I hope someone from Comcast can address this issue.

 

Posted by
Problem Solver

Message 3 of 13
3,005 Views

Today, 7/5/16, I just got through on the "Chat" line to ask about the UHD App. I would rate the help given by (name withheld) as "F".

 

He tried to tell me the App was discontinued last year in 2015. Nice try since I just got the information for down-loading the UHD App from our local Xfinity office about 3 months ago. I downloaded and watched about 50 episodes of 4K programing over the last 3 months with absolutely no problems.

 

The app just recently in last few weeks had new episodes added, and a few others removed. The app no longer functions correctly. I have owned and programed computers since 1979. It is rather obvious the a programer messed up the operation of the app.

 

I hope someone from Comcast with real knowledge of the company's computer operations can give me a correct answer to the current situation.

 

 

Posted by
Problem Solver

Message 4 of 13
2,987 Views

I just viewed more Xfinity information about the UHD sampler app and found some stating LG Tv's from 2016 also work with the app. So the app still exists and is being used at this time.

 

Any other owners of UHD TV's been using this app recently?

 

Posted by
Problem Solver

Message 5 of 13
2,960 Views

Today I deleted the version of the app I had in my Samsung TV memory. Then used the search function for locating apps not found in the TV's recomended list. I took a about 4 trys to get the name of the app right "Ultra HD Sampler". I down-loaded the app and found it to be the same version as the one deleted.

 

So no luck in getting it to work. I did this to eliminate the posibility of a corrupted file from using the original down-load.

 

 

Posted by
Problem Solver

Message 6 of 13
2,844 Views
Solution

I am pleased to inform you that my Samsung UHD TV just got another update (2nd since January 2016) this morning, 7/14/16.

 

I just tested the UHD Sampler App and it it functioning normally now. The update may have fixed an incompatibility issue for using the app.

Posted by
Problem Solver

Message 7 of 13
2,792 Views

I can now watch a chosen episode on the UHD Sampler app ONLY if I refrain from pushing any controls on my remote unit the episode finishes playing and returns to the Sampler app menu.

 

All streaming video apps require the use of my Samsung UHD TV remote which has about 20% of the buttons found on the Xfinity remote. Running "On Demand" on cable using the Xfinity remote always works trouble free.

 

The basic problem I found with this app is that the control codes using by the computer are not the same as my Samsung remote. Evidently commands like: Pause, Stop, Resume, etc. do not function. The error traping used in the program code is insufficient and the program bombs. No picture except for Srreaming icon symbol (3 blinking dots).

 

I suspect this problem is the cause of many complaints found on other streaming video apps. I can currently live with the problem by leaving the remote along until the choosen episode finishes.

Posted by
Problem Solver

Message 8 of 13
2,736 Views

I ran into one of the things that can cause the app to freeze or never load (3 dots blinking and no show).

 

The Samsung UHD TV cannot be used in "Sports Mode" which doubles the refresh rate (120HZ versus 60HZ in standard mode).

 

Not all apps using streaming video are not created equal. When viewing 4K video on You Tube no problems occur at either refresh rate.

 

I now know that the UHD Sampler app is not programed and utilizing a large enough buffer to handle the newer televisions that can speed up the refresh rate.

 

The app worked fine when put the TV back on standard fresh rate, and brought back the app to watch the episode that just failed.

Posted by
Problem Solver

Message 9 of 13
2,658 Views

I guess I should be happy the app is still functioning. To stream 4K programing it requires by far more broadband and speed.

 

The majority of Comcast's (and all their competition for that matter) problems is related to advertising for more customers and the inability to increase broadband service fast enough to keep the system running reliably.

 

Even this forum came grinding to a halt for while yesterday.

 

 

Posted by
Problem Solver

Message 10 of 13
1,873 Views

Just an update on 9/14/16.

 

Since the latest update in August (2016_8_26) the app has continued to work fine on my Samsung TV. They have added the 2016 season to "Outlanders" and not much else since spring for 4K regular network programs. They still have the Rio Olympics provided in regular 4K, and HDR/4K. I have watched all of the older available 4K programing without problems.

 

I would like to see more 4K programing soon from Comcast to make up for their debacle in delivering 4K for the majority of customers with UHD (and/or 3D) televisions.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 11 of 13
1,677 Views

I just get 3 dots whenever I try to play any episode in this app. I deleted and redownloaded the app , tried to update the firmware of my TV UN65JU7500 but my TV was already at version1462 which was the latest version. I am still not able to play anything on this app. Please help

Posted by
Problem Solver

Message 12 of 13
1,618 Views

When we got home today, 10/14/65, I found a new Samsung UHD TV update "1463". I did the update and the "Ultra HD Sampler" app finaly worked again for me. It is possible that Comcast fixed the app since last Monday.

 

Do the update to 1463 and maybe the app will work for you too.

Highlighted
Posted by
Visitor
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 13 of 13
924 Views

Hi if anyone is still following this thread.  Just got an OLED LG TV and I can't get this app to ever start.  Just the three loading dots.  one time it came up and asked me to activate and it was successful online activating but the app never responded to the activation.  Help would be appreciated.