Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,625,820

members

8

online now

1,804,932

discussions

Back to Top

All Cloud DVR Recordings Disappeared

Posted by
Frequent Visitor

Message 1 of 23
1,084 Views

Yesterday all of my cloud DVR recordings disappeared from all of my devices--iPad, iPhone, computer, etc. The recordings are still on my physical DVR box. Even the recordings that I had downloaded to my iPhone disappeared. At some point earlier in the day when I started up the app on my iPhone, it seemed like it could not connect to the network or server or something and got would sort of get stuck during the process. A while later, when I was able to fully start up the app, all recordings were gone. When I checked my iPad and the computer web app, all recordings were gone from those, too. They just showed zero recordings. I could see the scheduled recordings, though.

One of the tech support folks I spoke to said he saw all the recordings still existed, and he tried some kind of refresh. That did not help. The Tier 2 person I spoke to said to try running "Sync DVR" from the Xfinity menu on my DVR box at home. That did not help, either. I tried uninstalling and reinstalling the apps, still nothing.

It does seem that anything NEW recorded after this happened ARE showing up on the cloud. But anything recorded before is gone. And there were a lot of recordings.

Any idea what could have happened? And any idea how to refresh the cloud DVR so that all of my previous recordings are available again?

22 REPLIES
Posted by
Frequent Visitor

Message 2 of 23
1,069 Views

It's almost as if, at some point yesterday, whatever database contains the list of cloud recordings available to my account was wiped out and reset. And running "Sync DVR" from my DVR box does not repopulate this database. Just speculating.

Posted by
Service Expert

Message 3 of 23
1,064 Views

JavaJed wrote:

Yesterday all of my cloud DVR recordings disappeared from all of my devices--iPad, iPhone, computer, etc. The recordings are still on my physical DVR box. Even the recordings that I had downloaded to my iPhone disappeared. At some point earlier in the day when I started up the app on my iPhone, it seemed like it could not connect to the network or server or something and got would sort of get stuck during the process. A while later, when I was able to fully start up the app, all recordings were gone. When I checked my iPad and the computer web app, all recordings were gone from those, too. They just showed zero recordings. I could see the scheduled recordings, though.

One of the tech support folks I spoke to said he saw all the recordings still existed, and he tried some kind of refresh. That did not help. The Tier 2 person I spoke to said to try running "Sync DVR" from the Xfinity menu on my DVR box at home. That did not help, either. I tried uninstalling and reinstalling the apps, still nothing.

It does seem that anything NEW recorded after this happened ARE showing up on the cloud. But anything recorded before is gone. And there were a lot of recordings.

Any idea what could have happened? And any idea how to refresh the cloud DVR so that all of my previous recordings are available again?


some information first: comcast uses a cloud(server)-based sceduler program. It tells your DVR(s) in your home what and when to record. If you have cloud DVR, the same scheduler also tells the cloud DVR to record same programming. The recordings that are physically on your home DVR device(s) is not used by the cloud DVR. Your home X1 equipment can play cloud recordings that did not get recorded for whatever reason on the home DVR (example: power failure at your home).

 

the sync DVR intent is to have the cloud scheduler update your DVRs primarily if you replace a DVR so that upcoming programs are programmed into the DVR ASAP.

 

re disappearing, do you see the recordings when you go to xtv.comcast.net and login using a browser on a desk/laptop computer?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor

Message 4 of 23
1,050 Views

Rustyben wrote:

JavaJed wrote:

Yesterday all of my cloud DVR recordings disappeared from all of my devices--iPad, iPhone, computer, etc. The recordings are still on my physical DVR box. Even the recordings that I had downloaded to my iPhone disappeared. At some point earlier in the day when I started up the app on my iPhone, it seemed like it could not connect to the network or server or something and got would sort of get stuck during the process. A while later, when I was able to fully start up the app, all recordings were gone. When I checked my iPad and the computer web app, all recordings were gone from those, too. They just showed zero recordings. I could see the scheduled recordings, though.

One of the tech support folks I spoke to said he saw all the recordings still existed, and he tried some kind of refresh. That did not help. The Tier 2 person I spoke to said to try running "Sync DVR" from the Xfinity menu on my DVR box at home. That did not help, either. I tried uninstalling and reinstalling the apps, still nothing.

It does seem that anything NEW recorded after this happened ARE showing up on the cloud. But anything recorded before is gone. And there were a lot of recordings.

Any idea what could have happened? And any idea how to refresh the cloud DVR so that all of my previous recordings are available again?


some information first: comcast uses a cloud(server)-based sceduler program. It tells your DVR(s) in your home what and when to record. If you have cloud DVR, the same scheduler also tells the cloud DVR to record same programming. The recordings that are physically on your home DVR device(s) is not used by the cloud DVR. Your home X1 equipment can play cloud recordings that did not get recorded for whatever reason on the home DVR (example: power failure at your home).

 

the sync DVR intent is to have the cloud scheduler update your DVRs primarily if you replace a DVR so that upcoming programs are programmed into the DVR ASAP.

 

re disappearing, do you see the recordings when you go to xtv.comcast.net and login using a browser on a desk/laptop computer?

No, the recordings are gone from every cloud access point (xtv.comcest.net, iPhone, iPad, etc.). Before yesterday, my cloud DVR was about 70% full. Yesterday everything disappeared and my cloud DVR went to 0% full. All recordings are still on my physical DVR box at home. And any new recordings starting from last night do show up on the cloud. My cloud DVR is now about 5% full. And it's not as if I deleted them and they went to the deleted folder. That is empty as well.

 

One odd thing happened during all of this yesterday: I had several recordings downloaded to my iPhone, and I was watching one of them in the morning. I was about halfway through one of the recordings when I paused it, and went about my morning. A couple hours later, when I went back to my phone and clicked on the app, it took a long time to start up and connect, and when it did, recordings were at 0%, downloads were gone, etc. BUT, the program I had been watching still appeared in that little popup bar at the bottom of the screen that shows what you were most recently watching and lets you resume watching it. I clicked that popup and the program I was watching resumed playing from where I had left off, even though the downloads were gone and the recordings were at 0%. I watched it to the end and that window popped up to delete or return to recordings. I couldn't delete it because it said it said it was still being streamed.

 

So it was able to still play a phantom recording that supposedly no longer existed.

Posted by
Service Expert

Message 5 of 23
1,032 Views

JavaJed, I have contacted a red-letter comcast team member to ask for review of this thread (for assistance). 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor

Message 6 of 23
1,023 Views
Posted by
Frequent Visitor

Message 7 of 23
996 Views

I've had some contact with an Admin, who insists that this would only have happened if I had accepting Terms & Conditions, which would reset things:

I do know what causes that to happen. Anytime you accept the Terms & Conditions for Cloud service, it starts everything over. Meaning that anything that was stored to Cloud prior to last night, when you accepted those terms, got erased and now it starts over.

I responded to clarify:

No, none of this was related to accepting Terms & Conditions. Nothing changed in my iPhone app or on the web app when this happened, other than they seemed to be struggling with trying to connect to the cloud (one was on a 4G network, another on separate, wired ethernet connection). Prior to this, all devices showed recordings at 70% full. But the cloud was wiped out from all connected devices after that, down to 0%, nothing in the deleted folder. Of course eventually I had to try uninstalling the app, reinstalling, logging in again, accepting the Terms & Conditions again, etc., but this was after the cloud was already wiped out. Programs recorded since yesterday evening are showing up in the cloud.

He again insisted I had caused this:

Everything I'm showing has to do with accepting those Terms & Conditions again. There may have been a server error that was causing connection issues to begin with but Cloud recordings being wiped out happens when those Terms & Conditions are re-accepted. As you've stated, everything that's been recorded after accepting is now showing up.

So I FURTHER clarified:

No, there definitely wasn't any accepting of Terms & Conditions until much later in the day, in the evening, long after the recordings disappeared. The recordings disappeared in the morning. I never logged out of the app or the web app or anything until much later in the day. I uninstalled and reinstalled the app in the evening, many hours after this occured. The cloud recordings disappeared from ALL connected devices on our account, in the morning, without anyone accepting Terms & Conditions on any of the devices. In fact, the first new recording I set yesterday evening showed up in the cloud on my iPhone app BEFORE I uninstalled, reinstalled, and accepted Terms & Conditions.

There was a server error in the morning, and immediately after all cloud recordings were gone. I've had my devices connected and working with the cloud for a long, long time, and I would have no reason to log out or uninstall and reinstall the app and accept Terms & Conditions, especially not on ALL connected devices.

So to clarify the sequence of events:

  1. On the evening of 9/12 my cloud DVR was approximately 70% full. I had about four recordings downloaded to my iPhone. At this point I had three devices connected to the cloud (iPhone, iPad, computer) which had been connected to the cloud DVR and working (mostly) properly for approximately two years.
  2. At 8AM on 9/13, my cloud DVR was still about 70% full. I began watching one of my downloaded programs on my iPhone. About halfway through the program, I paused it, closed the app, and left it alone.
  3. Around 11AM I picked up my phone and started the app. It was connected to WiFi and a 4G network. During startup it started "spinning its wheels." I could see it trying to connect to the Xfinity servers, but it kept trying for a long time, and was unable to populate the "Just Recorded," "Recently Watched," and "Recent Channels" sections of the main screen. At the bottom of the screen, the little popup button that shows what you were most recently watching did show the program I had been watching, but trying to play it did not work. That also was "spinning its wheels" trying to load, despite being downloaded to my phone.
    1. I checked xtv.comcast.net on my computer (one of my connected devices) and it ALSO was unable to connect and populate any of those sections in the app.
  4. A little while later (say, around noon or 1pm) I checked the app again. This time it eventually connected, but showed zero recordings and zero downloads. It did list upcoming scheduled programs. Oddly, despite listing no recordings or downloads, it did still list the program I had been watching at the bottom, and how many minutes were remaining. I was able to click that and resume watching the program (a program that supposedly didn't exist on my phone or the cloud). And it was definitely playing a recording, not an On-Demand version, since it was a CBS program that isn't available for On-Demand until a week after it airs (an oddity with CBS).
  5. I finished watching the program on my phone early in the afternoon. When I reached the end, rather than popping up with "Return recording?" it popped up with "Delete program?" (which tells me it was playing form the cloud, not the download that used to be on my phone). I tried deleting it, but received a message saying it couldn't be deleted because it was streaming on a device.
    1. My iPhone still showed zero recordings and downloads, and no history or recent recordings or recently watched programs.
  6. I spoke to several people at Comcast tech support who tried to diagnose the problem, but could not. The only advice they could give was to try uninstalling and reinstalling the app. They seemed to think that would allow my devices to reconnect to the cloud and repopulate the past recordings. From past experience, though, I was pretty sure that doing this would prevent me from accessing any previous recordings, only future ones. So I did not follow their advice yet.
  7. Later in the afternoon, after receiving little help from Comcast tech support, I tested logging out and logging back in on xtv.comcast.net on my computer. This prompted me to accept Terms & Conditions. I logged back in, but the situation had not improved.
    1. I DID NOT log out of my iPhone app, nor did I uninstall it and reinstall it, or anything else that would have prompted for Terms & Conditions on my phone. So NOTHING changed on my iPhone app. My account remained connected on my iPhone throughout all of this. (Additionally, in the past, I have, for example, logged out and back in on my iPad, which did reset the cloud recordings on that device, but did not effect the cloud recordings or downloads on my iPhone or web app.)
  8. In the evening I checked my DVR, which still had all recordings, approximately 70% full. I set a new recording for 8PM.
    1. I also checked my iPad, which hadn't been touched during all of this. That also showed zero recordings.
  9. At 8PM, the program I had set started recording on my DVR. I checked my iPhone, and it DID show that new recording being recorded. This is BEFORE logging out or anything on my iPhone. So, to repeat, without changing anything on my iPhone, new recordings were showing up on the cloud. But my previous recordings still did not show up on any cloud connected devices.
  10. At approximately 8:10PM I uninstalled and reinstalled the X1 TV app on my iPhone. I logged in an accepted the terms. The 8PM recording showed up, but showed it as having started late (i.e., I would only be able to watch the portion of the program that was recorded after I reinstalled the app on my phone). Previous recordings still did not show up.
  11. Since then I've been able to watch and download any recordings that were recorded after this whole sequence. My cloud DVR on all devices shows it at about 15% full, with new recordings only. EVEN DEVICES THAT STAYED LOGGED IN, WITHOUT NEWLY ACCEPTING TERMS & CONDITIONS, DO NOT SHOW THE PREVIOUS RECORDINGS.

Clearly at some point in the morning of 9/13 something happened that made the Comcast/X1 servers innacessible and reset all of my devices connected to the cloud, removing access to every program previously recorded.

 

There should be a way for Comcast to reconnect my cloud-connected devices to my previous recordings, which I'm sure still exist in some form in the cloud DVR, since during this sequence of events, my iPhone was able to continue playing the one program I had been watching, even though it showed zero downloads and zero recordings at the time.

Posted by
Problem Solver

Message 8 of 23
980 Views

Sorry for your problems. I know the pain of dealing with Comcast about Cloud DVR issues. I just wanted to pipe in about the nonsense they are telling you about "Accepting the Terms & Conditions" resetting the Cloud DVR. That is the most ridiculous thing I ever heard.  So according to Comcast, if I get a new phone/tablet/computer, and I connect to the XTV portal for the first time, and accept the Terms & Conditions, I end up resetting the whole Cloud DVR from scratch? Yeah right! You know what a nightmare that would be?

 

Trust me, I've uninstalled and reinstalled the Xfinity TV app multiple times and never had it reset.

 

Comcast seems to have a hard time admitting when problems are their fault on the Cloud DVR. I know from experience when I was losing my entire Cloud DVR schedule randomly in the past.

 

I hate to say this, but unless they do some restore of a server backup, I highly doubt your Cloud DVR recordings will come back. But, miracles have happened in the past.

Posted by
Problem Solver

Message 9 of 23
975 Views

Just for kicks, I just uninstalled and reinstalled the Xfinity TV app on my tablet. What I noticed was it asked if I would "Accept the Terms of Activation", which is different than "Terms & Conditions".  I know that is splitting hairs, but are they 2 different things? Not sure where you get the "Terms & Conditions" prompt. Is it something that happens the very first time you go into the Cloud DVR. It's been almost 2 years since I activated mine that I really don't remember.

 

Just thought I would throw that out, and confuse the issue more.

Posted by
Frequent Visitor

Message 10 of 23
964 Views

Terms & Conditions is what the tech support admin who I've been talking to called it. I'm not sure what the actual wording was.

 

But you're right, this makes no sense. I have added new devices many times in the past and I don't remember losing all of my recordings on my other devices. But he is still insisting that is the case:

 

You need to understand that all your devices are pulling information from the same Cloud server so it doesn't matter if one device accepts these terms and others were never signed out. Once those terms are accepted it starts everything over so even devices that weren't signed out are now pulling information from when those terms were accepted again. I'll reiterate that what you had previously is not restore-able. Everything starts over.

 

Posted by
Frequent Visitor

Message 11 of 23
953 Views

I still cannot make heads or tails of what this Admin is saying. I responded to him:

 

This makes no sense. I have added new devices many times in the past, and it did not reset the cloud DVR for all of my other devices. That would mean anytime you bought a new phone and used the app for the first time, for example, every recording that everyone else had access to would disappear. This has not been the case.

He responded:

 

That's because you haven't had to accept those terms for those devices. Term acceptance links with your sign in. All you're doing with other devices is signing in. But again, any device you accept them with starts everything over.

To which I responded:

 

I have no idea what you mean. Are you saying that when I've downloaded and added the app to a new device in the past I DIDN'T have to accept any terms? Because I know that I have had to accept terms when I've added new devices. But you're saying I didn't have to accept terms when using the app on a new device for the first time, but for some reason yesterday I had to accept terms? That makes no logical sense.

Am I being a dunce? Can anyone figure out what he means? To reiterate, many times I have downloaded the app to a new device, or logged in on a new computer, signed in, accepted whatever terms popped up, etc., and this did not cause my entire cloud DVR to be reset to zero on all my other devices. Yesterday, my cloud DVR on all of my devices was reset to zero during some kind of server error on Comcast's part. Later, I tried uninstalling and reinstalling the app on one of my devices. Again, AFTER the server error had removed all of my cloud recordings from all of my connected devices.

 

Am I missing something here?

 

Posted by
Problem Solver

Message 12 of 23
941 Views

Not sure what he means when saying any new device just lets you sign in.  Like I said, I deleted the app completely then reinstalled.  Right after putting in my login credentials it asks me to accept the "Terms of Activation", and afterwards I can still see all my previous recordings. I even tried it in the browser on a new Chrome instance using a new user profile. It too forced me to accept the "Terms of Activation" before I could see my Cloud DVR contents, which were still available. Sounds like you are getting just a bunch of double talk.

 

Ask them if there is a difference between "Terms & Conditions" and "Terms of Activation".

 

Also ask them how does someone force a "Terms & Conditions" reset.

Posted by
Problem Solver

Message 13 of 23
935 Views

Also, according to this article, Activate Your X1 Cloud DVR TV Box, the Terms & Conditions are accepted through the DVR only.  I just looked on my box, and there is nothing under the General Preferences to allow me to "Accept the Terms & Conditions" again.

Posted by
Problem Solver

Message 14 of 23
933 Views

Here is my guess on what happened. Comcast likes to perform account audits periodically to ensure they aren't giving you something for free that they really should be charging you for.  I'm not sure if these audits are automated or manual, but probably something or someone removed the "Cloud DVR rate code" from your account, which caused a purge of your Cloud DVR recordings. Then they realized it was removed in error so they put it back, which was too late at that point. This is all just speculation on my part, but I wouldn't put it past Comcast to make mistakes like this.  I wonder if someone could look at your account record to see if any changes were made recently.

Posted by
Frequent Visitor

Message 15 of 23
932 Views

I think I figured out that the Admin is under the impression that after the server error, I had to activate Cloud DVR on my account as if for the first time. No idea why he thinks this, but this is not even close to the case.

 

He writes:

 

This is how this works:

In order to be able to use X1 Cloud DVR service, a customer must accept the X1 Cloud DVR Terms & Conditions. The customer will see an on-screen pop-up with the Terms & Conditions on their TV box upon first activating their equipment. Existing customer see this within an hour of adding the Cloud DVR rate codes to their account. If the customer has not accepted the terms, they will not be able to start recording content in the cloud.

Customers can also accept the Terms & Conditions from the XFINITY TV app or XFINITY TV website by clicking the I agree to the Terms of Activation box during login.
Customers are required to accept the terms from the mobile app or website every time they log in, even if they already accepted the terms.

What happened with yours goes back to that server error. Due to that error and re-accepting those terms, it was treated as starting it all over. It viewed it as if this was the first time accepting everything so it started everything over.

So to be clear, accepting these Terms from your box starts everything over. This server error treated this the same way. Website and devices still need term acceptance.

I responded:

 

I've been using the cloud DVR service for over two years. Yesterday I did not need to accept any terms on my DVR box. Once the server was working again, I did not need to accept any terms in order to start the app on my phone or computer. It started as normal, except all of my existing recordings were gone, on all of my devices. Again, there was NO acceptance of any terms. I did not need to login again. Nothing was different from normal operation, except that all of the recordings were gone.

Later on, the only terms I accepted were the standard ones you accept when you reinstall the app and login again--NOT any terms as if activating the cloud DVR for the first time. All of which is moot, anyway, because these recordings were gone long before that, from all devices, without ever even having to log in again on any device. I was never logged out from any device when all this happened and I did not have to login once the server was working again. The recordings just disappeared.

So, he seems to misunderstand the entire situation, which brings me back to square one. There was a server error on their end and all of my recordings "disappeared" somehow, and even though a tech support person told me on the phone that he can still see the recordings in the cloud, I cannot access them because... ¯\_(ツ)_/¯

 

"Tier 3" support was supposed to have contacted me yesterday about this. I have not heard anything from them.

 

Needless to say, I am not happy.

Posted by
Problem Solver

Message 16 of 23
930 Views

Wait until a Comcast person asks you why you are relying on the Cloud DVR in the first place (like I was asked in this thread). All I could do was facepalm when I read that.

Posted by
Frequent Visitor

Message 17 of 23
924 Views

Hah, wow. I think the question they should be asking is, "Why are you relying on Comcast in the first place?"

Posted by
Visitor
Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 18 of 23
396 Views

I had same thing happen to me yesterday and am trying to find solution. and came across your thread.  My"cloud"  programs disappeared and old deleted recordings from Last November  (4 months ago) appeared on my recordings list.  What's that about?  I think Comcast servers crashed and everything was lost.  My DVR recordings are fine.  Same as you, my devices are not showing anything.  It works with new recordings like it should.

Posted by
Service Expert

Message 19 of 23
370 Views

DP wrote:

I had same thing happen to me yesterday and am trying to find solution. and came across your thread.  My"cloud"  programs disappeared and old deleted recordings from Last November  (4 months ago) appeared on my recordings list.  What's that about?  I think Comcast servers crashed and everything was lost.  My DVR recordings are fine.  Same as you, my devices are not showing anything.  It works with new recordings like it should.


did you try a different device? or desk/laptop?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Contributor

Message 20 of 23
355 Views

Just a note - the non erase issue is back.  Also after trying to erase a watched show the display listinging freezes with 3 dots and requires exiting and reentering

Posted by
Service Expert

Message 21 of 23
335 Views

applehazar wrote:

Just a note - the non erase issue is back.  Also after trying to erase a watched show the display listinging freezes with 3 dots and requires exiting and reentering


the ghost listings (DVR service is unavailable..) has been around for over a year now. The 3 dots alternating brightness is a new bug probably caused by a fix they were trying to fix the problem we are having with ghost deleted recordings. 

 

if you follow the menu Xfinity >> Device Settings >> Sync DVR it will clear the current ghost settings.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Contributor

Message 22 of 23
333 Views
Posted by
Visitor
Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 23 of 23
271 Views

tried desktop, phones and tablets all lost recorded programs.  working ok now, but just had old recordings that wanted to view on other devices while at gym