Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








no dial tone

Regular Visitor

no dial tone

I do not have dial tone.  If I plug my other phone in (which is working), it looses dial tone in that plug.  I have been on hold four times tonight and get cut off after half an hour each time.  Even when I called the email number to get help in a round about way, I was put on hold and the line went dead.

Frequent Visitor

Re: no dial tone

1. Do you hear a dial tone?
2. Are all phones affected?
3. What do you hear on your receiver?
4. Can you call out but not receive calls, or the other way around?
5. Have you tried calling your home phone from a cellular phone, and was there an error message?

Make sure your response is as complete as possible, as more details will make it easier for us to effectively support you.

Meantime, please check the following items in an attempt to resolve your phone service issue:

1. Check the lights on your eMTA (embedded Multimedia Terminal Adapter):
- Power - should be solid. If not, verify that the eMTA is plugged directly into a working power outlet.
- Online - should be solid. If not, verify if standby mode is on by pushing the standby button.
- Telephone 1 or Telephone 2:
* Should be solid if the phone(s) are on the hook.
* A flashing light indicates a phone is off the hook. Check to make sure all phones are properly hung up.
* If the light is off, you will need to reset the eMTA. It is very simple to reset the eMTA. Please press the reset button located on the back of the unit. Get a pen, paperclip or other pointy object and depress the reset button until you see the lights on the front of the unit go off. Release the reset button and wait for the unit to cycle up.
It may take up to five minutes for the unit to reset. You may also find these instructions through this link:


2. Make sure that all phones are on the hook and that cordless phone batteries are charged.
3. Try to plug a working corded phone into different jacks to find out if the issue is isolated to one phone or jack.
4. Plug the phone directly into your eMTA to determine if the issue may be related to wiring inside your home.
5. If you are experiencing any other type of out of service condition with your telephone line, you may visit this link to view the detailed instructions on how to restore your service:



You will need to visit chat support at http://www.comcastsupport.com/chatentry if none of the above actions restore your phone service so they may troubleshoot in real time. If needed, they can escalate it to the network technicians or schedule a service call.

Regular Visitor

Re: no dial tone

Thanks for your thoughts.  I have now gotten ahold of Comcast.  The problem occured when we upgraded our comcast service and not all lines were connected to the upgrade.  All was working fine until then.

Comcast was unable to fix it in the office. 5 days later you sent out a technician who called into the office to fix it.




Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation