Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








modem fried ?

Regular Contributor

modem fried ?

Am experiencing a variety of symptoms that are progrsively getting worse.

The other day all the lights on the moden started blinking for no apparent reason. Basic phone service still worked but was spotty, called id did not work, calls were prone to be cut off at any time.


Tried resetting it, all the lights still blinked. Today, with no intervention from me, the lights stopped blinking, all are solid except the "link" light which is not on. Now when someone calls, caller id does not work, it will ring once and disconnect, but outgoing calls seem to work fine.

Anything I can try before requesting service ?

Regular Contributor

Re: modem fried ?


update to this problem.

Scheduled a service call, on the day he was supposed to come he called and said it was a general DTE problem that was in the process of being fixed. Phone did start working normally, but only for a short time [hours].

Same symptoms blinking lights, any calls get cut off after 1 ring. So I called again to set up another service call, rep said blinking lights indicate no/low power. I couldn't check the power right then and there and said I'd check it later.

I did, its getting power and all the lights are still blinking on the modem all the incoming calls drop out oafer 1 ring, so I guess I'll try to schedule another appointment.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 0 kudos
  • 1 in conversation