Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,842,334

members

1,529

online

36,211

topics

Top

Again, I have a bad phone service

Regular Visitor

Again, I have a bad phone service

My frustration level is through the roof.  I can't get hold of 'chat' at all to have anyone help.  It took me forever to figure out how to even post to this.  It couldn't be simple like:  phone issues - click here for forums?

 

Anyway, I have white noise on my phone line.  I've checked wires, I've rebooted, its a relatively new phone.  So what next?  Its been ongoing ever since I moved to xfinity from ATT with the phone.  All for $217 a month!!!

 

And evidently its now impossible to get hold of a real live person!

New Poster

Re: Again, I have a bad phone service

Static in your line is usually caused by your internal wiring. The old 2 wire phone lines, not the standard coax. A bad connection, mice nibbling on a wire, an old splice that has corroded or a line loose at a wall jack, even one of the wires coming from the wall to the phone. Also, electrical devices (mivrowaves, fridges, some cell phones) in the home will cause static due to frequencies.
Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 1006 views
  • 0 kudos
  • 2 in conversation