Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,514,136

members

54

online now

1,714,794

discussions

Back to Top

cable box problem

1 REPLY
Posted by
Cable Expert

Member Since: ‎12-31-2004
Posts: 10,676
Message 1 of 2 (783 Views)

Re: cable box problem

This could be caused by a weak signal, which can affect only certain channels. Check the connections to the cable box, especially the incoming coax, and eliminate any unnecessary splitters.

To check signal strength with a Motorola box, tune to the offending channel, turn off the box with the remote, then within two seconds hit "OK/Select." This will bring up the diagnostics screen. Select "Inband Status" (probably page d04) and look for "SNR" for the tuner(s). This value should be in the mid to upper 30s. You may be able to improve the signal strength by adding a signal amplifier to the incoming cable line.

It also may be a weak signal caused by problems outside your house, in which case a call to 1-800-COMCAST to have them send out a tech to check on it may be of benefit.




Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Was your question answered? Mark it as an accepted solution!solution Icon
Did this post help? Why not give it a kudo!!!Kudos Icon
Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Community Icon
I am an XFINITY Forum Expert and I am here to help. Expert Program
Posted by
Edited on
‎06-13-2011 11:16 AM

Regular Visitor
  • Congrats on Posting your first topic!

Member Since: ‎12-18-2009
Posts: 1
Message 2 of 2 (827 Views)

cable box problem

[ Edited ]

My main tv down stairs works perfectly but when the crossover to xfinity happened my upstairs tv with a cable box always says one moment please this channel should be available shortly. The channels never load.  and i have to reset the cable box by unplugging it everytime for it to work. any input?