Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,637,561

members

8

online now

1,815,350

discussions

Back to Top

Turn on closed captioning with Xfinity on SA HD4300 with HDMI connection to TV

SOLVED
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 28
158,217 Views

Before the automatic upgrade to Xfinity I had closed captioning available through the Menu button on the remote. Now, with Xfinity I find no closed captioning option.

 

How do I enable closed captioning?

 

Equipment is Scientific Atlanta HD4300 box connected to Vizio HD TV via HDMI.

 

Comcast support help still has the old pre-Xfinity instructions using the Menu button.

 

 

Here is my non-technical question on this issue:

Why would they disenfranchise the hearing-impaired community by not enabling the closed captioning feature with Xfinity?

27 REPLIES
Posted by
Cable Expert

Message 2 of 28
169,203 Views
Solution

With the TV on, turn off just the cable box with the remote.  Select "Menu" and then enable CC.  Unfortunately, iGuide doesn't provide any other means of enabling CC from the box.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 28
158,204 Views

Thanks, it worked. I did have to select "Guide" not "Menu."

 

It is a very unfriendly workaround, though.

Posted by
Frequent Visitor

Message 4 of 28
157,420 Views

Comcast should upgrade this annoyance of turning the cable box off and then on for CC

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 28
157,133 Views

I agree. This should be able to be done much easier.

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 28
156,848 Views
Posted by
Frequent Visitor

Message 7 of 28
154,938 Views

Thank god I found this!  CC was turned on accidentally & I was going crazy trying to figure out how to turn it off!

 

Comcast, are you listening??

Posted by
Visitor
Message 8 of 28
153,484 Views

" Select "Menu" and then enable CC".

 

Do you do this on the TV or the cable box? If cable box, I ahve a DVR and when I clicl menu, I do not see CC at all.  Thanks

 

Posted by
Bronze Problem Solver

Message 9 of 28
153,391 Views

Ohioboy2 wrote:

" Select "Menu" and then enable CC".

 

Do you do this on the TV or the cable box? If cable box, I ahve a DVR and when I clicl menu, I do not see CC at all.  Thanks

 


On my box you would select menu - then setup - page through the setup menu until you find closed captioning - select it and then select on.

Posted by
Visitor
Message 10 of 28
152,930 Views

If you're watching television on your computer Xfinity only offers a handful of those shows with close captioning. Yeah I think the hearing impaired community is getting shafted by comcast big time!

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 11 of 28
151,936 Views

Okay, this is bloody ridiculous. Why on earth would Comcast not make closed captioning more accessible? If I hadn't stumbled across this help site and persisted with the instructions (which didn't work at first), I'd still be unable to fully enjoy my cable. Dear Comcast - please add a cc button to the remote control if you can't add a cc function to the menu!

Posted by
Frequent Visitor

Message 12 of 28
151,746 Views

I have been in San Diego for 2 weeks watching HDTV supplied by Cox Communications.   One has to push TWO buttons on the remote to turn on or turn off Closed Captions!  Why can't Comcast/Xfinity make something this simple????

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 13 of 28
151,150 Views

This works for me.

 

Comcast Universal Remote:

Press the following sequentially - (think control alt delete)

TV - Power  - Menu (Red button).  Wait a bit - numbers will appear 16 or another number - wait - A list will appear - Click down to enable Closed Caption - Hit Menu (red button) - hit Power 

Now hit All On - You are ready to go

To get rid of enable, go through it again and disable.
Posted by
Frequent Visitor

Message 14 of 28
151,135 Views

Do any Comcast Techies read these concerns and take the hints?

Posted by
Frequent Visitor

Message 15 of 28
151,128 Views

Someone does -- my last (snide) comment was removed.  

 

I have found this site useful; Comcast has paid attention to it in the past:

 

http://www.broadbandreports.com/forum/tvcomcast

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 16 of 28
148,849 Views

I tried to go to CC but the CC was the only thing greyed out.  Any other solutions?

Thanks

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 17 of 28
146,605 Views

I was able to turn it on by following the turn the cable box off instructions.  But when I hit menu, the screen just flashed and turned off. I played with hitting the guide button and the menu button at the same time, and menu then guide and one of these things worked and the screen stayed on.  I then scrolled down to closed caption and "enabled" it.  Then I hit menu again, and the screen went blank.  I hit cable on, and BINGO, the closed captioning was there!  WooHoo!

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 18 of 28
143,853 Views

Yes, but what about when the DVR is currently recording??! You can't turn off the cable box then, so you have to wait until you're done recording to turn on CC. That's stupid. Turning off the cable box is not a incredibly cumbersome "solution". Comcast obviously doesn't care much for the hearing impaired.

Posted by
Bronze Problem Solver

Message 19 of 28
143,811 Views

jdesl wrote:

Yes, but what about when the DVR is currently recording??! You can't turn off the cable box then, so you have to wait until you're done recording to turn on CC. That's stupid. Turning off the cable box is not a incredibly cumbersome "solution". Comcast obviously doesn't care much for the hearing impaired.


On my box you would select menu from the remote - then select setup from the on-screen menu - page through the setup menu until you find closed captioning - select it and then select on

Posted by
Frequent Visitor

Message 20 of 28
143,809 Views

Agree totally.   Cox Communications does it all from the remote.   Comcast should get with it!

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 21 of 28
143,171 Views

Turn all off

1. Turn onlyTV on (still with cable box off)

2. Press cable button

3. Depress red menu button for a short press (don’t hold it down long). Cable box will come on after a few seconds displaying a black on white menu.

4. Scroll to Close Caption then click OK/Select to turn on

5. Press menu.( This will get you out of the menu)

6. Press cable button.

7. Press power button. (Turns on box)

8. Enjoy CC

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 22 of 28
142,635 Views

Thank you! The last post here described accurately what I had to do.
I had to wait until I was no longer recording>

turn off cable box and TV>

turn on TV only>

hit menu on my cable remote>

scroll down to the CC TV option and hit enable>

then turn on my cable box

 

Pre-recorded shows still had subtitles much to my guests ellation...we don't use them for hearing impaired, but for immigrants just learning english. Thanks!

 

Posted by
Frequent Visitor

Message 23 of 28
142,567 Views

NOT a good enough resolution.    It should be able to work with one touch!

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 24 of 28
142,146 Views

manamok wrote:

jdesl wrote:

Yes, but what about when the DVR is currently recording??! You can't turn off the cable box then, so you have to wait until you're done recording to turn on CC. That's stupid. Turning off the cable box is not a incredibly cumbersome "solution". Comcast obviously doesn't care much for the hearing impaired.


On my box you would select menu from the remote - then select setup from the on-screen menu - page through the setup menu until you find closed captioning - select it and then select on



Yeah, that doesn't work with mine. I tried it. It only works by turning off the cable box. It's pretty crappy.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 25 of 28
140,518 Views

Thank you so much for posting this. It was the only thing that worked in this whole thread, for me.

 

I have a hearing issue that makes it possible for me to hear and understand some shows and not others.

Why can't there be a button on the remote that would let me turn it on as needed and back off when the show is done?

 

We can put a man on the moon (at least we did at one time) but we can't do something like this?

Posted by
Frequent Visitor

Message 26 of 28
140,516 Views

Comcast definitely has to get with it.   I posted before that while in CA, Cox Communications (which is comparable to Comcast) only needs one to press one button on the remote!

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 27 of 28
140,000 Views

How do you turn it (closed caption) on with an Olivea 232T12 it was working fine until my new cable install,  please help

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 28 of 28
129,097 Views