Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,725,076

members

13

online now

1,887,085

discussions

Back to Top

Remote - powers TV on and controls sound but won't change channels

SOLVED
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 8
10,292 Views

Hi - I picked up a digital cable box and adapter for 2nd tv yesterday.  Setup went fine except on the primary tv the remote will power on/off the tv and will adjust volumn but will not change the channel.  I changed the batteries in the remote.  I also unplugged the box for 10 minutes and powered back on and still have the same problem.  I went through the remote setup process again with the same results.  The TV is a Philips Magnavox model TS2556 and the code used was 10054.  Any ideas?  There's a Celtics game on tonight so I consider this an emergency!  Smiley Happy

1 ACCEPTED SOLUTION

Accepted Solutions
Posted by
Cable Expert

Message 6 of 8
10,740 Views
Solution

For a RNG100 it must be a platnium remote and not the older sliver remotes. They might have given you the wrong remote.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

7 REPLIES
Posted by
Cable Expert

Message 2 of 8
10,290 Views

No setup should be required in order for the remote to change the channel on the cable box.  You need to press the "Cable" button at the top of the remote to send commands to the cable box.  What box do you have?  Are you able to view the output from the box on the TV?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 8
10,273 Views

Thanks for your reply.  The box is a Cisco RNG100.  I pressed "Cable" at the top of the remote and nothing happens.  Can't even turn the TV on

Posted by
Silver Problem Solver

Message 4 of 8
10,260 Views
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 5 of 8
10,254 Views

I have the silver remote with the red OK button.  I followed the procedures to enter the code last night but did it again just to make sure I did it correctly.  I got the double blink indicating the proper code was entered.  I can still power on/off the TV and adjust volume but cannot change the channel. 

Posted by
Cable Expert

Message 6 of 8
10,741 Views
Solution

For a RNG100 it must be a platnium remote and not the older sliver remotes. They might have given you the wrong remote.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 7 of 8
10,250 Views

Hmmm, well that could explain it.  I'll have to make the 80 min round trip trek to the Comcast office tomorrow to try to exchange it.  Bummer.  Thanks for your help.  I'll report back tomorrow as to whether that did the trick. 

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 8 of 8
10,170 Views

Hi - just had a chance today to exchange my silver remote for the platinum and - voila! - it works perfectly.  Thank you JayINAlg for for the heads up on this.