Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,667,121

members

57

online now

1,838,512

discussions

Back to Top

How do I turn on/off closed captioning?

SOLVED
Highlighted
Posted by
Frequent Visitor
Frequent Visitor
  • Congratulations, you've have started 5 topics! Your communication brings an abundance of information to the community!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 10 of 40
679,258 Views
There seems to be no easy way. Help?!
39 REPLIES
Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 40
86,246 Views

Hi

 

I was trying to get the closed captioning on from my cable box (RNG110) - in vain.

 

I went into the user settings in cable box by pressing "MENU" and switched "ON" the CC. But - still no CC on my TV.

 

I have a Samsung 43" plasma.

 

When I press CC button on my TV remote - it still says "not available".

 

Is there something I am missing?? Thanks. 

Posted by
Silver Problem Solver

Message 2 of 40
86,242 Views

PrasannaSK wrote:

Hi

 

I was trying to get the closed captioning on from my cable box (RNG110) - in vain.

 

I went into the user settings in cable box by pressing "MENU" and switched "ON" the CC. But - still no CC on my TV.

 

I have a Samsung 43" plasma.

 

When I press CC button on my TV remote - it still says "not available".

 

Is there something I am missing?? Thanks. 


Hello,

See the link below to see if this will help

http://customer.comcast.com/Pages/HelpNFC.aspx?id=article-turning-closed-captioning-on-or-off
Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 40
86,234 Views

Thanks. The post says what I already did - pressing the menu button and activating the CC.. I have already done that. 

 

I still am not seeing any closed captions for any programs.

Posted by
Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 40
86,228 Views
Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 5 of 40
86,213 Views

Thanks.

 

Again - its the same link. Please read my original post - I have already done what's given in the link.

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 6 of 40
85,849 Views
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.

Message 7 of 40
86,662 Views

Check to see if "subtitles" are on. (Power->Info). If subtitles are on, closed captions won't work.

 

Makes no sense to me, but that's the way it is.

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 8 of 40
85,696 Views

Thanks... I turned off the subtitles and viola it worked.. 

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 9 of 40
85,567 Views
Posted by
Contributor

Message 11 of 40
679,256 Views

It's a setting on your TV, not cable.  Use the remote that belongs to your TV.  Use your "menu" button to navigate to it.  It should be pretty easy to find.

Posted by
Gold Problem Solver

Message 12 of 40
679,252 Views

If using a cable box with an HDMI cable then captions are decoded by the box -- the caption data is not passed on to the TV.  See http://captionmax.com/blog/2010/08/hdmi-and-the-missing-closed-captions/ for "why", and http://forums.comcast.com/t5/XfinityTV-and-Equipment/Turn-on-closed-captioning-with-Xfinity-on-SA-HD... for how to turn captions on and off with a Comcast box.

Posted by
Official Employee

Message 13 of 40
768,534 Views
Solution

2m3 wrote:
There seems to be no easy way. Help?!

The best way to turn on the Closed Captioning feature depends on what kind of Comcast device and TV you have. We've outlined a few of the different setups to help point you in the right direction.

*Note: Audio connections are not shown in the illustrations below.

 

 

Standard Definition TV with Standard Definition TV Boxes or DTAs:

  • You’ll need to use the Closed Captioning features built into your TV. It is likely that the standard definition TV box or DTA is unable to send and receive Closed Captioning.
    Image shows how to connect TV box or DTA to a standard definition TV via coaxial cable or single yellow RCA cable.

 

 

Standard Definition TV with High Definition TV Boxes (with or without DVR):

  • You can use either the TV box or the TV to turn Closed Captioning on or off. If you accidentally turn Closed Captioning on in both, you'll see a double layer of captions.

Image shows connection between Standard Definition TV box and HDTV using coaxial cable or single yellow RCA cable.

 

 

High Definition TV with High Definition TV Boxes (with or without DVR):

  • You will need to use the TV box. Closed Captioning should be turned off on your TV to avoid the chance of double layers of captions.
    Image shows connection between a high definition set top box and a high definition TV. Connected via HDMI cable or three Component Video cables.

 

 

On High Definition TV with a CableCARD:

  • You’ll need to use the CableCARD device to turn Closed Captioning on or off.
    Image shows connection between CableCARD device and HDTV via HDMI cable or 3 Component Video cables.

 

 

 

Steps to enable and disable Closed Captioning on non-X1 Motorola HD Set Top Boxes:

 

  1. Turn STB off and leave TV on
  2. Press Menu on STB or remote control
  3. Using the down arrow, navigate to Closed Captioning
  4. Press the right arrow to select Enabled or Disabled  

 

 

If you have a Scientific Atlanta or Cisco branded cable box:

 

 

  1. Access the Main Menu by hitting the "Menu" button. 
  2. Using the arrow keys, navigate to Setup and press OK/Select on the remote control.
  3. Navigate to Closed Captioning Setup using arrow keys and press OK/Select. (On some TV boxes, this may be called Subtitle Setup instead. You may have to press the down arrow to navigate to the second menu screen to find this item.)
    Main menu screen. Closed Captioning Setup is the first option in the right-hand row.
  4. Using the remote control, modify the Closed Captioning and Background settings as needed, and press OK/Select to confirm the settings.Closed Captioning and Background Options display.  Both options are toggled to the On setting.
  5. Please refer to the TV manufacturer’s instructions if this does not activate Closed Captioning.

 

If this does not activate Closed Captioning, try the following:
 

  1. To access user settings (where you can manage Closed Captioning), turn OFF your set-top box; it will remain in standby mode.

    1. Press (Guide) on your remote while the set-top box is in standby mode. OR press Channel Up + Channel Down simultaneously on the front panel of the set-top box.
    2. Using the down arrow, navigate to Closed Captioning. Press the right arrow to select Enabled or Disabled  

 

For more information see here:

 

 

https://www.xfinity.com/support/cable-tv/hd-set-top-box-closed-captioning/

 

 

For X1 Boxes see here: 

http://forums.xfinity.com/t5/X1/How-do-I-turn-off-the-CC-closed-captioning/m-p/2394363#M44096

 

 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 14 of 40
645,776 Views

I recently swapped out my old Comcast HD-DVR box (which was about five years old) with Comcast's latest HD-DVR box (as of December 2012).  I hooked up my Sony Bravia TV to the HD-DVR box via the HDMI cable and the closed captioning button on my Sony remote wouldn't work.  I unhooked the HDMI cable and hooked up the analog RCA video/audio cables to the component input on my television.  Using this input, I could get the Sony remote to activate the closed captioning on the non-HD channels but not on the HD channels.  Leaving the RCA cables in place, I re-hooked up the HDMI cable from the HD-DVR box to the HDMI input on the TV.  If I select the HDMI input from the Sony remote, the closed captioning doesn't work on any channels.  If I select the component input from the Sony remote, the closed captioning works on all channels.  You have to have the HDMI cable connected from the box to your TV, you have to have the RCA video/audio cables (there are five RCA plugs, three for video and two for audio) hooked up from the box to the TV component input, and you have to select the component input and watch TV from that input if you want to use the closed captioning you're used to seeing.  It sounds complicated but once you have it hooked up, it's just a matter of changing your video input when you want to see closed captioning.  I'm Larry Gentry on facebook if you need help.

Posted by
Silver Problem Solver

Message 15 of 40
645,689 Views

On Motorola-based boxes updated to A30 software, you an now turn CC on and off from the main menu, and change the CC background between black and clear. More detailed settings still require the power-off/MENU method if you want to change fonts, color, etc...

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 16 of 40
642,626 Views

The software on my Motorola DCH3416 is ver: 78.53-A28p0-4.1005.r-8. I called Comcast and asked about A30 software. Was unable to get a satisfactory answer. Is this A30 software available nationwide or just in certain areas? Do I have to ask for it or is it an automatic upgrade?

Posted by
Silver Problem Solver

Message 17 of 40
642,582 Views

Your box will be updated automatically when they make it available in your area. They roll it out slowly at first as other back-end features may need updating first.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 18 of 40
635,805 Views

go to menu on the cable box go to main menu

then select setup

then closed captioning setup 

and turn it off you can do it all the the remote 

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 19 of 40
82,598 Views

When I have Vizio TV on, RNG110 on and hit INFO, I get ONLY HDMI1, not anything else, and Analog and Digital CC greyed out.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 20 of 40
82,590 Views

Seems goofy, but leave TV ON, turn Comcast unit OFF, then hit "menu" on Comcast (yes I know unit is off) and there will be ANOTHER menu that pops up on TV screen. Scroll down menu to "closed caption" and turn ON. Simple, but EVERYONE I talked to at Comcast support was unaware. They kept telling me that I should go to menu in my TV but it is really menu in the Comcast unit. They kept telling me it was problem with my TV. It is working fine now....VERY frusterating. Note that the way I found this out is that it is on YOUTUBE (Comcast tech support should look at it)

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 21 of 40
82,570 Views

Thanks a lot!!!!  FINALLY an answer that works. REALLY appreciative. It now works with Close Caption.

 

Great that you posted.

 

 

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 22 of 40
619,338 Views

yea there is no "easy" way, like a button on the remote (you know like the CC button on ALL my TV remotes).

 

PLEASE COMCAST add the feature as a button that is available on almost any tv remote.

Also please forward the CC signal to the TV so my TV can do it natively (and better) 

 

The "switch off box - enable cc" feature is ridiculous, and the "subtitle menu" is not reachable while watching on-demand shows (or enlighten me how).

 

Sometimes i just want to enable cc for a few sentences but it's soo hard to use.

And btw, it's not just for people who don't hear, i use it to understand some UK English shows.

 

 

Posted by
Silver Problem Solver

Message 23 of 40
619,208 Views

If you use an SD output, then CC is sent. The problem is that there isn't a standard for transmitting CC over component or HDMI outputs.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 24 of 40
605,051 Views

But when I turn my STB off, my TV goes off, too.  I didn't hook this all up, I'm just trying to get rid of the closed captions!

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 25 of 40
605,047 Views
Posted by
Official Employee

Message 26 of 40
604,983 Views

InigoJones wrote:

But when I turn my STB off, my TV goes off, too.  I didn't hook this all up, I'm just trying to get rid of the closed captions!


Apologies for this issue. I can see that you have a Motorola cable box but not sure entirely of the model number.

 

I can also see that there is an open ticket on your account that is being worked for this situation. Thanks for your patience. 

You are able to turn the cable box OFF using the power button located on the front panel of the box while leaving the TV set ON.  

Also, how is the TV connected to the cable box? HDMI? Component cables? Coaxial cables?  

Steps to enable and disable CC on Comcast STBs:

 

Motorola HD Set-Top Boxes 

  1. Turn STB off and leave TV on
  2. Press Menu on STB or remote control
  3. Using the down arrow, navigate to Closed Captioning
  4. Press the right arrow to select Enabled or Disabled  

 

Also, you can try this:

To modify the Closed Captioning settings:

  1. Access the TV Guide Main Menu (press Menu twice on the Comcast silver remote control)
  2. Using the arrow keys, navigate to Setup and press OK/Select 
  3. Using the arrow keys, navigate to Closed Captioning Setup and press OK/Select
     
     
  4. Using the remote control, modify the Closed Captioning and Background settings as needed and press OK/Select to confirm the settings
     
     
  5. Additional settings such as Font size, Color, Service selection, etc. still require accessing through the set top box diagnostics menu (accessed by pressing the power key to turn the set top box off and then followed by pressing the menu key on the set top box).

    Note: This feature is only available for HD and HD-DVR STBs. Standard Definition Boxes must continue to use the Closed Captioning feature built into their TV.

If the above doesn't work or you have a non-HD cable box, the closed captioning may be showing from your TV set (not the cable box). Locate your remote control for your  TV set (not the Comcast remote)and check the TV's menu setting or closed captioning settings.

 

I hope that works for you. 

 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 27 of 40
603,135 Views

Thank You for your input, very inlightling.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 28 of 40
579,285 Views
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 29 of 40
81,220 Views

I cannot get closed captioning to come on.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 30 of 40
81,214 Views
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 31 of 40
526,646 Views

I just had the same problem on the new version of the cable box with the updated Comcast software. Very simple. Hit the Menu button (the one that says xfinity in red). Go to the last icon for settings. Go to Device Settings and you will see that Closed Captioning is the first choice. You toggle on/off. 

Posted by
Visitor
  • Congrats on Posting your first topic!

Message 32 of 40
78,391 Views

I would like to know if there is a way to maybe reprogram the X1 remote so I can easily get to closed captioning, instead of going to the infinity button, then settings, then device setting, then to turning on closed captoning?

Posted by
Gold Problem Solver

Message 33 of 40
78,375 Views

Press the down arrow once the press OK.


Pursuant wrote:

I would like to know if there is a way to maybe reprogram the X1 remote so I can easily get to closed captioning, instead of going to the infinity button, then settings, then device setting, then to turning on closed captoning?


 

Posted by
Regular Contributor

Message 34 of 40
78,323 Views

Pursuant wrote:

I would like to know if there is a way to maybe reprogram the X1 remote so I can easily get to closed captioning, instead of going to the infinity button, then settings, then device setting, then to turning on closed captoning?



It's here...

http://customer.xfinity.com/help-and-support/cable-tv/x1-closed-captioning/

 

Comcast has done a decent job with online help and support.  I highly recommend it.

 

By the way, I found this in a few seconds with a search of "X1 remote closed captioning" in Google.

Posted by
Visitor
  • Congrats on Posting your first topic!

Message 35 of 40
76,268 Views

How to turn close captions off?

Posted by
Service Expert

Message 36 of 40
76,255 Views

WesternFlyer wrote:

How to turn close captions off?


Take a look here: http://customer.xfinity.com/help-and-support/cable-tv/enable-closed-captioning/

Or here if you have X1 : http://customer.xfinity.com/help-and-support/cable-tv/x1-closed-captioning




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Visitor
  • Congrats on Posting your first topic!

Message 37 of 40
57,257 Views

how do i disable closed caption for my remote.

Posted by
Service Expert

Message 38 of 40
57,208 Views

donmariny wrote:

how do i disable closed caption for my remote.


Take a look here:  http://customer.xfinity.com/help-and-support/cable-tv/enable-closed-captioning/

 

Or here if you have X1 :  http://customer.xfinity.com/help-and-support/cable-tv/x1-closed-captioning




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Visitor
  • Congrats on Posting your first topic!

Message 39 of 40
50,793 Views

how do you shut off closed caption

Posted by
Service Expert

Message 40 of 40
50,780 Views

cgarand wrote:

how do you shut off closed caption


Take a look here:  http://customer.xfinity.com/help-and-support/cable-tv/enable-closed-captioning/

 

Or here if you have X1 :  http://customer.xfinity.com/help-and-support/cable-tv/x1-closed-captioning




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon