Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,637,069

members

49

online now

1,814,921

discussions

Back to Top

why does xfinity home page load twice

Posted by
Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 1 of 7
1,851 Views

when I booth up my home page loads, and then loads again,very annoying and slow?

6 REPLIES
Posted by
Service Expert

Message 2 of 7
1,824 Views

schlo1901 wrote:

when I booth up my home page loads, and then loads again,very annoying and slow?


Have you checked wihin your browser to ensure you only have one entry for startup?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 7
1,741 Views

yes ,only one home page.

 It starts to load  half way then reloads the rest

Posted by
Regular Contributor

Message 4 of 7
896 Views

I posted about this loading issue and just saw it here again. Sorry to double post but I did not begin the thread, I just replied to a post. I have the same issue.

I use both Chrome and Edge and it does load twice with both.

My machine runs Windows 10 Pro without issue except for this.

I have a feeling it is fine for those who use MSIE which I consider dated.

Comcast is slow; I use my daughter's machine and verizon is faster. I cannot get it here, however.

Posted by
Service Expert

Message 5 of 7
890 Views

schlo1901 wrote:

yes ,only one home page.

 It starts to load  half way then reloads the rest


Okay, so it's not loading the page twice [two tabs], it just stalls before finishing loading.

 

Depending on what level of Internet connection you have it may load slowly since the page is graphic and video intensive.

 

My homepage loads very slowly because of the number of photos and blog posts I have on it [wordpress], and it also stalls like what you're describing.

 

You're free to use any webpage as a homepage; you don't have to use Comcast's homepage.  If you use webmail you can either login to webmail and then bookmark it [every time you go to webmail you'll have to login] or you can use an email client such as Thunderbird, bypassing webmail all together.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 7
863 Views

thanks 4 the correction in my question. thanks 4 the reply, sounds right to me.

Posted by
Visitor
Message 7 of 7
298 Views

What you describe is exactly what I am now experiencing.  The strange thing is that I have not changed my Xfinity Router or computer in the last year, but in the last 2 months I am now dealing with the slow loading of some pages (I'm guessing non-cached ones, but that is just a hypotheses), and the "hanging" of some web pages as they try to load (I have an Apple Macbook pro using Safari), and sometimes (less often) I also now notice the "double loading" of webpages.

 

What I'm trying to figure out is...

 

A) could my Xfinity SMC Router require a firmware updgrade to help alleviate this issue (and if so... can I do that myself or does Comcast force update Xfinity routers from their mothership?)

 

Could this poor performance the last 2 months simply be down to Comcast/Xfinity itself (poor bandwidth throughput in my local area) and nothing to do with my home set up?

 

C) Could my internal DNS settings on my MAC be set incorrectly/improperly?  Is there a specific Comcast/Xfinity DNS entry that is better than others that I could apply in my "System Preferences"

 

If the answer is likely "B" from above, does anyone have any advice on the best way to request Comcast improve their bandwidth to my local area?

 

thanks!