Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,744,621

members

71

online now

1,903,858

discussions

Back to Top

Received a Soap fault from ESP Payment Service (SH500.33)

New Poster

Received a Soap fault from ESP Payment Service (SH500.33)

I get this trying to pay my bill this morning.    

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

i am also getting "Received a Soap fault from ESP Payment Service (SH500.33)" have not been able to pay my bill

 

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Been getting this message since October 16th 2016 and I don't understand I'm just like everyone else I can't even pay my bill because I always pay my bill online and I'm kind of scared at this point. OMG what is a girl to do?!!!!!!
New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

I re-added my payment method and it worked.
New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Contacted tech support and they have no Idea what this fault is or how to fix it The old web site worked great, first the TV listings quit working now I can't pay my bill on-line and I'm having trouble with my email. I don't know the fix might be to get verizon which I don't like

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hey, did you get any more information on why that error occurs? I'm experiencing the same thing.

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Just received this message trying to pay my bill online. Apparently this has been going on for months and is still not fixed. Typical for Comcast. Comcast, are you listening?

Tags (1)
New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

I just experienced the same problem.  For what it's worth I had success submitting my payment by reentering my debit card number without any spaces.

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Indeed. Comcast's example of a card number shows spaces between each group of 4 numbers. Do NOT enter these spaces. Just use 16 continuous integers and the fault goes away.

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

I Get the same msg. How can i pay my bill to online to comcast ?

Visitor

Re: Received a Soap fault from ESP Payment Service (SH500.33)

BIG thanx!

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

I received the same code while trying to pay my bill using CHROME. I switched to I.E. and my payment went through fine the first time I tried. 

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

I got the same thing. Called Comcast and talked to tech for 40 minutes, he couldn't fix it, gave me a ticket# and said I would get a call back. 24 hours later no call back so I tried again, no luck. I then tried no spaces on cc#, payment went through, funny thing is I wasn't using spaces when I got the fault so I was trying spaces with no luck, I had this problem before and they downloaded upgrades to my modem and it worked, this time it didn't. Can't wait till next month's payment....LOL

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Even though the field format shows they accept spaces in the card number, it's definitely the spaces causing the issue!  I just had the same thing and it work when I removed the spaces.

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Received a Soap fault from ESP Payment Service (SH500.33) .....If they need us to re-enter our payment information then they shouldn't have allowed it to transfer to begin with!!!

I have been dealing with this issue for several months and not once have I seen an admin respond to this and the "billing support" is a joke.

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

"SH500.33: Received a Soap fault from ESP Payment Service"

SOAP is an old crappy API protocol. This is a terrible error message written by engineers who don't give a darn about users.

 

I'm trying to set up autopay. I'm trying to GIVE COMCAST MONEY. And I'm getting this useless frustrating error, now in 2017. And I'm not the first user to run into this, yet nobody from Comcast pitched in. Why do they even have this joke of a support forum?

 

[POST edited for circumventing the language filters]

Official Employee

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hi FlyingCloud, apologies for your experiences.  If you are still needing assistance I can review this further for you and will send you a private message to further assist.

 

Thank you




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hi, im having the same issue as flying cloud, im trying to set up my autopay payment method, but i got SH500.33: Received a Soap fault from ESP Payment Service. i want to know how to fix this.

Official Employee

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hi, luissbruni - Your current account didn't have any username associated with it. I migrated your username from your old account to the current one. Please try to sign out/in and let me know if you have any issues. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hi,

 

I am also getting the same error while setting up automatic payment.

https://customer.xfinity.com/#/settings/bill/autopay.

 

thanks,

Tapan

Official Employee

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hi tapan_gupta! I can help with this issue. I need to verify the email address you are using to log in. Please send me a private message verifying the first and last name of the account holder, and the street address associated with your services. To send a private message click on my name "ComcastChe", then click private message me. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

I am having the same issue. Very frustrating! 

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

I received the same error, i mistook a 3 for an eight when i corrected it, it went through

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

I had the same issue. Moreover, I removed the payment and added back again, I also got "Error while submitting: Received a Soap fault from ESP Payment Service". Can someone help?

 

New Poster

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hi can you please help me make sure my autopay is set up correctly? I recently moved my service to a new address and ported my username over the new account. When I go to billing, it says automatic payments is enabled and shows that my only linked checked account, but will not let me associate it with the automatic payment (it says "Payment method not available."). I keep getting a "SH500.20: Received a Soap fault from ESP AMS" error message when I click the checking account and the update button. I'm concerned my auto pay will not go through as planned.

 

Please help.

 

 

 

Official Employee

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hi tws5! Are you still receiving this error when attempting to make a payment? 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Official Employee

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hi sfreedland. I can understand your billing concerns. Can you please verify if you are still receiving this error? 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Official Employee

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hey Ben1985. Can you confirm if you are still getting this Soap error? 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Official Employee

Re: Received a Soap fault from ESP Payment Service (SH500.33)

Hey paulo500! Thanks for confirming how you were able to get the issue resolved on your end. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon