Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,663,647

members

78

online now

1,835,825

discussions

Back to Top

Received a Soap fault from ESP Payment Service (SH500.33)

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 21
13,106 Views

I get this trying to pay my bill this morning.    

20 REPLIES
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 2 of 21
13,070 Views

i am also getting "Received a Soap fault from ESP Payment Service (SH500.33)" have not been able to pay my bill

 

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 21
13,019 Views
Been getting this message since October 16th 2016 and I don't understand I'm just like everyone else I can't even pay my bill because I always pay my bill online and I'm kind of scared at this point. OMG what is a girl to do?!!!!!!
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 4 of 21
12,815 Views
I re-added my payment method and it worked.
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 21
12,317 Views

Contacted tech support and they have no Idea what this fault is or how to fix it The old web site worked great, first the TV listings quit working now I can't pay my bill on-line and I'm having trouble with my email. I don't know the fix might be to get verizon which I don't like

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 21
11,148 Views

Hey, did you get any more information on why that error occurs? I'm experiencing the same thing.

Posted by
Visitor
  • Congrats on Posting your first topic!

Message 7 of 21
10,621 Views

Just received this message trying to pay my bill online. Apparently this has been going on for months and is still not fixed. Typical for Comcast. Comcast, are you listening?

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 21
9,886 Views

I just experienced the same problem.  For what it's worth I had success submitting my payment by reentering my debit card number without any spaces.

Posted by
Visitor
Message 9 of 21
9,637 Views

Indeed. Comcast's example of a card number shows spaces between each group of 4 numbers. Do NOT enter these spaces. Just use 16 continuous integers and the fault goes away.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 10 of 21
9,309 Views

I Get the same msg. How can i pay my bill to online to comcast ?

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 11 of 21
8,773 Views
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 12 of 21
7,730 Views

I received the same code while trying to pay my bill using CHROME. I switched to I.E. and my payment went through fine the first time I tried. 

Posted by
Visitor
Message 13 of 21
7,193 Views

I got the same thing. Called Comcast and talked to tech for 40 minutes, he couldn't fix it, gave me a ticket# and said I would get a call back. 24 hours later no call back so I tried again, no luck. I then tried no spaces on cc#, payment went through, funny thing is I wasn't using spaces when I got the fault so I was trying spaces with no luck, I had this problem before and they downloaded upgrades to my modem and it worked, this time it didn't. Can't wait till next month's payment....LOL

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 14 of 21
6,700 Views

Even though the field format shows they accept spaces in the card number, it's definitely the spaces causing the issue!  I just had the same thing and it work when I removed the spaces.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 15 of 21
4,643 Views

Received a Soap fault from ESP Payment Service (SH500.33) .....If they need us to re-enter our payment information then they shouldn't have allowed it to transfer to begin with!!!

I have been dealing with this issue for several months and not once have I seen an admin respond to this and the "billing support" is a joke.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 16 of 21
1,052 Views

"SH500.33: Received a Soap fault from ESP Payment Service"

SOAP is an old crappy API protocol. This is a terrible error message written by engineers who don't give a darn about users.

 

I'm trying to set up autopay. I'm trying to GIVE COMCAST MONEY. And I'm getting this useless frustrating error, now in 2017. And I'm not the first user to run into this, yet nobody from Comcast pitched in. Why do they even have this joke of a support forum?

 

[POST edited for circumventing the language filters]

Posted by
Official Employee

Message 17 of 21
954 Views

Hi FlyingCloud, apologies for your experiences.  If you are still needing assistance I can review this further for you and will send you a private message to further assist.

 

Thank you




Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 18 of 21
832 Views

Hi, im having the same issue as flying cloud, im trying to set up my autopay payment method, but i got SH500.33: Received a Soap fault from ESP Payment Service. i want to know how to fix this.

Posted by
Official Employee

Message 19 of 21
647 Views

Hi, luissbruni - Your current account didn't have any username associated with it. I migrated your username from your old account to the current one. Please try to sign out/in and let me know if you have any issues. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 20 of 21
306 Views

Hi,

 

I am also getting the same error while setting up automatic payment.

https://customer.xfinity.com/#/settings/bill/autopay.

 

thanks,

Tapan

Posted by
Official Employee

Message 21 of 21
70 Views

Hi tapan_gupta! I can help with this issue. I need to verify the email address you are using to log in. Please send me a private message verifying the first and last name of the account holder, and the street address associated with your services. To send a private message click on my name "ComcastChe", then click private message me. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon