Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,637,627

members

34

online now

1,815,420

discussions

Back to Top

News videos do not play

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 1 of 4
739 Views

Why don't the news videos play?  And why does Xfinity not help?  This has been going on for a long while....recently have a new PC and also new laptop, Win 10, Google Chrome...still not working, only hear audio.

3 REPLIES
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 2 of 4
716 Views

GrammyLou I am having the same problem and it sure is frustrating. Hope someone can help us soon!

Posted by
Valued Contributor

Message 3 of 4
503 Views

I'm having the same problem on ny Mac.

Posted by
Valued Contributor

Message 4 of 4
74 Views

Still no videos! When is Comcast going to fix this!!! I'm on a MacBook Pro, 10.12.4 OS. This has been going on way too long! It's not just the News videos-- it's all of them! I have tried every fix suggested in several forums. Nothing works.